Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]Magic Assistant - amd64 - failing to run
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Mon May 14, 2012 9:47 am    Post subject: [Solved]Magic Assistant - amd64 - failing to run Reply with quote

Magic Assistant, a java app, used to work on my amd64 system (64 bit).
Now it doesn't. It's been a while since I ran it.
Inititally, it appeared I was missing env variable MOZILLA_FIVE_HOME, which I set to /usr/lib64/firefox, not knowing if this is correct or not, but now, I see the following stack trace in workspace/.metadata/.log
I was hoping someone may be able to offer some insight into what is wrong.
I am currently running firefox 12 on my fully patched up Gentoo system (with only a few ~amd64 packages).
My Java VM is sun-jdk-1.6
Code:
!ENTRY org.eclipse.osgi 4 0 2012-05-14 19:10:04.869
!MESSAGE Application error
!STACK 1
org.eclipse.swt.SWTError: XPCOM error -1041039104
   at org.eclipse.swt.browser.Mozilla.error(Mozilla.java:2502)
   at org.eclipse.swt.browser.Mozilla.initFactories(Mozilla.java:1764)
   at org.eclipse.swt.browser.Mozilla.create(Mozilla.java:757)
   at org.eclipse.swt.browser.Browser.<init>(Browser.java:99)
   at com.reflexit.magiccards.ui.views.card.CardDescComposite.<init>(CardDescComposite.java:83)
   at com.reflexit.magiccards.ui.views.card.CardDescView.createPartControl(CardDescView.java:238)
...

_________________
...Lyall


Last edited by lyallp on Sun Jul 15, 2012 8:25 am; edited 1 time in total
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1400
Location: Adelaide/Australia

PostPosted: Sun Jul 15, 2012 8:25 am    Post subject: Reply with quote

Well, I think I found the problem.

Magic Assistant would appear to require xulrunner, as per it's download page. Xulrunner is something that has gone by the wayside quite some time ago.

I found that the zugaina overlay appears to have an ebuild for xulrunner and I had to google for and manually download the required source firefox-3.5rc3-source.tar.bz2, placing it in my portage distfiles directory.

Installing xulrunner would appear to have solved my problem.
_________________
...Lyall
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum