Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
WARNING: sqlite-3.7.12 causes *my* gnome-shell to segfault
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Wed May 16, 2012 10:41 pm    Post subject: WARNING: sqlite-3.7.12 causes *my* gnome-shell to segfault Reply with quote

I am running an (~x86) system.

Just updated my system and noticed gnome-shell segfaults, meaning I can't load the desktop.
Initially after the "Oh no" fail whale, I thought it may have something to do with extensions, so I disabled them all, but no luck.
So I checked dmesg and noticed gnome-shell was segfaulting with sqlite3.
The recent update included sqlite.
So I resolved the problem by downgrading sqlite to 3.7.11
Now I can load gnome-shell without any problems.
In fact, it has just occurred to me, would a revdep-rebuild have resolved this?

EDIT: Ok, just performed an update to sqlite-3.7.12 (again) then ran revdep-rebuild to see if it picked up anything, but no.
So I suppose I am answering the question above. revdep-rebuild did not spot the problem.

emerge --info below. (although I am not looking for solutions as my system is working again)
Code:
Portage 2.1.10.60 (default/linux/x86/10.0/desktop/gnome, gcc-4.5.3, glibc-2.14.1-r3, 3.3.4-gentoo i686)
=================================================================
                        System Settings
=================================================================
System uname: Linux-3.3.4-gentoo-i686-Pentium-R-_Dual-Core_CPU_E5400_@_2.70GHz-with-gentoo-2.1
Timestamp of tree: Tue, 15 May 2012 23:00:01 +0000
app-shells/bash:          4.2_p28
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.6.8, 2.7.3-r2, 3.1.5, 3.2.3-r1
dev-util/cmake:           2.8.8-r2
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1
sys-apps/openrc:          0.9.9.3
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.9.6-r3, 1.10.3, 1.11.5
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.4.7, 4.5.3-r2
sys-devel/gcc-config:     1.7.1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.3 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo gamerlay-stable spring OVERLAY-pigs_overlay
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA AdobeFlash-10.3 dlj-1.1 Oracle-BCLA-JavaSE PUEL ut2003"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=native -O2 -pipe -fomit-frame-pointer"
DISTDIR="/mnt/nfs_portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles metadata-transfer news parallel-fetch parse-eapi-ebuild-head protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr"
FFLAGS=""
GENTOO_MIRRORS="http://mirror.bytemark.co.uk/gentoo/ http://mirror.qubenet.net/mirror/gentoo/ http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/ http://gentoo.virginmedia.com/"
LANG="en_GB.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en_GB"
MAKEOPTS="-j3"
PKGDIR="/mnt/nfs_portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/mnt/nfs_portage"
PORTDIR_OVERLAY="/var/lib/layman/gamerlay /var/lib/layman/Spring /usr/local/portage"
SYNC="rsync://pig2/gentoo-portage"
USE="X X509 a52 aac acl acpi additions alsa animation-rtl antialiasing apache2 applet archive artworkextra autoipd berkdb binary-drivers bluetooth bonobo branding bzip2 cairo caps cdaudio cdda cdio cdr cdrkit cdrom cdrtools cg cifs cleartype cli client clutter colord consolekit cracklib crypt cups curl curlwrappers cursors cxx dbase dbus dconf desktop-effects device-mapper dga dns dri dso dts dv dvb dvbpsi dvd dvdnav dvdr dvdread eds effects emboss encode equalizer evo exif extraicons extras fallback fam fat fat16 fbcondecor fbosd fbsplash ffmpeg fftw firefox fits flac flash fltk flv fontconfig foomaticdb fortran ftp fuse g3dvl games gcj gconf gd gdbm gdm gdu gedit geoloc gif git gjs glade glib glitz glx gmedia gnome gnome-dvb-daemon gnome-keyring gnome-online-accounts gnome-print gnome-shell gnomecanvas gnomecd gnutls gphoto2 gpib gpm gps graphviz grub gstreamer gtk gtk3 gtkhtml gtkstyle gudev h224 hardware hddtemp help-screen hibernate-script hidd howl-compat hpn htsp http httpd i2c icc icons iconv id3 id3tag idn ieee1394 imagemagick imap inotify introspection ipc iplayer iptables ipv6 ivman jack java java6 javascript jit jpeg jpeg2k json kdrive kerberos keymap lame laptop lastfm lastfmradio lcms ldap libburn libgda libmpeg2 libnotify libsamplerate libsexy libsoup libv4l2 libvisual lm_sensors logrotate lzo mad mailwrapper mbox mdnsresponder-compat metadata mime mms mmx mmxext mng modplug modules mono mozilla mp2 mp3 mp4 mpd mpeg mpg123 mplayer msn mudflap nautilus ncurses net network networking networkmanager new-login nfs nfsv3 nfsv4 nls nptl nsplugin nss ntfs ntp nvcontrol nvram objc offensive ogg openal opengl openmp openstreetmap optimization osc oss outputs overlays pam pango parted pcre pdf perl pipechan pixmaps player playlist plugins pm-utils pmu png policykit ppds pppd previewer pulseaudio pvr pypy1_8 pyqt4 python python-daap quicktime quvi raw readline rss rsync rtsp sasl scrobbler sctp sdl search-screen sendto server session sftp shaders sharedext sharedmem shm shmvideo shotwell showtabbar sid sip slideshow slp smi smp smtp sndfile snmp socialweb sockets sound spell splash sql sqlite sse sse2 sse3 ssh ssl ssse3 startup-notification svg swf symlink syslog sysvipc taglib tcpd tdb teletext terminal tetex themes theora tiff tk toolbar tools tordns totem tracker transcode truetype tvheadend twisted twolame type3 udev udev-acl udisks underscores unicode unsupported upnp upower usb userpriv v4l v4l2 v8 vaapi vala vdpau vfat vga vhook video videos virtualbox vnc vorbis wav wavpack weather webdav webgl win32codecs wma wmf wmp wxwidgets x264 x86 x86emu xattr xcb xcomposite xcursors xf86 xine xml xorg xosd xpm xrandr xrender xulrunner xv xvid xvmc youtube yv12 zlib" ALSA_CARDS="emu10k1 hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="auth_digest authn_file authz_groupfile authz_host dav dav_fs dir mime status" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CURL_SSL="nss" DVB_CARDS="usb-dtt200u usb-wt220u" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="pc" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en_GB" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS

=================================================================
                        Package Settings
=================================================================

dev-db/sqlite-2.8.16-r5 was built with the following:
USE="nls -doc -tcl"
CFLAGS="-march=native -mmmx -msse -msse2 -msse3 -mmmx -O2 -pipe -fomit-frame-pointer"
CXXFLAGS="-march=native -mmmx -msse -msse2 -msse3 -mmmx -O2 -pipe -fomit-frame-pointer"


dev-db/sqlite-3.7.11 was built with the following:
USE="extensions fts3 readline threadsafe -debug -doc -icu -secure-delete -soundex -tcl -test -unlock-notify"

_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
feigeb
n00b
n00b


Joined: 18 May 2012
Posts: 2

PostPosted: Fri May 18, 2012 2:53 pm    Post subject: Reply with quote

Hi,

I've got the same problem, also on ~x86. I tried to track down the problem but no luck. /var/log/messages says:

Quote:
kernel: gnome-shell[12607]: segfault at 54 ip b567de65 sp bfce1dc0 error 4 in libsqlite3.so.0.8.6[b5632000+ab000]


twice in a row, always directly after
Quote:
goa[12689]: goa-daemon version 3.2.1 starting
.
There is no direct sqlite3 usage in gnome-shell; gnome-shell is actually linked with libsqlite3.so.0 but I suspect its inclusion comes through libsoup.

I thought some erroneous sqlite3 db somewhere could be the cause but strace did not indicate any sqlite file opened - then I even renamed the whole home directory so that I started with a totally clean environment and still got the same error. Could it be that an in-memory sqlite db is created to accumulate calendar / user presence info and such?

Next would be to file a bug report I think. It might all be due to the current heavy changes towards gnome 3.4 though...

Best regards,
Bernd
Back to top
View user's profile Send private message
Genfoo'
Tux's lil' helper
Tux's lil' helper


Joined: 24 Feb 2004
Posts: 112

PostPosted: Sat May 19, 2012 12:19 am    Post subject: Reply with quote

Thank you for this!

I was having the same problem for the past two days. I was looking through various log files and trying to install older versions of packages to fix this. I would have never figured out sqlite was to blame.

I feel stupid that i didn't try dmesg first.
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 439
Location: Maryland, US

PostPosted: Sun May 20, 2012 3:14 am    Post subject: Reply with quote

Thanks as well Thistled..

I had the exact same issue with my gnome-shell too. After using genlop to figure out which updated packages were installed prior to the reboot that brought me the gnome-shell "Oh No.." failed login message, I had it narrowed down to 14 packages, one of which was dev-db/sqlite-3.7.12. After reading your post, and downgrading to dev-db/sqlite-3.7.11, everything is back to normal. BTW, here was my dmesg error message that pointed to sqlite;
Code:
gnome-shell[2991] general protection ip:7ff1e089390a sp:7fffb6e7bb80 error:0 in libsqlite3.so.0.8.6

Anyway, I don't know if others will hit this sqlite/gnome-shell problem, but if they do, this thread may be easier found in Desktop Environments. Searching either the Gentoo forums, or the internet, for the error generated in .xsession-errors by this problem;
Code:
gnome-shell-calendar-server[3096]: Got HUP on stdin - exiting
gnome-session[2924]: WARNING: App 'gnome-shell.desktop' respawning too quickly
gnome-session[2924]: WARNING: Application 'gnome-shell.desktop' killed by signal

will lead one totally away from the real cause, including the top 5 Gentoo Forum threads from this Google search.

On a side note, I had initially complicated things for myself by performing an unrelated emerge --emptytree @world soon after the update mentioned above. While the updated dev-db/sqlite-3.7.12 didn't cause any package build errors, an update of dev-libs/fribidi-0.19.2-r2, (updated in the same world update that included dev-db/sqlite-3.7.12), left me with the following packages unable to emerge on my system;
Code:
media-video/dvdauthor-0.7.0
app-text/fbreader-0.12.10
app-cdr/backlite-1.0.3

because of this closed bug. After also rolling it back to dev-libs/fribidi-0.19.2-r1, the aforementioned packages emerged cleanly.

Thanks again..
Back to top
View user's profile Send private message
feigeb
n00b
n00b


Joined: 18 May 2012
Posts: 2

PostPosted: Sun May 20, 2012 10:20 am    Post subject: Reply with quote

Note: There is a gentoo bug, filed against gnome-shell 3.4 but potentially related: https://bugs.gentoo.org/show_bug.cgi?id=416563
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 439
Location: Maryland, US

PostPosted: Sun May 20, 2012 1:43 pm    Post subject: Reply with quote

Bernd,

Thanks for adding that it also happens to gnome-shell-3.2.2.1 in the bug report.

Jason
Back to top
View user's profile Send private message
Thistled
Guru
Guru


Joined: 06 Jan 2011
Posts: 548
Location: Scotland

PostPosted: Sun May 20, 2012 2:16 pm    Post subject: Reply with quote

No probs.
It's the first thing I do when spotting any "loading up" errors in Gentoo, is check dmesg.
Everyone should get to know the power and helpfulness of dmesg.
Looks like Alexandre is on the case with the bug reporting.
Out of interest, would sqlite have something to do with the search component of the shell?
_________________
Whatever you do, do it properly!
Back to top
View user's profile Send private message
jasn
Guru
Guru


Joined: 05 May 2005
Posts: 439
Location: Maryland, US

PostPosted: Thu May 24, 2012 2:18 pm    Post subject: Reply with quote

After updating to dev-db/sqlite-3.7.12.1, I am able to login to my system using gnome-base/gnome-shell-3.2.2.1 without issue.

Thanks..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum