Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Marlin (Filemanager from Elementary proyect)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 453
Location: Near /dev/urandom | /dev/null

PostPosted: Thu May 17, 2012 5:13 pm    Post subject: Marlin (Filemanager from Elementary proyect) Reply with quote

Hey guys, I've tried to reduce it to the bare minimum so I could have this splendid-looking file manager.
But I'm hitting some roadblockers:
Code:

Jaguar zeuz # emerge -av marlin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-util/gdbus-codegen-2.32.2 [2.30.3] 5,975 kB
[ebuild     U ~] dev-libs/glib-2.32.2 [2.30.3] USE="utils -debug -doc (-fam) (-selinux) -static-libs* -systemtap -test -xattr" 0 kB
[ebuild  NS    ] dev-lang/vala-0.16.0 [0.12.1] USE="vapigen -test" 2,624 kB
[ebuild  N     ] dev-libs/libgee-0.6.4  USE="-introspection" 423 kB
[ebuild     U ~] x11-libs/pango-1.30.0::sabayon [1.29.4::gentoo] USE="X introspection -debug -doc -test" 1,132 kB
[ebuild  N    *] x11-libs/varka-9999::elementary  0 kB
[ebuild     U ~] x11-libs/gdk-pixbuf-2.26.1 [2.24.1-r1] USE="X introspection jpeg tiff -debug -doc -jpeg2k -test" 1,141 kB
[ebuild     U ~] x11-libs/gtk+-3.4.3 [3.2.4-r1] USE="X%* colord (-aqua) -cups -debug -doc -examples -introspection* (-packagekit) -test -vim-syntax (-wayland) -xinerama" 12,551 kB
[ebuild  N    *] x11-libs/granite-9999::elementary  USE="-demo -nls -static-libs" 0 kB
[ebuild  N    *] pantheon-base/marlin-9999::elementary  0 kB

Total: 10 packages (5 upgrades, 4 new, 1 in new slot), Size of downloads: 23,843 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/pango:0

  (x11-libs/pango-1.30.0::sabayon, ebuild scheduled for merge) pulled in by
    >=x11-libs/pango-1.30[introspection?] required by (x11-libs/gtk+-3.4.3::gentoo, ebuild scheduled for merge)

  (x11-libs/pango-1.29.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/glib:2

  (dev-libs/glib-2.32.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.32.2:2 required by (dev-util/gdbus-codegen-2.32.2::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

  (dev-libs/glib-2.30.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/gtk+:3

  (x11-libs/gtk+-3.2.4-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/gtk+-3.4.3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-3.3.14:3 required by (x11-libs/granite-9999::elementary, ebuild scheduled for merge)



To my understanding, gtk+ libs can live along eachother versions, or so I read in a tutorial a while ago when I was introduced into the framework.
The problem being, I beleave, the ebuild trying to force itself into a slot number wich is occupied and dependency of something else.
Has anybody successfully managed to pull in (and if so, without introspection) Marlin? How would you suggest to sort this obstacle without going GNOME3?
(PS: I'm using Gnome2.32-light)
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Fri May 18, 2012 2:18 pm    Post subject: Reply with quote

Isn't this dead?

https://answers.launchpad.net/marlin/+question/193884

Anyway, I can't really help much about Sabayon stuff, since it differs significantly from Gentoo. But from that output, it seems that the problem is that your elementary overlay wants to push two versions of gtk+-3.x into the tree. You can install alongside gtk+-2.x and 3.x, but you CAN'T install two 3.x releases.

From what I see in the overlay, granite wants >=x11-libs/gtk+-3.3.14:3. The marlin ebuild seems to have been removed, so I can't see it, but it probably wants another gtk+3.x version, or wants something that in turn wants it. You can try to edit the ebuild to adjust the versions yourself. But if something fails to compile (and it probably will) you will have to patch it yourself or forget about it.

I wouldn't bother with unmaintained software unless you are willing to pick the maintenance up yourself.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 453
Location: Near /dev/urandom | /dev/null

PostPosted: Sat May 19, 2012 12:27 am    Post subject: Reply with quote

Well, as far as I can do, I'll try to edit the ebuild and see if it turns out.
If it happens to turn out well, I'll post it here and if I can be of use to the Gentoo Community then so be it, I'd gladly accept it.
But let me probe myself worthy first.
I don't really want a charge I wouldn't be able to do..
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sat May 19, 2012 8:18 am    Post subject: Reply with quote

The marlin ebuild wasn't there yesterday, and it seems to be there now. If you used layman to install the overlay, I would try "layman -S" first, to sync all your overlays. Then try to emerge it and check if the problem was gone.

Backup your overlays first. Note that, being this 3rd party stuff, if they decide to drop something from their tree, you will lose it on the next layman sync.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 453
Location: Near /dev/urandom | /dev/null

PostPosted: Sat May 19, 2012 8:31 am    Post subject: Reply with quote

You're right, there are being changes.
Since the last time I checked, the sabayon overlay dropped the marlin ebuild.
As it stands right now, it's a matter of just the 'elementary' overlay.
Code:

Jaguar zeuz # emerge -av marlin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-util/gdbus-codegen-2.32.2 [2.30.3] 5,975 kB
[ebuild     U ~] dev-libs/glib-2.32.2 [2.30.3] USE="utils -debug -doc (-fam) (-selinux) -static-libs* -systemtap -test -xattr" 0 kB
[ebuild  NS    ] dev-lang/vala-0.16.0 [0.12.1] USE="vapigen -test" 2,624 kB
[ebuild  N     ] dev-libs/libgee-0.6.4  USE="-introspection" 423 kB
[ebuild     U ~] x11-libs/pango-1.30.0 [1.29.4] USE="X introspection -debug -doc -test" 1,132 kB
[ebuild  N    *] x11-libs/varka-9999::elementary  0 kB
[ebuild     U ~] x11-libs/gdk-pixbuf-2.26.1 [2.24.1-r1] USE="X introspection jpeg tiff -debug -doc -jpeg2k -test" 1,141 kB
[ebuild     U ~] x11-libs/gtk+-3.4.3 [3.2.4-r1] USE="X%* colord (-aqua) -cups -debug -doc -examples -introspection* (-packagekit) -test -vim-syntax (-wayland) -xinerama" 12,551 kB
[ebuild  N    *] x11-libs/granite-9999::elementary  USE="-demo -nls -static-libs" 0 kB
[ebuild  N    *] pantheon-base/marlin-9999::elementary  USE="-nls -plugins" 0 kB

Total: 10 packages (5 upgrades, 4 new, 1 in new slot), Size of downloads: 23,843 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/pango:0

  (x11-libs/pango-1.30.0::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/pango-1.30[introspection?] required by (x11-libs/gtk+-3.4.3::gentoo, ebuild scheduled for merge)

  (x11-libs/pango-1.29.4::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

dev-libs/glib:2

  (dev-libs/glib-2.32.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.32.2:2 required by (dev-util/gdbus-codegen-2.32.2::gentoo, ebuild scheduled for merge)
    (and 3 more with the same problem)

  (dev-libs/glib-2.30.3::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

x11-libs/gtk+:3

  (x11-libs/gtk+-3.2.4-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/gtk+-3.4.3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-3.3.14:3 required by (x11-libs/granite-9999::elementary, ebuild scheduled for merge)


This is not much less than the previous attempt, but still on the same track.
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sat May 19, 2012 9:49 am    Post subject: Reply with quote

Try to update pango and glib, and see what happens after that.

Code:
emerge -au1 pango glib

_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 453
Location: Near /dev/urandom | /dev/null

PostPosted: Sat May 19, 2012 10:26 pm    Post subject: Reply with quote

After updating it, this is the current situation:
Code:

Jaguar zeuz # emerge -av marlin

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS    ] dev-lang/vala-0.16.0 [0.12.1] USE="vapigen -test" 2,624 kB
[ebuild  N     ] dev-libs/libgee-0.6.4  USE="-introspection" 423 kB
[ebuild  N    *] x11-libs/varka-9999::elementary  0 kB
[ebuild     U ~] x11-libs/gdk-pixbuf-2.26.1 [2.24.1-r1] USE="X introspection jpeg tiff -debug -doc -jpeg2k -test" 1,141 kB
[ebuild     U ~] x11-libs/gtk+-3.4.3 [3.2.4-r1] USE="X%* colord (-aqua) -cups -debug -doc -examples -introspection* (-packagekit) -test -vim-syntax (-wayland) -xinerama" 12,551 kB
[ebuild  N    *] x11-libs/granite-9999::elementary  USE="-demo -nls -static-libs" 0 kB
[ebuild  N    *] pantheon-base/marlin-9999::elementary  USE="-nls -plugins" 0 kB

Total: 7 packages (2 upgrades, 4 new, 1 in new slot), Size of downloads: 16,738 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-libs/gtk+:3

  (x11-libs/gtk+-3.2.4-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/gtk+-3.4.3::gentoo, ebuild scheduled for merge) pulled in by
    >=x11-libs/gtk+-3.3.14:3 required by (x11-libs/granite-9999::elementary, ebuild scheduled for merge)

_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun May 20, 2012 9:13 am    Post subject: Reply with quote

Ok, that's a bit simpler. Try to emerge it with -avt. The -t parameter will give us a better view of the dependency tree.

In any case, be warned that, since this is unmaintained stuff, there might be components that simply will not compile against a common gtk+3.x version, and thus, the problem might be unsolvable unless someone patches it so everything compiles against the latest gtk+.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun May 20, 2012 9:19 am    Post subject: Reply with quote

by the way, does it work if you do "emerge -u1 gtk+:3"?
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 453
Location: Near /dev/urandom | /dev/null

PostPosted: Sun May 20, 2012 1:51 pm    Post subject: Reply with quote

Code:

Jaguar zeuz # emerge -u1 gtk+:3
Calculating dependencies... done!
[ebuild     U ~] x11-libs/gdk-pixbuf-2.26.1 [2.24.1-r1]
[ebuild     U ~] x11-libs/gtk+-3.4.3 [3.2.4-r1] USE="X%* -introspection* (-wayland)"
[uninstall     ] x11-libs/vte-0.30.1-r3
[blocks b      ] <x11-libs/vte-0.31.0:2.90 ("<x11-libs/vte-0.31.0:2.90" is blocking x11-libs/gtk+-3.4.3)
[blocks B      ] <x11-base/xorg-server-1.11.4 ("<x11-base/xorg-server-1.11.4" is blocking x11-libs/gtk+-3.4.3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-libs/gtk+-3.4.3::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/gtk+:3 required by (x11-plugins/cairo-dock-plugins-3.0.0::sabayon, installed)
    x11-libs/gtk+:3 required by (x11-misc/cairo-dock-3.0.0-r1::sabayon, installed)
    x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    x11-libs/gtk+:3 required by (media-libs/libcanberra-0.28-r5::gentoo, installed)
    >=x11-libs/gtk+-2.90.0:3 required by (dev-libs/libunique-3.0.2::gentoo, installed)
    >=x11-libs/gtk+-3.2.0:3 required by (dev-cpp/gtkmm-3.2.0::gentoo, installed)
    >=x11-libs/gtk+-3.1.18:3 required by (x11-themes/gnome-themes-standard-3.2.1::gentoo, installed)
    >=x11-libs/gtk+-2.90.7:3 required by (sys-apps/gnome-disk-utility-3.0.2-r200::gentoo, installed)
    x11-libs/gtk+:3 required by (x11-misc/lightdm-1.0.6-r3::gentoo, installed)
    x11-libs/gtk+:3 required by (gnome-base/dconf-0.10.0::gentoo, installed)
    gtk+:3

  (x11-base/xorg-server-1.11.2-r2::gentoo, installed) pulled in by
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-evdev-2.6.0::gentoo, installed)
    >=x11-base/xorg-server-1.5.99.901 required by (x11-drivers/xf86-input-mouse-1.7.1::gentoo, installed)
    x11-base/xorg-server[-minimal] required by (x11-drivers/xf86-video-intel-2.17.0-r3::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-synaptics-1.4.0::gentoo, installed)
    >=x11-base/xorg-server-1.6.3 required by (x11-drivers/xf86-input-keyboard-1.6.0::gentoo, installed)
    >=x11-base/xorg-server-1.6.3 required by (x11-drivers/xf86-input-evdev-2.6.0::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-video-intel-2.17.0-r3::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-mouse-1.7.1::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-keyboard-1.6.0::gentoo, installed)
    x11-base/xorg-server required by @selected
    <x11-base/xorg-server-1.11.99 required by (x11-drivers/xf86-input-synaptics-1.4.0::gentoo, installed)

Seems like xorg blocks, and the fact I pulled cairo-dock from sabayon overlay because all others were kinda broken, are interfering now...
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun May 20, 2012 3:38 pm    Post subject: Reply with quote

ugh! if you want you can try updating vte and the rest of packages using the same procedure. But I can't tell you where will this all end... you might get to a point where you will finally hit an unsolvabl.e blocker... I don't know
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 453
Location: Near /dev/urandom | /dev/null

PostPosted: Sun May 20, 2012 4:45 pm    Post subject: Reply with quote

Well, so I decided to remove cairo-dock and it's plugins, so that nothing from the sabayon overlay would still be there, and then sync and update, this is what I've gotten:
Code:

Jaguar zeuz # emerge --deep --newuse --update --ask world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-libs/libevent-2.0.18 [2.0.16]
[ebuild     U  ] app-admin/sudo-1.8.5_p1 [1.8.3_p2]
[ebuild   R    ] dev-lang/yasm-1.2.0  USE="-nls*"
[ebuild     U  ] dev-lang/python-2.7.3-r1 [2.7.2-r3]
[ebuild     U  ] dev-lang/v8-3.9.24.21 [3.8.9.19]
[ebuild     U  ] dev-python/simplejson-2.5.0 [2.3.0]
[ebuild     U  ] dev-lang/python-3.2.3 [3.2.2]
[ebuild  N     ] dev-python/ply-3.4  USE="-examples"
[ebuild     U  ] www-client/chromium-19.0.1084.46-r2 [18.0.1025.168]
[ebuild     U ~] x11-libs/gdk-pixbuf-2.26.1 [2.24.1-r1]
[ebuild     U ~] x11-libs/gtk+-3.4.3 [3.2.4-r1] USE="X%* -introspection* (-wayland)"
[ebuild   R    ] x11-libs/vte-0.30.1-r3  USE="-introspection*"
[ebuild     U  ] x11-misc/xdg-user-dirs-gtk-0.9 [0.8-r1]
[blocks B      ] <x11-libs/vte-0.31.0:2.90 ("<x11-libs/vte-0.31.0:2.90" is blocking x11-libs/gtk+-3.4.3)
[blocks B      ] <x11-base/xorg-server-1.11.4 ("<x11-base/xorg-server-1.11.4" is blocking x11-libs/gtk+-3.4.3)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (x11-base/xorg-server-1.11.2-r2::gentoo, installed) pulled in by
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-evdev-2.6.0::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-video-intel-2.17.0-r3::gentoo, installed)
    x11-base/xorg-server[-minimal] required by (x11-drivers/xf86-video-intel-2.17.0-r3::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-synaptics-1.4.0::gentoo, installed)
    >=x11-base/xorg-server-1.6.3 required by (x11-drivers/xf86-input-keyboard-1.6.0::gentoo, installed)
    >=x11-base/xorg-server-1.6.3 required by (x11-drivers/xf86-input-evdev-2.6.0::gentoo, installed)
    >=x11-base/xorg-server-1.5.99.901 required by (x11-drivers/xf86-input-mouse-1.7.1::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-mouse-1.7.1::gentoo, installed)
    x11-base/xorg-server[xorg] required by (x11-drivers/xf86-input-keyboard-1.6.0::gentoo, installed)
    x11-base/xorg-server required by @selected
    <x11-base/xorg-server-1.11.99 required by (x11-drivers/xf86-input-synaptics-1.4.0::gentoo, installed)

  (x11-libs/gtk+-3.4.3::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/gtk+:3 required by (media-libs/libcanberra-0.28-r5::gentoo, installed)
    >=x11-libs/gtk+-2.90.0:3 required by (dev-libs/libunique-3.0.2::gentoo, installed)
    >=x11-libs/gtk+-2.90.7:3 required by (sys-apps/gnome-disk-utility-3.0.2-r200::gentoo, installed)
    x11-libs/gtk+:3 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=x11-libs/gtk+-3.1.18:3 required by (x11-themes/gnome-themes-standard-3.2.1::gentoo, installed)
    x11-libs/gtk+:3 required by (x11-misc/xdg-user-dirs-gtk-0.9::gentoo, ebuild scheduled for merge)
    x11-libs/gtk+:3 required by (gnome-base/dconf-0.10.0::gentoo, installed)
    >=x11-libs/gtk+-3.1.9:3 required by (x11-libs/vte-0.30.1-r3::gentoo, ebuild scheduled for merge)

  (x11-libs/vte-0.30.1-r3::gentoo, ebuild scheduled for merge) pulled in by
    x11-libs/vte required by @selected


Removing gtk+3+ is a viable option for me, then rebuilding is due..
Then start from scracth with the marlin ebuild hehe
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 453
Location: Near /dev/urandom | /dev/null

PostPosted: Sun May 20, 2012 5:24 pm    Post subject: Reply with quote

Ok, I've hitted that roadblocker with the main tree.
Not using any overlays, but I don't understand why this block is occuring?
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Sun May 20, 2012 8:36 pm    Post subject: Reply with quote

I have no idea where this started, so can't answer that, at least not yet.

Did you try updating vte as well?

Code:
emerge -au1 vte


This might have been caused by overlays, or maybe some subtle corruption in /var/lib/portage/world, or... did you check if you have some leftovers in your /etc/portage/* directories? (particularly, /etc/portage/packages.mask/).
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 453
Location: Near /dev/urandom | /dev/null

PostPosted: Mon May 21, 2012 1:20 pm    Post subject: Reply with quote

Your later asumption was right, package.accept_keywords was still set to accept arch from gtk+..
So in the end I made a mess but I'm going back for it now :P
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
ZeuZ_NG
Guru
Guru


Joined: 10 Sep 2008
Posts: 453
Location: Near /dev/urandom | /dev/null

PostPosted: Fri May 25, 2012 6:21 am    Post subject: Reply with quote

Well, so after a while, I ended up moving to arch for X.org.
Now, I'm facing problems while building varka-9999 (varka-0.1.gir file is missing)
Perhaps I need to build with introspection?
I've seen that other places that solved it.
_________________
| Intel Core i7 920. | Intel DX58SO Extreme. |
| 8gb DDR3 1666mHz | 1TB 7200 RPM WD HDD.|
Unix´s guru view of sex:
unzip ; strip ; touch ; grep ; finger ; \
mount ; fsck ; more ; yes ; umount ; sleep.
Back to top
View user's profile Send private message
i92guboj
Bodhisattva
Bodhisattva


Joined: 30 Nov 2004
Posts: 10306
Location: Córdoba (Spain)

PostPosted: Fri May 25, 2012 6:25 am    Post subject: Reply with quote

You should probably enable introspection by default, globally, to avoid all kind of problems in the future. I have no idea if it has something to do with your current problem though.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum