Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Server verweigert den Shutdown Befehl
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
haegar87
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 144

PostPosted: Tue May 22, 2012 8:34 pm    Post subject: [solved] Server verweigert den Shutdown Befehl Reply with quote

Guten Abend alle zusammen,

ich habe ein (für meine Verhältnisse) ziemlich exotisches Problem. Seit ich meinen Server neu aufgesetzt habe, lässt er sich nichtmehr ausschalten.
Zum Beispiel wenn ich ihm mit dem Kommando "shutdown -h now" herunterfahren möchte, wechselt er sauber ins Runlevel 0 und schaltet die Dienste ab, unmountet die Partitonen, alles genau so, wie es normalerweise sein soll.
Als letzte Meldung gibt er abschließend "Power down" aus... nun kommt aber das verzwickte.

Er schaltet sich nicht ab, sondern rebootet... 8O
Grundsätzlich begrüße ich eine hohe Uptime, aber meiner übertreibts da gerade :lol:

Ich weiß leider nicht wo ich ansetzen soll, da er bei LiveCDs problemlos abschaltet (auch bei der Gentoo LiveCD/InstallCD).
Als Besonderheit kommt noch hinzu, dass ca. alle 20-30 "shutdowns" einer dabei ist, wo sich der Rechner pflichtbewusst wirklich abschaltet!

Kann mir jemand einen Tipp geben, was ich jetzt prüfen könnte, um dieses Fehlverhalten zu unterbinden?

Grüße,
haegar87
_________________
"Spielt man die Windows CD rückwärts ab, hört man satanistische Texte!" - "Das ist ja noch harmlos! Wenn man sie vorwärts abspielt, installiert sich das Teufelszeug!"


Last edited by haegar87 on Mon May 28, 2012 4:41 pm; edited 1 time in total
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Wed May 23, 2012 12:48 am    Post subject: Re: Server verweigert den Shutdown Befehl Reply with quote

Hi
haegar87 wrote:
Guten Abend alle zusammen,

ich habe ein (für meine Verhältnisse) ziemlich exotisches Problem. Seit ich meinen Server neu aufgesetzt habe, lässt er sich nichtmehr ausschalten.
Zum Beispiel wenn ich ihm mit dem Kommando "shutdown -h now" herunterfahren möchte, wechselt er sauber ins Runlevel 0 und schaltet die Dienste ab, unmountet die Partitonen, alles genau so, wie es normalerweise sein soll.
Als letzte Meldung gibt er abschließend "Power down" aus... nun kommt aber das verzwickte.

Er schaltet sich nicht ab, sondern rebootet... 8O
Grundsätzlich begrüße ich eine hohe Uptime, aber meiner übertreibts da gerade :lol:

Ich weiß leider nicht wo ich ansetzen soll, da er bei LiveCDs problemlos abschaltet (auch bei der Gentoo LiveCD/InstallCD).
Als Besonderheit kommt noch hinzu, dass ca. alle 20-30 "shutdowns" einer dabei ist, wo sich der Rechner pflichtbewusst wirklich abschaltet!

Kann mir jemand einen Tipp geben, was ich jetzt prüfen könnte, um dieses Fehlverhalten zu unterbinden?

Grüße,
haegar87

Ich kenne das Problem (schon lange her). Bei mir hatte es was im Kernel mit APM also Powermanager zu schaffen.
Wenn du deine alte .config vom Kernel noch hast bevor du den Server aufgesetzt hast solltest du die mit der jetzigen
mal vergleichen. ACPI Einstellungen (oder wie das heisst, auf jeden Fall auch was mit Powermanager) im Kernel
könnte auch so ein Kandidat sein.

MfG
Back to top
View user's profile Send private message
haegar87
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 144

PostPosted: Wed May 23, 2012 5:47 am    Post subject: Reply with quote

Leider hat die alle Kernel Konfiguration nicht überlebt.
Aber danke für den Tipp mit den APM/ACPI Einstellungen.
Da werde ich mich dann wohl mal durcharbeiten müssen.

Grüße
haegar87
_________________
"Spielt man die Windows CD rückwärts ab, hört man satanistische Texte!" - "Das ist ja noch harmlos! Wenn man sie vorwärts abspielt, installiert sich das Teufelszeug!"
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 483
Location: münchen.de

PostPosted: Wed May 23, 2012 10:02 am    Post subject: Reply with quote

Ich habe das Problem auch seit ein paar Monaten. "shutdown" funktioniert immer noch nicht sauber, aber "halt". Versuchs mal damit.
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
haegar87
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 144

PostPosted: Wed May 23, 2012 10:37 am    Post subject: Reply with quote

Tag,

hab ich leider vergessen zu schreiben. Leider funktioniert weder shutdown, noch halt.
Auch der Parameter -P hat keine Besserung gebracht.

Grüße,
haegar87
_________________
"Spielt man die Windows CD rückwärts ab, hört man satanistische Texte!" - "Das ist ja noch harmlos! Wenn man sie vorwärts abspielt, installiert sich das Teufelszeug!"
Back to top
View user's profile Send private message
fuchur
Guru
Guru


Joined: 12 Aug 2003
Posts: 578

PostPosted: Wed May 23, 2012 11:42 am    Post subject: Reply with quote

Hi

Du hast geschrieben das es bei einer Livecd geht. Übernimm zu test doch
einfach mal die Einstellungen von "Power management and ACPI options"
in "/proc/config.gz" von der LiveCd.

MfG
Back to top
View user's profile Send private message
haegar87
Tux's lil' helper
Tux's lil' helper


Joined: 08 Jan 2006
Posts: 144

PostPosted: Mon May 28, 2012 4:41 pm    Post subject: Reply with quote

So, ich setze das jetzt einfach mal auf [solved].
Weiß selbst nicht warum, aber als ich mein XEN Start-/Stopscript fertig hatte (was schon an die 5min Laufzeit hat beim shutdown) schaltet
sich der Rechner pflichtbewusst selbstständig ab... vielleicht brauchte er einfach mehr Zeit?!

Grüße,
haegar87
_________________
"Spielt man die Windows CD rückwärts ab, hört man satanistische Texte!" - "Das ist ja noch harmlos! Wenn man sie vorwärts abspielt, installiert sich das Teufelszeug!"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum