Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Gnome3 crash between gdm and gnome-shell
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Thu May 24, 2012 6:31 pm    Post subject: [SOLVED] Gnome3 crash between gdm and gnome-shell Reply with quote

I'm in the middle of doing a big upgrade on my system. Almost all packages are updated, so it's time to try gnome 3.2.

When I boot the laptop into gdm, and login as my user, gdm switches out, seemingly to start gnome, but then returns. I never see gnome.
If I login as root, gnome does start up nicely.

I then stop xdm from a terminal and login as my user, and do "startx", and gnome works nicely.

Problem is I can't figure out why gnome bails out in the typical usecase. There's still lots of other problems and stray error messages, but gnome works ok.

.xsession coming up....


Last edited by pjv on Sat May 26, 2012 2:06 pm; edited 1 time in total
Back to top
View user's profile Send private message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Thu May 24, 2012 6:43 pm    Post subject: Reply with quote

.xsession-errors (doesn't differ between sessions):

Code:
/etc/gdm/Xsession: Beginning session setup...
unable to find device pointer:Logitech USB Receiver
/etc/gdm/Xsession: regel 143: xmodmap: opdracht niet gevonden
/etc/gdm/Xsession: regel 156: id: opdracht niet gevonden
/etc/gdm/Xsession: regel 156: xhost: opdracht niet gevonden
/etc/X11/xinit/xinitrc.d/00-xhost: regel 7: id: opdracht niet gevonden
/etc/X11/xinit/xinitrc.d/49-keychain: regel 5: which: opdracht niet gevonden
/etc/X11/xinit/xinitrc.d/50-ssh-agent: regel 5: which: opdracht niet gevonden
/etc/gdm/Xsession: ssh-agent not found!
/etc/gdm/Xsession: Setup done, will execute: gnome-session
/etc/gdm/Xsession: regel 196: exec: gnome-session: niet gevonden


The greeter.log sometimes contains:

Code:
(gnome-settings-daemon:28353): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.


The slave.log:

Code:
gdm-welcome][28334]: pam_unix(gdm-welcome:session): session opened for user gdm by (uid=0)
gdm-password][28374]: pam_unix(gdm-password:session): session opened for user pjv by (uid=0)
gdm-simple-slave[28314]: WARNING: Child process 28343 was already dead.


Are any other debugging techniques available to me?
Back to top
View user's profile Send private message
pjv
Guru
Guru


Joined: 02 Jul 2003
Posts: 353
Location: Belgium

PostPosted: Sat May 26, 2012 2:06 pm    Post subject: Reply with quote

I solved it. Had an improper PATH in one of my shell scripts. See the comment at http://www.held.org.il/blog/2011/02/solution-for-xsession-bash_completion-problem/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum