Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[kernel] impossible de compiler le 3.4.0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Mon May 28, 2012 3:15 pm    Post subject: [kernel] impossible de compiler le 3.4.0 Reply with quote

Bonjours à tous,
j'ai une machine sous gentoo qui a un noyeau 3.2.6 pour le moment, donc pour passer au 3.4.0 je fais comme d'habitude: je fais un:
Quote:

cp /etc/kernels/kernel-config-x86_64-3.2.6-gentoo /etc/kernels/kernel-config-x86_64-3.4.0-gentoo
rm /usr/src/linux
emerge gentoo-sources
ln -s /usr/src/linux-3.4.0-gentoo /usr/src/linux
cd /usr/src/linux
genkernel --menuconfig all


mais voila, ce coup ci ca ne passe pas et j'ai ca:

Quote:
StarK linux # genkernel all
* Gentoo Linux Genkernel; Version 3.4.33.1
* Running with options: all

* Linux Kernel 3.4.0-gentoo for x86_64...
* kernel: Using config from /etc/kernels/kernel-config-x86_64-3.4.0-gentoo
* Previous config backed up to .config--2012-05-28--16-50-29.bak
* kernel: >> Running mrproper...
* >> Running oldconfig...
* kernel: >> Cleaning...
* >> Compiling 3.4.0-gentoo bzImage...
* >> Not installing firmware as it's included in the kernel already (CONFIG_FIRMWARE_IN_KERNEL=y)...
* >> Compiling 3.4.0-gentoo modules...
* ERROR: Failed to compile the "modules" target...
*
* -- Grepping log... --
*
* Debug Statements (ACPI_DEBUG) [N/y/?] n
* PCI slot detection driver (ACPI_PCI_SLOT) [N/m/y/?] n
* Power Management Timer Support (X86_PM_TIMER) [Y/n/?] y
* Container and Module Devices (EXPERIMENTAL) (ACPI_CONTAINER) [M/y/?] m
* Smart Battery System (ACPI_SBS) [N/m/y/?] n
* Hardware Error Device (ACPI_HED) [N/m/y/?] n
* Boottime Graphics Resource Table support (ACPI_BGRT) [N/m/y/?] (NEW) ACPI Platform Error Interface (APEI) (ACPI_APEI) [N/y/?] n
*--
*
*PCI support (PCI) [Y/n/?] y
* Support mmconfig PCI config space access (PCI_MMCONFIG) [Y/n] y
* Read CNB20LE Host Bridge Windows (PCI_CNB20LE_QUIRK) [N/y/?] n
* PCI Express support (PCIEPORTBUS) [Y/n/?] y
* Root Port Advanced Error Reporting support (PCIEAER) [Y/n/?] y
* PCI Express ECRC settings control (PCIE_ECRC) [N/y/?] n
* PCIe AER error injector support (PCIEAER_INJECT) [N/m/y/?] n
*--
*
* Voltage and Current Regulator Support
*
*Voltage and Current Regulator Support (REGULATOR) [Y/n/?] y
* Regulator debug support (REGULATOR_DEBUG) [Y/n/?] y
* Provide a dummy regulator if regulator lookups fail (REGULATOR_DUMMY) [N/y/?] n
*--
*Dnotify support (DNOTIFY) [Y/n/?] y
*Inotify support for userspace (INOTIFY_USER) [Y/n/?] y
*Filesystem wide access notification (FANOTIFY) [N/y/?] n
*Quota support (QUOTA) [Y/?] y
*Report quota messages through netlink interface (QUOTA_NETLINK_INTERFACE) [N/y/?] n
*Print quota warnings to console (OBSOLETE) (PRINT_QUOTA_WARNING) [Y/n/?] y
*--
*Print additional diagnostics on RCU CPU stall (RCU_CPU_STALL_INFO) [N/y/?] (NEW) Enable tracing for RCU (RCU_TRACE) [N/y/?] n
*Self test for the backtrace code (BACKTRACE_SELF_TEST) [N/m/y/?] n
*Force extended block device numbers and spread them (DEBUG_BLOCK_EXT_DEVT) [N/y/?] n
*Force weak per-cpu definitions (DEBUG_FORCE_WEAK_PER_CPU) [N/y/?] n
*Debug access to per_cpu maps (DEBUG_PER_CPU_MAPS) [N/y/?] n
*CPU notifier error injection module (CPU_NOTIFIER_ERROR_INJECT) [N/m/y/?] n
*--
* CC [M] drivers/net/wireless/ipw2x00/ipw2100.o
* CC [M] drivers/scsi/libiscsi.o
* CC [M] drivers/scsi/iscsi_boot_sysfs.o
* CC [M] drivers/net/wireless/ipw2x00/ipw2200.o
* CC [M] drivers/scsi/advansys.o
*drivers/scsi/advansys.c:71:2: attention : #warning this driver is still not properly converted to the DMA API
*--
* CC [M] drivers/scsi/lpfc/lpfc_nportdisc.o
* CC [M] drivers/ssb/scan.o
* CC [M] drivers/ssb/sprom.o
* CC [M] drivers/ssb/pci.o
* CC [M] drivers/scsi/lpfc/lpfc_scsi.o
*cc1: warnings being treated as errors
*--
* LD [M] drivers/ssb/ssb.o
*make: *** [drivers] Erreur 2
* Gentoo Linux Genkernel; Version 3.4.33.1
* Running with options: all
*
* ERROR: Failed to compile the "modules" target...
*
* -- End log... --
*
* Please consult /var/log/genkernel.log for more information and any
* errors that were reported above.
*
* Report any genkernel bugs to bugs.gentoo.org and
* assign your bug to genkernel@gentoo.org. Please include
* as much information as you can in your bug report; attaching
* /var/log/genkernel.log so that your issue can be dealt with effectively.
*
* Please do *not* report compilation failures as genkernel bugs!
*
StarK linux #


quelqu'un aurais une petite idée ?

(jai bien tenté de retirer les modules concernées mais au bout d'un moment mon eth0 n'apparait meme plus dans ifconfig )
Back to top
View user's profile Send private message
pilla
Administrator
Administrator


Joined: 07 Aug 2002
Posts: 7695
Location: Pelotas, BR

PostPosted: Tue May 29, 2012 10:47 am    Post subject: Reply with quote

Moved from Gentoo on AMD64 to French.
_________________
"I'm just very selective about the reality I choose to accept." -- Calvin
Back to top
View user's profile Send private message
guilc
Bodhisattva
Bodhisattva


Joined: 15 Nov 2003
Posts: 3326
Location: Paris - France

PostPosted: Wed May 30, 2012 6:09 am    Post subject: Reply with quote

Code:
Please consult /var/log/genkernel.log for more information and any
* errors that were reported above.

Ça serait cool si on pouvait avoir la fin de ce fichier. Parce que là, dur de dire quoi que ce soit ;)
_________________
Merci de respecter les règles du forum.

Mon site perso : https://www.xwing.info
Mon PORTDIR_OVERLAY : https://gentoo.xwing.info ou layman -a xwing
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8125
Location: ~Brussels - Belgique

PostPosted: Wed May 30, 2012 7:22 am    Post subject: Reply with quote

Hello,

As-tu revérifié les options en faisant un --menuconfig ?

Sinon, quelqu'un d'autre a aussi un souci: https://forums.gentoo.org/viewtopic-t-924808-highlight-.html
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
barul
Guru
Guru


Joined: 28 May 2010
Posts: 430

PostPosted: Wed May 30, 2012 6:47 pm    Post subject: Reply with quote

Peut-être que tu peux essayer de virer les modules, ici j'ai compilé le mien à la main, tout a bien fonctionné. (avec un vieux .config)
Back to top
View user's profile Send private message
Chr0nos
Apprentice
Apprentice


Joined: 26 Feb 2010
Posts: 205

PostPosted: Sun Jun 03, 2012 10:37 am    Post subject: Reply with quote

alors pour la fin du fichier en question:

Quote:
CC [M] drivers/scsi/lpfc/lpfc_hbadisc.o
CC [M] drivers/scsi/megaraid/megaraid_sas_fp.o
LD [M] drivers/scsi/megaraid/megaraid_sas.o
CC [M] drivers/scsi/lpfc/lpfc_init.o
CC [M] drivers/scsi/pcmcia/fdomain_stub.o
CC [M] drivers/scsi/pcmcia/fdomain_core.o
CC [M] drivers/scsi/pcmcia/qlogic_stub.o
CC [M] drivers/scsi/pcmcia/sym53c500_cs.o
LD [M] drivers/scsi/pcmcia/qlogic_cs.o
LD [M] drivers/scsi/pcmcia/fdomain_cs.o
CC [M] drivers/scsi/lpfc/lpfc_mbox.o
CC [M] drivers/ssb/main.o
CC [M] drivers/scsi/lpfc/lpfc_nportdisc.o
CC [M] drivers/ssb/scan.o
CC [M] drivers/ssb/sprom.o
CC [M] drivers/ssb/pci.o
CC [M] drivers/scsi/lpfc/lpfc_scsi.o
cc1: warnings being treated as errors
drivers/scsi/lpfc/lpfc_scsi.c: In function ‘lpfc_bg_setup_bpl’:
drivers/scsi/lpfc/lpfc_scsi.c:1900:11: erreur: unused variable ‘rc’
drivers/scsi/lpfc/lpfc_scsi.c: In function ‘lpfc_bg_setup_bpl_prot’:
drivers/scsi/lpfc/lpfc_scsi.c:2037:11: erreur: unused variable ‘rc’
drivers/scsi/lpfc/lpfc_scsi.c: In function ‘lpfc_bg_setup_sgl’:
drivers/scsi/lpfc/lpfc_scsi.c:2256:11: erreur: unused variable ‘rc’
drivers/scsi/lpfc/lpfc_scsi.c: In function ‘lpfc_bg_setup_sgl_prot’:
drivers/scsi/lpfc/lpfc_scsi.c:2386:11: erreur: unused variable ‘rc’
CC [M] drivers/ssb/pcihost_wrapper.o
make[3]: *** [drivers/scsi/lpfc/lpfc_scsi.o] Erreur 1
make[2]: *** [drivers/scsi/lpfc] Erreur 2
make[1]: *** [drivers/scsi] Erreur 2
make[1]: *** Attente des tâches non terminées....
CC [M] drivers/ssb/pcmcia.o
CC [M] drivers/ssb/driver_chipcommon.o
CC [M] drivers/ssb/driver_chipcommon_pmu.o
CC [M] drivers/ssb/driver_pcicore.o
CC [M] drivers/ssb/b43_pci_bridge.o
LD [M] drivers/ssb/ssb.o
make: *** [drivers] Erreur 2
* Gentoo Linux Genkernel; Version 3.4.33.1
* Running with options: all

* ERROR: Failed to compile the "modules" target...
*
* -- Grepping log... --
*
*
* -- End log... --
*
* Please consult /var/log/genkernel.log for more information and any
* errors that were reported above.
*
* Report any genkernel bugs to bugs.gentoo.org and
* assign your bug to genkernel@gentoo.org. Please include
* as much information as you can in your bug report; attaching
* /var/log/genkernel.log so that your issue can be dealt with effectively.
*
* Please do *not* report compilation failures as genkernel bugs!
*


j'ai bien vérifié mes options dans un --menuconfig mais quand je retire les modules qui posent problemes je me retrouve jusqu'a ne plus avoir de /dev/disk (entre autres)

à chaque fois que je change de noyeau je copie celui de l'ancien kernel

ps: désolé pour le temp de réponse
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8125
Location: ~Brussels - Belgique

PostPosted: Sun Jun 03, 2012 1:28 pm    Post subject: Reply with quote

Hello,

Tant qu'à faire, ne pourrais-tu pas essayer de te refaire un noyau tout propre, à partir de (presque) zéro ?

Prends une configuration de base de "Kernel Seeds" : http://kernel-seeds.org/
Combinée avec les modules nécessaires pour ton système via Debian HCL : http://kmuto.jp/debian/hcl/index.rhtmlx

Et ce qu'il faut pour démarrer ton système : filesystem contenant "root", raid, ...

Tout ceci n'est bien sûr pas incompatible avec genkernel ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2671
Location: Paris

PostPosted: Sun Jun 03, 2012 11:04 pm    Post subject: Reply with quote

J'ai eu le même problème ce soir (toujours en train de remonter mon PC suite au feu d'artifice de mon alimentation). J'ai noté avec genkernel et ce noyau les éléments suivants :
- J'ai pour habitude d'utiliser genkernel avec l'option --menuconfig car ayant du raid1 pour mes partitions systèmes et de données, ça m'évite de m'emmerder avec l'initramfs et le fait de passer par un --menuconfig me permet de ne charger que les éléments qui m'intérssent.
- J'ai aussi pour habitude quand je quitte menuconfig de faire "exit" et là je ne sais pas pourquoi mais ce soir ça ne voulait pas sauvegarder la configuration...
- J'ai donc sauvegarder la configuration dans un fichier alternatif et j'ai lancé ensuite "genkernel --kernel-config=.config_perso all"
- Et là le module drivers/scsi/lpfc/lpfc_scsi.o dont je n'ai pas besoin qui faisait planté la compilation était bien ignoré.

J'ai pas cherché plus que ça pourquoi genkernel sauvegardait pas la configuration en fin de "menuconfig" mais bon ce fut simple à voir la 2ème fois dans le log /var/log/genkernel.log car j'avais viré tous les pilotes réseaux sauf le mien et tous les trucs résaux ATM/FDDI/Token Ring et je les ai vu défiler dans le log. C'est ainsi que j'ai vu qu'il prenait pas mes modifications.

@+
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum