Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba 4 alpha 21 on Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Jd032371
n00b
n00b


Joined: 31 Aug 2010
Posts: 13

PostPosted: Thu Jun 07, 2012 3:46 pm    Post subject: Samba 4 alpha 21 on Gentoo Reply with quote

I installed the Samba 4 alpha 21 using the Samba 4 alpha 20 ebuild as a template:

When I try to run the samba-tool command, I keep getting

Code:
File "/usr/bin/samba-tool", line 38
    except SystemExit, e:
                     ^
SyntaxError: invalid syntax


Any ideas?
Back to top
View user's profile Send private message
Maitreya
Guru
Guru


Joined: 11 Jan 2006
Posts: 421

PostPosted: Sat Jun 09, 2012 9:03 am    Post subject: Reply with quote

Can you post
Code:

eselect python list


?
Back to top
View user's profile Send private message
Jd032371
n00b
n00b


Joined: 31 Aug 2010
Posts: 13

PostPosted: Mon Jun 11, 2012 5:11 pm    Post subject: Reply with quote

Output from eselect python list

Code:

  [1]   python2.6
  [2]   python3.1 *
  [3]   python3.2


Thanks in advance for any help.
Back to top
View user's profile Send private message
Jd032371
n00b
n00b


Joined: 31 Aug 2010
Posts: 13

PostPosted: Mon Jun 11, 2012 5:14 pm    Post subject: Samba 4 alpha 21 on Gentoo Reply with quote

Thanks for pointing me in the correct direction...samba 4 alpha 21 works with python 2.6. It is broken on python 3.1 or 3.2.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum