Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Automake funkgioniert nicht mehr.
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sat Jun 09, 2012 6:42 am    Post subject: Automake funkgioniert nicht mehr. Reply with quote

Es scheint gerade etwas automake zerschossen zu haben. Es lässt sich bei mir folgende Liste von Anwendungen nicht übersetzen:
Code:
=net-libs/gnutls-2.12.19
=media-sound/lame-3.99.5
=media-plugins/gst-plugins-lame-0.10.18
=app-text/recode-3.6_p17-r2
=net-libs/gtk-vnc-0.5.0-r1
=net-misc/vinagre-3.4.2
=media-video/ffmpeg-0.10.3
=net-libs/webkit-gtk-1.8.1-r301
=gnome-extra/sushi-0.4.1
=www-client/epiphany-3.4.2
=gnome-extra/yelp-3.4.2
=dev-libs/seed-3.2.0-r1
=dev-libs/libpeas-1.4.0-r1
=net-libs/glib-networking-2.32.3
=media-video/totem-3.4.2
=media-gfx/eog-3.4.1
=net-misc/vino-3.4.2
=app-editors/gedit-3.4.2
=media-gfx/shotwell-0.12.3
=net-libs/gnome-online-accounts-3.4.2
=gnome-extra/evolution-data-server-3.4.2
=dev-libs/folks-0.6.9
=mail-client/evolution-3.4.2
=gnome-base/gnome-panel-3.4.1
=gnome-extra/gnome-contacts-3.4.1
=app-mobilephone/obexd-0.46
=gnome-base/gnome-control-center-3.4.2
=gnome-base/gnome-shell-3.4.1
=net-im/pidgin-2.10.4
=gnome-base/gnome-applets-3.4.1
=net-voip/telepathy-haze-0.6.0
=net-im/empathy-3.4.2.1
=app-misc/tracker-0.14.1
=gnome-extra/nautilus-tracker-tags-0.14.1
=gnome-extra/gnome-documents-0.4.2

Die erste Fehlermeldung sieht so aus, durch alle habe ich mich dann nicht mehr durchgekämpft, es ist aber fast immer automake:
Code:
 * Running autoconf ...                                                  [ ok ]
 * Running autoheader ...                                                [ ok ]
 * Running automake --add-missing --copy ...                             [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/net-libs/gnutls-2.12.19/temp/automake.out

Die automake.out sieht so aus:
Code:
***** automake *****
***** PWD: /var/tmp/portage/net-libs/gnutls-2.12.19/work/gnutls-2.12.19
***** automake --add-missing --copy

configure.ac:129: warning: AC_LANG_CONFTEST: no AC_LANG_SOURCE call detected in body
../../lib/autoconf/lang.m4:193: AC_LANG_CONFTEST is expanded from...
../../lib/autoconf/general.m4:2661: _AC_LINK_IFELSE is expanded from...
../../lib/autoconf/general.m4:2678: AC_LINK_IFELSE is expanded from...
configure.ac:129: the top level
automake-1.12: warnings are treated as errors
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libexamples.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
doc/examples/Makefile.am:80:   while processing Libtool library 'libexamples.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libguile-gnutls-extra-v-1.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
guile/src/Makefile.am:36:   while processing Libtool library 'libguile-gnutls-extra-v-1.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libguile-gnutls-v-1.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
guile/src/Makefile.am:36:   while processing Libtool library 'libguile-gnutls-v-1.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libcfg.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:100:   while processing Libtool library 'libcfg.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libcmd-certtool.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:48:   while processing Libtool library 'libcmd-certtool.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libcmd-cli-debug.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:48:   while processing Libtool library 'libcmd-cli-debug.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libcmd-cli.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:48:   while processing Libtool library 'libcmd-cli.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libcmd-p11tool.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:131:   while processing Libtool library 'libcmd-p11tool.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libcmd-psk.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:48:   while processing Libtool library 'libcmd-psk.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libcmd-serv.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:48:   while processing Libtool library 'libcmd-serv.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libcmd-srp.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
src/Makefile.am:62:   while processing Libtool library 'libcmd-srp.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libutils.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
tests/Makefile.am:58:   while processing Libtool library 'libutils.la'
/usr/share/automake-1.12/am/ltlibrary.am: warning: 'libecore.la': linking libtool libraries using a non-POSIX
/usr/share/automake-1.12/am/ltlibrary.am: archiver requires 'AM_PROG_AR' in 'configure.ac'
tests/suite/Makefile.am:43:   while processing Libtool library 'libecore.la'
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 4408

PostPosted: Sat Jun 09, 2012 6:53 am    Post subject: Reply with quote

gnutls:
https://bugs.gentoo.org/show_bug.cgi?id=420333

Gibt noch mehr reports in der Richtung, bei mir wars z.B. recordmydesktop, war aber mit ein paar Updates in den eclasses (von den Gentoo-Devs) plötzlich magisch behoben. Hilft wohl nur: Fehler melden und warten, bis sich die (umgebauten -> u.a. multiprocessing.eclass) eclasses stabilisiert haben :/
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Sat Jun 09, 2012 7:10 am    Post subject: Reply with quote

Na ich bin begeistert... Solch ein Klopfer sollte eigentlich nicht passieren.

Hab auch Workaround gefunden, wenn man Pakete installieren will.
Code:
emerge-webrsync --revert=20120606

Damit kann man sich erst mal die fehlenden Pakete installieren.
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6281

PostPosted: Sat Jun 09, 2012 8:13 am    Post subject: Reply with quote

Klaus Meier wrote:
Na ich bin begeistert... Solch ein Klopfer sollte eigentlich nicht passieren.

Das kann höchsten Diego mit seiner Tinderbox vorher feststellen: Das Problem ist, dass irgendwann einmal WANT_AUTOMAKE auf die aktuelle automake-Version gesetzt werden muss, sonst muss man für alle Ewigkeiten die obsoleten früheren Versionen beibehalten. Es ist sinnvoll, dass dieser Default systemweit ist, da sonst einige Pakete (mit fast inaktiven oder desinteressierten Maintainern) de facto doch zur Beibehaltung der obsoleten Automake-Versionen zwingen würden. Das ist ähnlich wie ein neues baselayout: Irgendwann muss man mal den Schritt wagen; automake-1.12 gibt es jetzt schon etliche Monate.

Nicht funktionierende Pakete kann man bis zu ihrem Fix mit
Code:
export WANT_AUTOMAKE=1.11
erschlagen...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum