Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Gelöst] Kann manche Programme nicht starten
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Tue Jun 19, 2012 9:25 pm    Post subject: [Gelöst] Kann manche Programme nicht starten Reply with quote

Hallo zusammen

Ich habe folgendes Problem:

Ich hatte mir kmix geladen um meine lautstäke ändern zu können ich konnte es auch immer starten bis heute wenn ich es starten möchte ist es in der fesnterleiste zu sehen aber nach ca. 10 sekunden verschwindet es wieder.

Genau das gleiche Problem habe ich jetzt auch mit vlc

wenn ich kmix in der konsolse als root eintippe kommt das hier:

Code:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.



wenn ich kmix in der konsole als anderen Benutzer eintippe kommt das hier:

Code:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
unnamed app(12988): KUniqueApplication: Cannot find the D-Bus session server:  "Unable to autolaunch a dbus-daemon without a $DISPLAY for X11"

unnamed app(12987): KUniqueApplication: Pipe closed unexpectedly.


wenn ich vlc in der konsole eintippe als root kommt das hier:

Code:
VLC is not supposed to be run as root. Sorry.
If you need to use real-time priorities and/or privileged TCP ports
you can use vlc-wrapper (make sure it is Set-UID root and
cannot be run by non-trusted users first).


Wenn ich mich als anderen benutzer anmelde im der konsole und vlc eintippe kommt das hier:

Code:
vlc
VLC media player 2.0.1 Twoflower (revision 2.0.1-0-gf432547)
[0x80c99f0] inhibit interface error: Failed to connect to the D-Bus session daemon: Unable to autolaunch a dbus-daemon without a $DISPLAY for X11
[0x80c99f0] main interface error: no suitable interface module
[0x80c99f0] main interface error: no suitable interface module
[0x804c908] main libvlc error: interface "globalhotkeys,none" initialization failed
[0x804c908] main libvlc: VLC wird mit dem Standard-Interface ausgeführt. Benutzen Sie 'cvlc', um VLC ohne Interface zu verwenden.
[0x80c99f0] qt4 interface error: Could not connect to X server
[0x80c99f0] skins2 interface error: cannot initialize OSFactory
Remote-Control-Interface initialisiert. Geben Sie `help' für Hilfe ein.


Was kann das sein werde daraus nicht schlau?

wenn ich STRG+ESC Drücke sehe ich das Kmix dort ist aber vlc nicht

Gruß


Last edited by linux88 on Wed Jun 20, 2012 9:27 pm; edited 1 time in total
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 483
Location: münchen.de

PostPosted: Tue Jun 19, 2012 11:00 pm    Post subject: Reply with quote

Da sind soviele DBus Meldungen. Läuft denn der DBus Service überhaupt?
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Tue Jun 19, 2012 11:33 pm    Post subject: Reply with quote

Wennich ehrlich bin hab ich keine ahnug,
Ich glube ich bin noch so windows verseucht da brauch ich nen tag länger um linux zu verstehen aber es macht ja spass :-)

Wo kann ich das denn nachgucken ?
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 483
Location: münchen.de

PostPosted: Tue Jun 19, 2012 11:37 pm    Post subject: Reply with quote

Code:
# /etc/init.d/dbus status
 * status: started

_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Tue Jun 19, 2012 11:44 pm    Post subject: Reply with quote

Das zeigt mir:

Code:
/etc/init.d/dbus status
 * status: stopped


an
Back to top
View user's profile Send private message
forrestfunk81
Guru
Guru


Joined: 07 Feb 2006
Posts: 483
Location: münchen.de

PostPosted: Tue Jun 19, 2012 11:52 pm    Post subject: Reply with quote

Dann lies dich doch zuerstmal ein bißchen in das Thema ein. Zum Beispiel hier.
_________________
# cd /pub/
# more beer
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Tue Jun 19, 2012 11:55 pm    Post subject: Reply with quote

Genau das werd ich jetzt machen :-)

Hoffe das ich danach das Problem lösen kann




Edit::

Ich bae dbus jetzt mal gestartet über status habe ich geprüft ob es auch so ist

/etc/init.d/dbus status
* status: started

aber leider hilft dies bis jetzt erstmal nicht weiter
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Wed Jun 20, 2012 8:12 am    Post subject: Reply with quote

Trag mal dbus so ein, dass er immer gestartet wird, als root:

rc-update add dbus default

Bezüglich der anderen DBus Meldung:
"Unable to autolaunch a dbus-daemon without a $DISPLAY for X11"

War das noch, als du über startx gestartet hast?
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Wed Jun 20, 2012 5:50 pm    Post subject: Reply with quote

Also habe ich jetzt mal gemacht jetzt bekomm ich das hier ausgegeben wenn ich mich über startx anmelde und als root kmix eingebe:

Code:
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
grepHelper: File does not exists:  "/proc/asound/card1/pcm3p/info"
grepHelper: File does not exists:  "/proc/asound/card0/pcm0c/info"
grepHelper: File does not exists:  "/proc/asound/card0/pcm0p/info"
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor
Running Mixer_ALSA destructor
Running Mixer_Backend destructor





Ja genau als ich noch über startx gestartet habe kam das aber auch nur wenn ich mich in der Konsole als normalen Benutzer angemeldet habe kam diese meldug und jetzt immernoch.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3626
Location: Germany

PostPosted: Wed Jun 20, 2012 7:35 pm    Post subject: Reply with quote

Gewöhne dir doch bitte ab grafische Anwendungen als root zu starten - das ist i.d.R nicht nötig, und meist auch noch gefährlich.

Zu kmix
kmix braucht normal nicht extra gestartet werden. Sofern von alsa eine betriebsbereite Soundkarte bereitgestellt wird sollte kmix automatisch schon mit dem KDE-Start im Systemtray verfügbar sein.
Wenn dem nicht so ist ist wahrscheinlich noch keine konfigurierte Soundkarte vorhanden. (ohne Soundkarte wird kmix gar nicht erst mit angezeigt)
Sprich, prüfe bitte mal deine Soundkarten Konfiguration - nutze dafür zb den Gentoo Linux: ALSA-Leitfaden
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Wed Jun 20, 2012 8:35 pm    Post subject: Reply with quote

Du solltest auch nicht über startx das graphische System starten, sondern über /etc/init.d/xdm start.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Wed Jun 20, 2012 9:27 pm    Post subject: Reply with quote

JA das werde ich auch nicht mehr machen jetzt weiß ich bescheid Danke

Kde Startet jetzt bei mir sofort nach dem reboot so das ich mich ganz normal als normeln benutzer anmelde

Es hat sich eigentlich alles erledigt mitllerweile komme ich gut zurecht Danke euch allen :-)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum