Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[OK]error writing /boot/grub/grub.conf Read-Only file system
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Thu Jun 21, 2012 5:48 am    Post subject: [OK]error writing /boot/grub/grub.conf Read-Only file system Reply with quote

Hallo zusammen;

Ich wollte grade mein 2ten Laptop auch mit gentoo bestücken leider geht bei der /grub.conf nicht weiter.
Wenn ich mit nano -w /boot/grub/grub.conf öffne kommt diese Meldung:
Code:
Read 16 lines (Warning: No write permisddion)


Wenn ich diese Speichern möchte bekomme ich diese Meldung:

Code:
error writing /boot/grub/grub.conf Read-Only file system



Wie kann das denn sein ?

Steck mitten in der installation und dann sowas wie bekomm ich die berechtigung das ich die datei berbeiten kann ?

Gruß

Edit:

Komisch

Nach einen
Code:
mount -n -o remount,rw /dev/sda1
gehts wieder.
Aber wie kommt das die ich das neu mounten muss ?

Musste ich bei meiner ersten Installation auch nicht und ich habe nichts anderes gemacht ?


Last edited by linux88 on Thu Jun 21, 2012 6:33 am; edited 2 times in total
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Thu Jun 21, 2012 5:58 am    Post subject: Reply with quote

Ist /boot bei dir ein Ordner oder eine eigene Partition? Wenn Partition, wie hast du sie gemountet?
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Thu Jun 21, 2012 6:08 am    Post subject: Reply with quote

Als Partition wie in dieser Anleitung beschrieben: http://www.gentoo.de/doc/de/handbook/handbook-x86.xml?part=1&chap=4#doc_chap6

Bei 4.f


# mount /dev/sda3 /mnt/gentoo
# mkdir /mnt/gentoo/boot
# mount /dev/sda1 /mnt/gentoo/boot

Nach einen
Code:
mount -n -o remount,rw /dev/sda1
gehts wieder.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Thu Jun 21, 2012 6:16 am    Post subject: Reply with quote

Die Partition /boot wird bei dir readonly gemountet. Und nach dem remount ist sie dann beschreibbar. Du musst sie beim ersten Mal readonly gemountet haben, denn nach dem remount geht es ja, also ist sonst alles in Ordnung.
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Thu Jun 21, 2012 6:19 am    Post subject: Reply with quote

Ja keine ahnug vieleicht bin ich einfach zu müde, wieder mal ganze nacht wach gewehsen Gentoo lässt mich einfach nicht in Ruhe ;-)

Danke Dir

Ps: War noch nie in einen Forum unterwegs wo so schnell wie hier einen geholfen wird. Hut Ab !!!
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Thu Jun 21, 2012 6:23 am    Post subject: Reply with quote

Ich habe halt gerade Urlaub und etwas Zeit. Aber wenn es irgendwo eine Lösung gibt, dann ist dieses Forum gar nicht so schlecht...

Jup, manchmal ist es einfach die beste Lösung, einfach mal eine Tasse Kaffee zu trinken und mal etwas runter zu kommen, wenn man sich in irgendwas verrannt hat. Und stellt dann fest, dass es nur eine Kleinigkeit war. Und man an die ganz großen Dinge gedacht hat.

Oder wirklich erst mal ins Bett zu gehen :roll: :roll: :roll:
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Thu Jun 21, 2012 6:26 am    Post subject: Reply with quote

Ne in Bett gehe ich erst wenn ich hier fertig bin das lässt mir sonst keine ruhe

Aber wenn wir grade mal bei Thema Grub sind ist es egal was man als Tiel in der /grub.conf einträgt ?

Ja oder ?
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Thu Jun 21, 2012 6:29 am    Post subject: Reply with quote

Ja, das ist nur, damit du weißt, was du startest. Sollte dein System halt schon beschreiben.
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Thu Jun 21, 2012 6:32 am    Post subject: Reply with quote

Ja gut zu wissen da weiß ich bescheid :D

Dann kann ja gleich mein reboot stattfinden hehe
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2903
Location: Bozen

PostPosted: Thu Jun 21, 2012 6:35 am    Post subject: Reply with quote

Wenn es dann klappt, nach der Anleitung wird /boot ja nicht automatisch eingehängt. Du musst es jedesmal per Hand einhängen. Nicht vergessen. Sonst schreibst du den Ordner doppelt. Und wenn es dann klappt, dann war es doch egal, warum es bei der Installation gehakt hat. Und wenn nicht, dann poste mal deine fstab.
Back to top
View user's profile Send private message
linux88
n00b
n00b


Joined: 05 Jun 2012
Posts: 72

PostPosted: Thu Jun 21, 2012 6:46 am    Post subject: Reply with quote

Quote:
/dev/sda1 /boot ext2 defaults,noatime 1 2
/dev/sda2 none swap sw 0 0
/dev/sda3 / ext3 noatime 0 1

/dev/cdrom /mnt/cdrom auto noauto,user 0 0

proc /proc proc defaults 0 0
shm /dev/shm tmpfs nodev,nosuid,noexec 0 0


so Schauts aus


Bin noch was am emergen danach kommt der reboot
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum