Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Fatal server error: no screens found
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Hennich
n00b
n00b


Joined: 14 Sep 2011
Posts: 6

PostPosted: Wed Jun 27, 2012 2:51 pm    Post subject: Fatal server error: no screens found Reply with quote

Hallo,

Ich habe vor einer Weile einen Kernel-Update durchgeführt und seitdem läuft mein X nicht mehr.
Wenn ich startx ausführen will, kommt
Code:

xauth:  file /home/hennich/.Xauthority does not exist


X.Org X Server 1.12.2
Release Date: 2012-05-29
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.12-gentoo x86_64 Gentoo
Current Operating System: Linux hennich-laptop 3.4.2-gentoo-r1 #7 SMP Mon Jun 25 11:50:29 BST 2012 x86_64
Kernel command line: root=/dev/sda5 video=uvesafb:mtrr:3,ywrap,1440x900-32@70,nouveau.modset=0
Build Date: 03 June 2012  01:27:44AM
 
Current version of pixman: 0.26.0
   Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jun 27 17:38:39 2012
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
ERROR: could not insert 'nvidia': Exec format error

Fatal server error:
no screens found

Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
Please also check the log file at "/var/log/Xorg.0.log" for additional information.

Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error


Der Inhalt von /var/log/Xorg.0.log erscheint mir etwas zu groß, deshalb nur verlinkt, nebst xorg.conf und make.conf:
http://users.informatik.uni-halle.de/~abefc/errors/


Ich vermute, dass ich bei den Kernel-Konfigurationen etwas vergessen habe. Aber ich habe in letzter Zeit so einige ergoogelte Lösungen versucht und nicht davon half.
nvidia-drivers habe ich auch nach Kompilieren des Kernels mehrfach emerged.
Hat jemand eine Idee, wie ich X wieder zum laufen kriege?

Grafikkarte: GeForce G210M
Treiber: nvidia-drivers
Kernel: 3.4.2.-r1

Ich hoffe, ich habe alle nötigen Informationen angegeben und freue mich auf Antworten.

Hennich
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1188

PostPosted: Wed Jun 27, 2012 3:10 pm    Post subject: Reply with quote

im xorg.log ist ein hinweise auf das kernellog (Dmesg), kannst du das auch bitte posten?
Back to top
View user's profile Send private message
Hennich
n00b
n00b


Joined: 14 Sep 2011
Posts: 6

PostPosted: Wed Jun 27, 2012 3:27 pm    Post subject: Reply with quote

Da auch die Datei recht groß ist, hab ich sie unter obigem Link mit hochgeladen.

Ich hoffe sowas verstößt nicht gegen irgendwelche Nettiquette.^^
Back to top
View user's profile Send private message
Christian99
Veteran
Veteran


Joined: 28 May 2009
Posts: 1188

PostPosted: Wed Jun 27, 2012 4:26 pm    Post subject: Reply with quote

da steht nix dazu drin, hast du den rechner grad erst neu gestartet und noch nicht probiert x zu starten? wenn ja, dann bitte mal versuchen x zu starten und dann die ausgabe von dmesg.
auhc informativ wäre die ausgabe von "lsmod | grep nvidia"
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3716
Location: Germany

PostPosted: Wed Jun 27, 2012 11:05 pm    Post subject: Reply with quote

Hallo Hennich

Huh, du hast uvesafb, nouveau mit KMS, und den proprietären nvidia Treiber zusammen im System, das wird i.d.R. schief gehen (sofern man sie nicht trennt).
(zudem ist in der xorg.conf auch noch der "nv" Treiber gesetzt)

Ich denke bevor man hier irgendwelche Tipps oder Ratschläge postet sollte noch genannt werden welcher Treiber denn letztendlich genutzt werden soll.
Was für Grafikkarte(n) sind denn verfügbar - poste am besten auch noch die
Code:
 lspci | grep VGA
Ausgabe:
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3258
Location: de

PostPosted: Thu Jun 28, 2012 11:00 am    Post subject: Reply with quote

Xorg.0.log beschwert sich, dass das Nvidia-Modul nicht geladen werden kann. In der Xorg.conf hast du aber den nv-Treiber drinstehen.

xorg.conf: -> nv-Treiber
make.conf: -> Nvidida-Treiber
Kernel: -> noveau-Framebuffer-Treiber

Da passt was nicht zusammen.

Kommt 'ne Fehlermeldung, wenn du:
Code:
rmmod nvidia
modprobe nvidia

machst?

Ich verwende ebenfalls, den proprietären nvidida-Treiber für X, hab aber im Kernel als Framebuffer-Device uvesafb aktiviert und alles Nvidia-Spezifische rausgeschmissen.

Btw: Coole Frisur. 8)
Back to top
View user's profile Send private message
Hennich
n00b
n00b


Joined: 14 Sep 2011
Posts: 6

PostPosted: Fri Jun 29, 2012 1:43 pm    Post subject: Reply with quote

Danke für die Hinweise.
Da sind wohl noch ein paar Spuren meiner vielen versuche übrig geblieben.
Ich werd mich heut Abend mal da ransetzen. Bei dem schönen Wetter ruft erstmal noch das Real-Life. 8)
Back to top
View user's profile Send private message
Hennich
n00b
n00b


Joined: 14 Sep 2011
Posts: 6

PostPosted: Mon Jul 02, 2012 2:05 pm    Post subject: Reply with quote

Da ich nicht mehr genau weiß, wass ich alles geändert habe, habe ich die kernel-Quellen aktualisiert (auf 3.4.4), make silentoldconfig von meiner letzten funktionierenden config ausgehend nach bestem Gewissen ausgeführt und nvidia-drivers neu installiert.

Dann sorgte jedoch startx für die Fehlermeldungen
Code:

im modulpfad »clearlooks« konnte keine themen-engine gefunden werden
im modulpfad »crux-engine« konnte keine themen-engine gefunden werden


Zudem blieb der Rechner nach startx bei einem schwarzen Bildschirm, den ich nur noch über Neustart (bzw Strg+Alt+Shift+S-Abf+REISUB) los wurde.

Ich habe dann vesucht dieses Problem durch Neuinstallation von gtk+ und Installation von gtk-engines zu beheben.
Jetzt kommt bei startx die Fehlermeldung
Code:

E: [pulseaudio] main.c: Start des Daemons fehlgeschlagen.

** (terminal:9240): WARNING **: Invalid borders specified for theme pixmap:
        /home/hennich/.themes/Elegant Dark/gtk-2.0/scrollbar/trough-scrollbar-vert.png,
borders don't fit within the image


Das Verwirrende: Elegant Dark ist noch mein altes Ubuntu-Theme. Eigentlich sollte das garnicht angefasst werden.
Ich nutze den awesome window-manager.

An welcher Stelle genau müsste startx eigenlich den window-manager aufrufen (d.h. wo/wie wird festgelegt, welcher verwendet wird)?

PS: Grafikkarte
Code:

01:00.0 VGA compatible controller: NVIDIA Corporation GT218 [GeForce G210M] (rev a2)

lsmod erzeugt bei mir eine leere Ausgabe (abgesehen vom Tabellenkopf), sowohl als Nutzer als auch als root

PPS@musv: Habe ich irgendwo auf meiner Seite ein Bild von mir oder hast du gegoogelt?^^
Back to top
View user's profile Send private message
Hennich
n00b
n00b


Joined: 14 Sep 2011
Posts: 6

PostPosted: Sat Jul 07, 2012 3:46 pm    Post subject: Reply with quote

Ist noch jemandem eine Idee dazu gekommen?
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3258
Location: de

PostPosted: Sat Jul 07, 2012 4:57 pm    Post subject: Reply with quote

Hennich wrote:
An welcher Stelle genau müsste startx eigenlich den window-manager aufrufen (d.h. wo/wie wird festgelegt, welcher verwendet wird)?

Steht in der ~/.xinitrc, sofern du keinen Login-Manager verwendest.

Bei mir wäre das z.B.
.xinitrc:
#!/bin/sh
exec /usr/bin/e16


So ohne wirkliche Fehlermeldung ist es natürlich schwierig zu analysieren, warum jetzt Deine Kiste abschmiert.

Um in Deinem Fall mal die ganzen Überbleibsel von früher als Fehlerquelle auszuschließen, leg mal einen Testuser mit entsprechender .xinitrc an und starte das X über den. Damit schließt du schon mal irgendwelche GTK-Themeeinstellungen aus.

Zu Pulseaudio kann ich nicht viel sagen, ich hab 2 mal probiert, das Teil irgendwie vernünftig zum Laufen zu kriegen und hab's beide Male aufgegeben. Ich brauch's auch nicht wirklich. Ist nur'n unnötiger Daemon. Sofern das bei Dir ähnlich ist, deinstallier das Teil.

Hennich wrote:
lsmod erzeugt bei mir eine leere Ausgabe (abgesehen vom Tabellenkopf), sowohl als Nutzer als auch als root

lsmod braucht keine Root-Rechte. Wenn da bei Dir kein nvidia geladen ist, wirst du wohl einen anderen Treiber (noveau?) benutzen. Was passiert denn bei:
Code:
modprobe nvidia

Also bevor du das X startest.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3716
Location: Germany

PostPosted: Sat Jul 07, 2012 6:09 pm    Post subject: Reply with quote

Hennich dmesg wrote:
Code:
[    0.000000] Linux version 3.4.2-gentoo-r1 (root@hennich-laptop) (gcc version 4.6.3 (Gentoo 4.6.3 p1.3, pie-0.5.1) ) #7 SMP Mon Jun 25 11:50:29 BST 2012
[    0.000000] Command line: root=/dev/sda5 video=uvesafb:mtrr:3,ywrap,1440x900-32@70,nouveau.modset=0
....
[    0.383104] uvesafb: unrecognized option nouveau.modset=0
[    0.383592] uvesafb: failed to execute /sbin/v86d
[    0.383933] uvesafb: make sure that the v86d helper is installed and executable
[    0.384559] uvesafb: Getting VBE info block failed (eax=0x4f00, err=-2)
[    0.384902] uvesafb: vbe_init() failed with -22
[    0.385257] uvesafb: probe of uvesafb.0 failed with error -22
.....
[    0.486817] [drm] Initialized drm 1.1.0 20060810
......
[    2.568937] Console: switching to colour frame buffer device 170x48
[    2.570508] fb0: nouveaufb frame buffer device
[    2.570510] drm: registered panic notifier
[    2.570514] [drm] Initialized nouveau 1.0.0 20120316 for 0000:01:00.0 on minor 0

Ja, der DRM_NOUVEAU=y (Kernel Mode Setting) Framebuffer beißt sich mit dem proprietären nvidia Treiber.
Vermutlich wird durch den Tippfehler
Code:
,nouveau.modset=0
KMS auch nicht wirklich deaktiviert.
Richtig wäre vermutlich
Code:
 nouveau.modeset=0
Beachte auch das zwischen dem video=uvesafb:blub,bla Befehl und dem nouveau.modeset=0 statt ein Komma, ein Leerzeichen gesetzt werden sollte.

Aber:
Da du vermutlich den proprietären nvidia Treiber nutzen möchtest ist es wahrscheinlich besser die ganzen DRM und DRM_NOUVEAU Treiber im Kernel zu deaktivieren.
Diese findest du im "make menuconfig" unter
Code:
Device Drivers  --->
Graphics support  --->
Deaktiviere hier
Code:
< > /dev/agpgart (AGP Support)  --->
< > Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->

Damit sollte sich dann vermutlich das nvidia Modul fehlerfrei laden lassen. (bzw normal wird es schon automatisch geladen - siehe dann im lsmod)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum