Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] USB Cam will einfach nicht
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Obelix
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2011
Posts: 100

PostPosted: Fri Jun 29, 2012 8:17 am    Post subject: [Solved] USB Cam will einfach nicht Reply with quote

Hoi,

ich beiß gleich in die Tischkante - und kann nicht mal ein Bild einstellen, weil die Kamera nicht geht ;)

Eigentlich will ich auf was ganz anderes raus, aber zum Test bräuchte ich die USB-Cam.
Es ist eine TechSolo, die sich folgendermaßen meldet:

Code:
[  527.518021] usb 5-2: ep0 maxpacket = 8
[  527.524321] usb 5-2: default language 0x0409
[  527.528322] usb 5-2: udev 4, busnum 5, minor = 515
[  527.528325] usb 5-2: New USB device found, idVendor=04fc, idProduct=0561
[  527.528327] usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  527.528329] usb 5-2: Product: Generic Digital camera
[  527.528330] usb 5-2: Manufacturer: Sunplus Technology Co., Ltd.
[  527.528386] usb 5-2: usb_probe_device
[  527.528389] usb 5-2: configuration #1 chosen from 1 choice
[  527.530313] usb 5-2: adding 5-2:1.0 (config #1, interface 0)
[  527.530369] hub 5-0:1.0: state 7 ports 3 chg 0000 evt 0004


Treiber sind folgende als Module vorhanden

Code:
gspca_sunplus           9983  0
gspca_main             17297  1 gspca_sunplus
videodev               66929  1 gspca_main
v4l2_compat_ioctl32     7807  1 videodev


leider wird kein /dev/video0 oder ähnliches angelegt. Weder automatisch, noch wenn ich
Code:
modprobe gspca_sunplus

mache. Zwar melden sich die Treiber mit
Code:
Jun 29 09:57:57 ObelixPC kernel: [ 1152.293303] Linux video capture interface: v2.00
Jun 29 09:57:57 ObelixPC kernel: [ 1152.294075] gspca_main: v2.14.0 registered
Jun 29 09:57:57 ObelixPC kernel: [ 1152.294688] usbcore: registered new interface driver sunplus

aber es gibt trotzdem kein device und außerdem sollte das ja automatisch passieren, wenn die Kamera eingesteckt wird.

Viel kann eigentlich nicht mehr fehlen, aber ein bißchen nicht gehen ist immer noch zu wenig ;)

Danke schon mal im Voraus
Obelix
_________________
read my lips: NO MORE BUGS!!


Last edited by Obelix on Mon Jul 02, 2012 3:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
SinoTech
Advocate
Advocate


Joined: 20 Mar 2004
Posts: 2579
Location: Neunkirchen / Saarland / Germany

PostPosted: Sun Jul 01, 2012 11:39 am    Post subject: Reply with quote

Probier doch mal diesen Treiber:

Code:

Device Drivers -->
    <*> Multimedia support  --->
        [*]   Video capture adapters (NEW)  --->
            [*]   V4L USB devices (NEW)  --->
                <M>   GSPCA based webcams (NEW)  --->
                    <M>   SPCA561 USB Camera Driver


Cheers,

Sino
_________________
Help to answer the unanswered
Back to top
View user's profile Send private message
Obelix
Tux's lil' helper
Tux's lil' helper


Joined: 22 Aug 2011
Posts: 100

PostPosted: Sun Jul 01, 2012 6:10 pm    Post subject: Reply with quote

...du bist ein Hund.

Ich habe mich schon für pfiffig gehalten, weil ich gesehen habe, dass ein techsolo Kamera eigentlich von Sunplus ist, aber wie kommt man denn darauf, dass man diesen Treiber verwendet...?

Es klappt, und für alle, die wie ich das Teil mit Skype in Verbindung verwenden wollen, hier noch der Hinweis, dass man Skyp folgendermaßen starten muss, damit die Kamera erkannt wird:

LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so /opt/bin/skype "$@"

oder aber im Menü folgendes hinterlegen in der Verknüpfung zu Skype:
env LD_PRELOAD=/usr/lib32/libv4l/v4l1compat.so skype

Schönen Abend noch allen
Obelix
_________________
read my lips: NO MORE BUGS!!
Back to top
View user's profile Send private message
SinoTech
Advocate
Advocate


Joined: 20 Mar 2004
Posts: 2579
Location: Neunkirchen / Saarland / Germany

PostPosted: Mon Jul 02, 2012 1:45 am    Post subject: Reply with quote

Obelix wrote:
...du bist ein Hund.

Ich habe mich schon für pfiffig gehalten, weil ich gesehen habe, dass ein techsolo Kamera eigentlich von Sunplus ist, aber wie kommt man denn darauf, dass man diesen Treiber verwendet...?
[...]

Hab gegoogelt ;-) und nebenbei passt auch die USB-ID (idProduct=0561) dazu ( SPCA561[...])

Cheers,

Sino
_________________
Help to answer the unanswered
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum