Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved][Laptop] Bildschirmhelligkeit nicht mehr veränderbar
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jul 06, 2012 6:55 am    Post subject: [Solved][Laptop] Bildschirmhelligkeit nicht mehr veränderbar Reply with quote

Hallo,

seit irgendeinem Kernel-Update scheint die Einstellung der Bildschirmhelligkeit (unter KDE) nicht mehr zu gehen.
Im Internet habe ich gesehen, dass das über /proc/acpi/video oder /sys/class/backlight gehen soll.
Beide Verzeichnisse sind aber leer oder nicht existent.

CONFIG_ACPI_VIDEO ist aber gesetzt.

Hat jemand einen Rat?
Kernel ist im Moment: 3.4.0

Code:
$grep BACKLIGHT //usr/src/linux/.config
# CONFIG_FB_BACKLIGHT is not set
CONFIG_BACKLIGHT_LCD_SUPPORT=y
CONFIG_BACKLIGHT_CLASS_DEVICE=y
CONFIG_BACKLIGHT_GENERIC=y
# CONFIG_BACKLIGHT_PROGEAR is not set
# CONFIG_BACKLIGHT_APPLE is not set
# CONFIG_BACKLIGHT_SAHARA is not set
# CONFIG_BACKLIGHT_ADP8860 is not set
# CONFIG_BACKLIGHT_ADP8870 is not set
# CONFIG_BACKLIGHT_LP855X is not set
# CONFIG_LEDS_TRIGGER_BACKLIGHT is not set

$grep ACPI //usr/src/linux/.config
CONFIG_X86_64_ACPI_NUMA=y
# Power management and ACPI options
CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_PROCFS=y
CONFIG_ACPI_PROCFS_POWER=y
# CONFIG_ACPI_EC_DEBUGFS is not set
CONFIG_ACPI_PROC_EVENT=y
CONFIG_ACPI_AC=y
CONFIG_ACPI_BATTERY=y
CONFIG_ACPI_BUTTON=y
CONFIG_ACPI_VIDEO=y
CONFIG_ACPI_FAN=y
CONFIG_ACPI_DOCK=y
CONFIG_ACPI_PROCESSOR=y
CONFIG_ACPI_HOTPLUG_CPU=y
# CONFIG_ACPI_PROCESSOR_AGGREGATOR is not set
CONFIG_ACPI_THERMAL=y
CONFIG_ACPI_NUMA=y
# CONFIG_ACPI_CUSTOM_DSDT is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
# CONFIG_ACPI_PCI_SLOT is not set
CONFIG_ACPI_CONTAINER=y
# CONFIG_ACPI_SBS is not set
# CONFIG_ACPI_HED is not set
# CONFIG_ACPI_CUSTOM_METHOD is not set
# CONFIG_ACPI_BGRT is not set
# CONFIG_ACPI_APEI is not set
CONFIG_X86_ACPI_CPUFREQ=y
# CONFIG_HOTPLUG_PCI_ACPI is not set
CONFIG_PNPACPI=y
CONFIG_ATA_ACPI=y
# ACPI drivers
# ACPI drivers
# CONFIG_SENSORS_ACPI_POWER is not set
# CONFIG_THINKPAD_ACPI is not set
# CONFIG_ACPI_WMI is not set
# CONFIG_ACPI_CMPC is not set


Danke
Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke


Last edited by Finswimmer on Fri Jul 06, 2012 11:24 am; edited 1 time in total
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1792
Location: Oranienburg/Germany

PostPosted: Fri Jul 06, 2012 9:38 am    Post subject: Reply with quote

Hi Tobi,

von welchem Hersteller ist dein NB. Mein Samsung Netbook benötigt neben den üblichen Kerneltreibern noch das Paket app-laptop/easy-slow-down-manager. Da waren erst die nötigen Kerneltreiber drin. :(

MfG. Stefan
_________________
1st: i5-4570, 16GB, 1.75TB
2nd: i5-4570, 16GB, 620GB
3rd: i5-4570, 16GB, 10,5TB
4th: Asus N61VN, 8GB, 240GB
5th: C2D T7200, 2GB, 16GB USB + NFS
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jul 06, 2012 10:00 am    Post subject: Reply with quote

Hi,

Laptop: Sony VPCEB1Z1E
GraKa: Radeon HD 5650

Es ging ja schonmal...
Im Moment gehe ich davon aus, dass es am Kernel liegt. Könnte aber auch mit einem Update von X und Konsorten gekommen sein...?
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
giga89
Apprentice
Apprentice


Joined: 30 Mar 2005
Posts: 153

PostPosted: Fri Jul 06, 2012 10:04 am    Post subject: Reply with quote

Hast du es mal mit x11-apps/xbacklight -inc/-dec versucht? Damit verhelfe ich mir immer in awesome, in KDE funktioniert es per Hotkeys. Falls es damit funktioniert, könnte es auch an KDE bzw. Hotkeys liegen?
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jul 06, 2012 11:16 am    Post subject: Reply with quote

$xbacklight
No outputs have backlight property

auch als root.

Unter Ubuntu 12.04 gibt es hier:
ls /sys/class/backlight/
ein acpi_video

das habe ich aber defintiv drin:
$grep CONFIG_ACPI_VIDEO .config
CONFIG_ACPI_VIDEO=y

Irgendwie verstehe ich das grade nicht mehr...
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jul 06, 2012 11:24 am    Post subject: Reply with quote

Solved:
Ich habe im Internet gefunden, dass man die Kernel-Option acpi_backlight=vendor anhängen muss.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 3672
Location: Germany

PostPosted: Fri Jul 06, 2012 2:11 pm    Post subject: Reply with quote

Hm, sofern nicht gesetzt ist CONFIG_SONY_LAPTOP
eventuell auch eine bessere Alternative?
[ungetestet! - ich hab kein Sony Laptop]
Code:
CONFIG_SONY_LAPTOP:

This mini-driver drives the SNC and SPIC devices present in the ACPI
BIOS of the Sony Vaio laptops.

It gives access to some extra laptop functionalities like Bluetooth,
screen brightness control, Fn keys and allows powering on/off some
devices.

Read <file:Documentation/laptops/sony-laptop.txt> for more information.

Symbol: SONY_LAPTOP [=n]
Type  : tristate
Prompt: Sony Laptop Extras
Defined at drivers/platform/x86/Kconfig:266
Depends on: X86 [=y] && X86_PLATFORM_DEVICES [=y] && ACPI [=y] && INPUT [=y] && RFKILL [=m]
Location:
  -> Device Drivers
     -> X86 Platform Specific Device Drivers (X86_PLATFORM_DEVICES [=y])
Selects: BACKLIGHT_CLASS_DEVICE [=y]
(ist aus Linux/i386 3.4.4-gentoo)
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5467
Location: Langen (Hessen), Germany

PostPosted: Fri Jul 06, 2012 3:46 pm    Post subject: Reply with quote

Das ist gesetzt und hat auch die ganze Zeit alleine funktioniert.
Jetzt ist wohl noch was weiteres nötig.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum