Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerge stop working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 6:49 pm    Post subject: emerge stop working Reply with quote

oh dear, I did

Code:
emerge -C sys-libs/zlib


now my emerge stop working at all. it says ImportError: libz.so.1: cannot open shared object file: No such file or directory
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7089
Location: Saint Amant, Acadiana

PostPosted: Thu Jul 19, 2012 6:56 pm    Post subject: Reply with quote

Download it from http://tinderbox.dev.gentoo.org/ , then re-emerge.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 7:00 pm    Post subject: Reply with quote

Jaglover wrote:
Download it from http://tinderbox.dev.gentoo.org/ , then re-emerge.

use wget to download? please give detail commands, thank you
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7089
Location: Saint Amant, Acadiana

PostPosted: Thu Jul 19, 2012 7:03 pm    Post subject: Reply with quote

For 64-bit
Code:
wget http://tinderbox.dev.gentoo.org/default-linux/amd64/sys-libs/zlib-1.2.5-r2.tbz2

_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 7:30 pm    Post subject: Reply with quote

Jaglover wrote:
For 64-bit
Code:
wget http://tinderbox.dev.gentoo.org/default-linux/amd64/sys-libs/zlib-1.2.5-r2.tbz2


wget also looked for libz.so.1, i reboot my system to liveDVD, wget the file to the harddisk.

However, I got more serious problem at login stage, when i put in my user name "root", the system will not ask for password input, instead just show" login incorrect.

I will have to reinstall the whole system, disaster!
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7089
Location: Saint Amant, Acadiana

PostPosted: Thu Jul 19, 2012 7:35 pm    Post subject: Reply with quote

If your kernel boots just log on in single user mode (it will give you root shell without login password) and fix it.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 7:38 pm    Post subject: Reply with quote

Jaglover wrote:
If your kernel boots just log on in single user mode (it will give you root shell without login password) and fix it.

how do i get in to single user mode? the system prints many startup messages, and then Show

Quote:
Gentoo-zuoshulu login:
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7089
Location: Saint Amant, Acadiana

PostPosted: Thu Jul 19, 2012 7:43 pm    Post subject: Reply with quote

Append init=/bin/bash to kernel command line.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 7:52 pm    Post subject: Reply with quote

Jaglover wrote:
Append init=/bin/bash to kernel command line.

i suppose you meant append /bin/bash to keyword init one of config file, but which file?
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7089
Location: Saint Amant, Acadiana

PostPosted: Thu Jul 19, 2012 8:16 pm    Post subject: Reply with quote

Nope, I meant kernel command line as it is in bootloader.
Say, you have something like this
Code:
/boot/bzImage root=/dev/sda1
make it
Code:
/boot/bzImage root=/dev/sda1 init=/bin/bash

If you use Grub this is just a matter of hitting e and editing it for one time when you get to the Grub menu.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
zuoshulu
n00b
n00b


Joined: 13 Jul 2012
Posts: 34

PostPosted: Thu Jul 19, 2012 8:51 pm    Post subject: Reply with quote

Jaglover wrote:
Nope, I meant kernel command line as it is in bootloader.
Say, you have something like this
Code:
/boot/bzImage root=/dev/sda1
make it
Code:
/boot/bzImage root=/dev/sda1 init=/bin/bash

If you use Grub this is just a matter of hitting e and editing it for one time when you get to the Grub menu.


i hit e i saw 3 lines of grub settings, the 2nd line has
Quote:
init=/linuxrc ramdisk=8192 real_root=/dev/sda3


I modified /linuxrc to /bin/bash, then press esc


if press e again, the changes could not be saved!

else if press b, it will still ask login
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum