Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Unable to boot with DELL Inspiron N5110
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 278

PostPosted: Sat Jul 28, 2012 1:35 pm    Post subject: Unable to boot with DELL Inspiron N5110 Reply with quote

hello

i am confused i have changed to a new laptop and tried to do a reinstall from scratch but i dont know how to make it work.
I have now the classical "used greatest stack depth" message during boot sequence and it hangs on it.
can someone help me ?

here is the config file for the compiled kernel
http://pastebin.com/wTbWQh2T
and there the message log file
http://pastebin.com/qNG1VqAY

and finally my lspci config
Code:

(chroot) Gentoo-2012 log # lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.7 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 8 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 540M] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)
09:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 (rev 34)
0b:00.0 USB controller: Texas Instruments Device 8241 (rev 02)


thanks for your help
ade05fr
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Sat Jul 28, 2012 1:46 pm    Post subject: Reply with quote

The "Used greatest stack depth" is just informative, as long as it doesn't hit 0 it's not a problem. There's something else that it doesn't like....Need more information, what other messages does it do before it crashes?
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 278

PostPosted: Sat Jul 28, 2012 2:07 pm    Post subject: Reply with quote

the link to the messages file contains all the logs during the boot sequence.
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Sat Jul 28, 2012 2:51 pm    Post subject: Reply with quote

That's the chroot, it got to a prompt, did not look like a hang there...
Yes, I know it will be hard but need to get the screen capture of the hung state (which means you can't cat out logfiles...)...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 278

PostPosted: Sat Jul 28, 2012 4:20 pm    Post subject: Reply with quote

Ok can you explain me how to get the infos?
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43221
Location: 56N 3W

PostPosted: Sat Jul 28, 2012 4:34 pm    Post subject: Reply with quote

ade05fr,

Go through your kernel and turn off all the debug options. Rebuild and reinstall your kernel.
They always result in logspam and often interfere with normal operation.

The key items you need to boot are set correctly. Are you sure you are using the kernel that resulted from that config file ?

If the boot sequence gets a s far as saying "Press I for Interactive mode" do it, an see which service start is causing the issue.

... edit ...

Does it really halt or does the boot continue with a console using black text on a black background ?
Listen for HDD activity.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 278

PostPosted: Sun Jul 29, 2012 8:33 am    Post subject: Reply with quote

hello

here is the infos asked

grub.conf file + kernel config file
http://pastebin.com/sCKm7N1z

Message log after recompiling kernel without debug/log option
http://pastebin.com/VdmgZFf2

i feel a little bit confused because my kernel is well used but i dont succeed to define where is the problem. I have used the interactived mode to define which service is broken and it seems to be udev, at this step it hangs and nothing happen anymore (no activity HDD and no possibility to use the keyboard to force the execution or to swith in root mode with ctrl-D)

but i look in the message file it seems that it continued to executed till xdm service !!!really weird

can you help me ?

Updated : i have disabled nouveau.modeset in grub.conf and now it starts but not in good resolution (640x480 it seems) moreover xdm is not starting so i dont have my login screen but the console mode.
_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
ade05fr
Apprentice
Apprentice


Joined: 18 Sep 2006
Posts: 278

PostPosted: Sun Jul 29, 2012 10:49 am    Post subject: Reply with quote

I have found a dirty solutionm disable nouveau.modeset in grub.conf (set to 0 instead of 1)
i dont know how to solve it
Moreover i cant start xdm
here is the log files
Xorg.0.log
http://pastebin.com/mN86dZs1

message log file
http://pastebin.com/tVEEeLrE

and finally xdm.log file
http://pastebin.com/brG99hhD

any idea to solve my 2 issues ?
thanks a lot



ade05fr wrote:
hello

here is the infos asked

grub.conf file + kernel config file
http://pastebin.com/sCKm7N1z

Message log after recompiling kernel without debug/log option
http://pastebin.com/VdmgZFf2

i feel a little bit confused because my kernel is well used but i dont succeed to define where is the problem. I have used the interactived mode to define which service is broken and it seems to be udev, at this step it hangs and nothing happen anymore (no activity HDD and no possibility to use the keyboard to force the execution or to swith in root mode with ctrl-D)

but i look in the message file it seems that it continued to executed till xdm service !!!really weird

can you help me ?

Updated : i have disabled nouveau.modeset in grub.conf and now it starts but not in good resolution (640x480 it seems) moreover xdm is not starting so i dont have my login screen but the console mode.

_________________
[LAPTOP]
DELL Inspiron 5110
i5-2450M CPU @ 2.50GHz
[LINUX-GENTOO]
Gentoo 2018-0
kernel 5.0.6
gnome 3.30
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum