Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Error on boot using VMware
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
nitto414
n00b
n00b


Joined: 30 Jul 2012
Posts: 2

PostPosted: Mon Jul 30, 2012 1:11 pm    Post subject: Error on boot using VMware Reply with quote

Hello,

I went through the steps of installing gentoo and I almost made it to the end without any issues!

Unfortunately, after completing setup 10 (configuring the bootloader) and rebooting I get the following error:

Booting 'Gentoo Linux 2.6.24-r5'
root (hd0,0)
Filesystem type is ext2fs, partition type 0x83
kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 real_root=/dev/sda3

Error 15: File not found

Press any key to continue...



Have a nice day
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Mon Jul 30, 2012 8:27 pm    Post subject: Reply with quote

nitto414,

Welcome to Gentoo.

You have read the handbook too literally.
Code:
Error 15: File not found
tells that one or more of the filenames you have used in grub.conf do not exist in /boot.
Its very unlikely you actually have a kernel called
Code:
kernel-genkernel-x86-2.6.24-gentoo-r5
and its matching initrd file.
You need to change the -2.6.24-gentoo-r5 part to whatever your kernel file is called in /boot. The initrd/initramfs file will have the same naminging issue.

The problem is that 2.6.24-gentoo-r5 was one of the possible options when the handbook was updated in that section last but kernel versions change every few weeks.
Look in your /boot to see what the kernel and initramfs file names actually are then fix it in /boot/grub.conf

There is no need to chroot. Mount your /boot partition on /mnt/gentoo
do
Code:
ls /mnt/gentoo
to see the file names. Make a note of them.
Code:
nano -w /mnt/gentoo/grub/grub.conf
will allow you to make the changes.

Reboot to test.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
nitto414
n00b
n00b


Joined: 30 Jul 2012
Posts: 2

PostPosted: Tue Jul 31, 2012 11:57 am    Post subject: Reply with quote

Hello Neddy,

Thanks for the response.

I followed the first part of your directions and this is the result.

Code:

livecd ~ # ls /mnt/gentoo/
livecd ~ # mount /dev/sda3 /mnt/gentoo/
livecd ~ # mkdir /mnt/gentoo/boot/
mkdir: cannot create directory `/mnt/gentoo/boot/': File exists
livecd ~ # mount /dev/sda1 /mnt/gentoo/boot/
livecd ~ # ls /mnt/gentoo/
bin    dev  home  lib32  lost+found  mnt  portage-latest.tar.bz2  root  sbin                           sys  usr
boot   etc  lib   lib64  media       opt  proc                    run   stage3-amd64-20120621.tar.bz2  tmp  var



Also. When I ran

Code:
nano -w /mnt/gentoo/grub/grub.conf


It was a blank file. I pretty sure I am doing something incorrectly or just missing a couple steps.

Update:

Code:

livecd gentoo # cd boot/
livecd boot # ls
boot   grub   kernel-2.6.34-gentoo-r1 lost+found



Update 2:

At the grub menu and selected to edit the first boot option. I deleted

Code:
kernel-genkernel-x86-2.6.24-gentoo-r5


and used the tab autocomplete. When I did that and tried to boot with

Code:
/boot/kernel-2.6.34-gentoo-r1


It failed with

No filesystem could mount root, tried: reiserfs ext3... etc.
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)[/code]
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43198
Location: 56N 3W

PostPosted: Tue Jul 31, 2012 7:25 pm    Post subject: Reply with quote

nitto414,

Believe it or not, thats an improvement.
This time the kernel loaded but it could not mount your root filesystem.
Code:
unknown-block(1,0)
tells that the kernel cannot communicate with your hard drive at all.

There can be several reasons for this.
Going back to your original kernel line
Code:
kernel /boot/kernel-genkernel-x86-2.6.24-gentoo-r5 root=/dev/ram0 real_root=/dev/sda3

it says root=dev/ram0, which is also what block(1,0) means in the error message.
You may have told the kernel to use an initrd but not provided one, so /dev/ram0 is empty.

If you still have the root=/dev/ram0 there it needs to be root=/dev/sda3 ... thats all that should be after the kernel file name.

Next, if you intnded no not use an initrd, all the code needed to mount the root filesystem must be included in the kernel. Loadable modules are stored on the root filesystem and cannot be loaded until root is mounted.
Having loadable modules, which you need to mount root is a non started, unless you use an initrd.

You need SCSI Disk support as <*>, the SATA Menu as <*>, your HDD chipset driver as <*>, your root filesystem driver as <*> and your partition code as <*>. Thats either EFI or MSDOS, or both.
We know from
Code:
No filesystem could mount root, tried: reiserfs ext3... etc.
that you have some filestsrem built in. The kernel tried them all and listed them here. At the moment, the kernel isn't looking at sda3, so we can't tell if it can read your root filesystem.

Get back into your chroot and check/fix your kernel, reinstall it into /boot and reboot to test.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum