Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Trouble for reboot the machine after installed Gentoo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
yyljwyy
n00b
n00b


Joined: 24 Aug 2012
Posts: 3

PostPosted: Fri Aug 24, 2012 1:59 am    Post subject: Trouble for reboot the machine after installed Gentoo Reply with quote

I just installed Gentoo as Gentoo Handbook, and the system shows readonly filesystem.
Please help!

This is the first time I install the Linux. Would you please tell me the reason and give the detail solution?

Code:
kjournald starting. Commit interval 5 seconds
EXT3-fs (sda3): mounted filesystem with writeback data mode
VFS: Mounted root (ext3 filesystem) readonly on device 8:3.
devtmpfs: mounted
Freeing unused kernel memory: 392k
Write protecting the kernel text: 3608k
Write protecting the kernel read-only data: 1180k
/bin/bb: can't access tty; job control turned off


[*]Environment: VMware Workstation 8.0.4 build-744019
[*]Processors: 1
[*]Memory: 512M
[*]20G SCSI hard driver
[*]Network Adapter: NAT
Back to top
View user's profile Send private message
yyljwyy
n00b
n00b


Joined: 24 Aug 2012
Posts: 3

PostPosted: Fri Aug 24, 2012 5:01 pm    Post subject: [Solved] Reply with quote

I just viewed the /boot/grub/grub.conf and found the incorrect point:

incorrect version
Code:
kernel /boot/kernel-3.3.8-gentoo root=/dev/sda3 init=/bin/bb rootfstype=ext3


after corrected
Code:
kernel /boot/kernel-3.3.8-gentoo root=/dev/sda3
#init=/bin/bb rootfstype=ext3


And it looks OK.
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 699

PostPosted: Fri Aug 24, 2012 5:18 pm    Post subject: Reply with quote

you can also try init=/bin/bash or init=/linuxrc
Back to top
View user's profile Send private message
yyljwyy
n00b
n00b


Joined: 24 Aug 2012
Posts: 3

PostPosted: Sat Aug 25, 2012 3:09 am    Post subject: Reply with quote

I tried init=/bin/bash and init=/linuxrc, and found

    init=/bin/bash is failed as init=/bin/bb

    init=/linuxrc is OK, but the boot screen will show a failed message


Thank you for Sabayonino's suggestion!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum