Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] skype4pidgin-9999 requiring root privileges?
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message

Joined: 15 Jan 2005
Posts: 36

PostPosted: Sun Sep 09, 2012 9:20 am    Post subject: [SOLVED] skype4pidgin-9999 requiring root privileges? Reply with quote

I was trying to use skype with telepathy, which requires to install a libpurple plugin, currently only provided by skype4pidgin-9999 (overlay package: funtoo, flora or powerman).

The plugin shows very strange behavoir: I can only add Skype accounts when I run "systemsettings" as root, otherwise it fails to display the account name input field. This is especially confusing as skype is only running on a session bus of an unprivileged user. Kopete can connect to Skype just fine.

/etc/dbus-1/system.d/skype.conf :
<!DOCTYPE busconfig PUBLIC "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"

  <!-- ../system.conf have denied everything, so we just punch some holes -->

  <policy context="default">
    <allow own="com.Skype.API"/>

    <allow send_destination="com.Skype.API"/>
    <allow receive_sender="com.Skype.API"/>

    <allow send_path="/com/Skype"/>


It seemed odd to me that this file is in system.d instead of session.d, so I tried moving it (and restarting dbus), however without any perceivable effect.
Update: Added the file to both, and restarted dbus, which made it work.

some versions:
[IP-] [  ] net-im/kde-telepathy-meta-0.4.1:4
[IP-] [  ] net-im/ktp-accounts-kcm-0.4.1:4
[IP-] [  ] net-im/ktp-approver-0.4.1:4
[IP-] [  ] net-im/ktp-auth-handler-0.4.1:4
[IP-] [  ] net-im/ktp-common-internals-0.4.1:4
[IP-] [  ] net-im/ktp-contact-applet-0.4.1:4
[IP-] [  ] net-im/ktp-contact-list-0.4.1:4
[IP-] [  ] net-im/ktp-contact-runner-0.4.1:4
[IP-] [  ] net-im/ktp-filetransfer-handler-0.4.1:4
[IP-] [  ] net-im/ktp-kded-module-0.4.1:4
[IP-] [  ] net-im/ktp-presence-applet-0.4.1:4
[IP-] [  ] net-im/ktp-send-file-0.4.1:4
[IP-] [  ] net-im/ktp-text-ui-0.4.1:4
[IP-] [  ] net-im/pidgin-2.10.6:0
[IP-] [  ] net-im/skype-
[I-O] [  ] net-im/skype4pidgin-9999:0
[IP-] [  ] net-im/telepathy-connection-managers-1:0
[IP-] [  ] net-im/telepathy-logger-0.2.12-r1:0
[IP-] [  ] net-im/telepathy-mission-control-5.10.1:0
[IP-] [  ] net-irc/telepathy-idle-0.1.11:0
[IP-] [  ] net-libs/telepathy-farsight-0.0.19:0
[IP-] [  ] net-libs/telepathy-glib-0.16.5:0
[IP-] [  ] net-libs/telepathy-logger-qt-0.5.0-r1:0
[IP-] [  ] net-libs/telepathy-qt-0.9.2:0
[IP-] [  ] net-voip/telepathy-gabble-0.14.1:0
[IP-] [  ] net-voip/telepathy-haze-0.5.0:0
[IP-] [  ] net-voip/telepathy-rakia-0.6.8:0
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum