Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X server cannot detect any device [solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 04 Sep 2007
Posts: 58

PostPosted: Tue Sep 18, 2012 6:46 pm    Post subject: X server cannot detect any device [solved] Reply with quote

Not sure whether this should rather go to the hardware section but I guess this kind of overlaps. Anyway I am installing Gentoo on my Dell L502X laptop and most things appear to be working as far as I can tell by now. But I cannot get X to start. Now for the basics:

I have an Intel Core i7-2670QM CPU with integrated graphics as well as an nVidia Geforce GT 540M graphics card. I have installed xorg-server with intel and nvidia graphics options enabled and nvidia-drivers are installed. (emerge --info output will come at the bottom).

When I start X I get the following result


[ 1544.486]
X.Org X Server 1.13.0
Release Date: 2012-09-05
[  1544.488] X Protocol Version 11, Revision 0
[  1544.488] Build Operating System: Linux 3.5.3-gentoo x86_64 Gentoo
[  1544.489] Current Operating System: Linux erwin-linux 3.5.3-gentoo #6 SMP Mon Sep 17 23:09:54 CEST 2012 x86_64
[  1544.489] Kernel command line: root=/dev/sda7
[  1544.490] Build Date: 16 September 2012  07:06:13PM
[  1544.490] 
[  1544.491] Current version of pixman: 0.27.2
[  1544.492]    Before reporting problems, check
   to make sure that you have the latest version.
[  1544.492] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1544.494] (==) Log file: "/var/log/Xorg.0.log", Time: Tue Sep 18 20:29:16 2012
[  1544.494] (==) Using config file: "/etc/X11/xorg.conf"
[  1544.495] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[  1544.495] (==) No Layout section.  Using the first Screen section.
[  1544.495] (==) No screen section available. Using defaults.
[  1544.495] (**) |-->Screen "Default Screen Section" (0)
[  1544.495] (**) |   |-->Monitor "<default monitor>"
[  1544.495] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[  1544.495] (==) Automatically adding devices
[  1544.495] (==) Automatically enabling devices
[  1544.495] (==) Automatically adding GPU devices
[  1544.495] (WW) The directory "/usr/share/fonts/misc/" does not exist.
[  1544.495]    Entry deleted from font path.
[  1544.495] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
[  1544.495]    Entry deleted from font path.
[  1544.495] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[  1544.495]    Entry deleted from font path.
[  1544.495] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[  1544.495]    Entry deleted from font path.
[  1544.495] (WW) The directory "/usr/share/fonts/100dpi/" does not exist.
[  1544.495]    Entry deleted from font path.
[  1544.495] (WW) The directory "/usr/share/fonts/75dpi/" does not exist.
[  1544.495]    Entry deleted from font path.
[  1544.495] (==) FontPath set to:
[  1544.495] (==) ModulePath set to "/usr/lib64/xorg/modules"
[  1544.495] (II) The server relies on udev to provide the list of input devices.
   If no devices become available, reconfigure udev or disable AutoAddDevices.
[  1544.495] (II) Loader magic: 0x806c00
[  1544.495] (II) Module ABI versions:
[  1544.495]    X.Org ANSI C Emulation: 0.4
[  1544.495]    X.Org Video Driver: 13.0
[  1544.495]    X.Org XInput driver : 18.0
[  1544.495]    X.Org Server Extension : 7.0
[  1544.496] (II) config/udev: Adding drm device (/dev/dri/card0)
[  1544.497] (--) PCI:*(0:0:2:0) 8086:0116:1028:050e rev 9, Mem @ 0xf1400000/4194304, 0xe0000000/268435456, I/O @ 0x00004000/64
[  1544.497] (--) PCI: (0:1:0:0) 10de:0df4:1028:050e rev 161, Mem @ 0xf0000000/16777216, 0xc0000000/268435456, 0xd0000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/524288
[  1544.497] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[  1544.498] Initializing built-in extension Generic Event Extension
[  1544.498] Initializing built-in extension SHAPE
[  1544.499] Initializing built-in extension MIT-SHM
[  1544.499] Initializing built-in extension XInputExtension
[  1544.500] Initializing built-in extension XTEST
[  1544.501] Initializing built-in extension BIG-REQUESTS
[  1544.501] Initializing built-in extension SYNC
[  1544.502] Initializing built-in extension XKEYBOARD
[  1544.503] Initializing built-in extension XC-MISC
[  1544.503] Initializing built-in extension XINERAMA
[  1544.504] Initializing built-in extension XFIXES
[  1544.504] Initializing built-in extension RENDER
[  1544.505] Initializing built-in extension RANDR
[  1544.506] Initializing built-in extension COMPOSITE
[  1544.506] Initializing built-in extension DAMAGE
[  1544.507] Initializing built-in extension MIT-SCREEN-SAVER
[  1544.508] Initializing built-in extension DOUBLE-BUFFER
[  1544.508] Initializing built-in extension RECORD
[  1544.509] Initializing built-in extension DPMS
[  1544.510] Initializing built-in extension X-Resource
[  1544.510] Initializing built-in extension XVideo
[  1544.511] Initializing built-in extension XVideo-MotionCompensation
[  1544.512] Initializing built-in extension XFree86-VidModeExtension
[  1544.512] Initializing built-in extension XFree86-DGA
[  1544.513] Initializing built-in extension XFree86-DRI
[  1544.514] Initializing built-in extension DRI2
[  1544.514] (II) LoadModule: "glx"
[  1544.514] (II) Loading /usr/lib64/xorg/modules/extensions/
[  1544.522] (II) Module glx: vendor="NVIDIA Corporation"
[  1544.522]    compiled for 4.0.2, module version = 1.0.0
[  1544.522]    Module class: X.Org Server Extension
[  1544.522] (II) NVIDIA GLX Module  304.48  Sun Sep  9 20:42:38 PDT 2012
[  1544.522] Loading extension GLX
[  1544.522] (==) Matched intel as autoconfigured driver 0
[  1544.522] (==) Matched vesa as autoconfigured driver 1
[  1544.522] (==) Matched modesetting as autoconfigured driver 2
[  1544.522] (==) Matched fbdev as autoconfigured driver 3
[  1544.522] (==) Assigned the driver to the xf86ConfigLayout
[  1544.522] (II) LoadModule: "intel"
[  1544.522] (II) Loading /usr/lib64/xorg/modules/drivers/
[  1544.574] (II) Module intel: vendor="X.Org Foundation"
[  1544.574]    compiled for 1.13.0, module version = 2.20.7
[  1544.574]    Module class: X.Org Video Driver
[  1544.574]    ABI class: X.Org Video Driver, version 13.0
[  1544.574] (II) LoadModule: "vesa"
[  1544.601] (WW) Warning, couldn't open module vesa
[  1544.601] (II) UnloadModule: "vesa"
[  1544.601] (II) Unloading vesa
[  1544.601] (EE) Failed to load module "vesa" (module does not exist, 0)
[  1544.601] (II) LoadModule: "modesetting"
[  1544.601] (WW) Warning, couldn't open module modesetting
[  1544.601] (II) UnloadModule: "modesetting"
[  1544.601] (II) Unloading modesetting
[  1544.601] (EE) Failed to load module "modesetting" (module does not exist, 0)
[  1544.601] (II) LoadModule: "fbdev"
[  1544.601] (WW) Warning, couldn't open module fbdev
[  1544.601] (II) UnloadModule: "fbdev"
[  1544.601] (II) Unloading fbdev
[  1544.601] (EE) Failed to load module "fbdev" (module does not exist, 0)
[  1544.601] (II) intel: Driver for Intel Integrated Graphics Chipsets: i810,
   i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G, 915G,
   E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM, Pineview G,
   965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33, GM45,
   4 Series, G45/G43, Q45/Q43, G41, B43, B43, Clarkdale, Arrandale,
   Sandybridge Desktop (GT1), Sandybridge Desktop (GT2),
   Sandybridge Desktop (GT2+), Sandybridge Mobile (GT1),
   Sandybridge Mobile (GT2), Sandybridge Mobile (GT2+),
   Sandybridge Server, Ivybridge Mobile (GT1), Ivybridge Mobile (GT2),
   Ivybridge Desktop (GT1), Ivybridge Desktop (GT2), Ivybridge Server,
   Ivybridge Server (GT2), Haswell Desktop (GT1), Haswell Desktop (GT2),
   Haswell Desktop (GT2+), Haswell Mobile (GT1), Haswell Mobile (GT2),
   Haswell Mobile (GT2+), Haswell Server (GT1), Haswell Server (GT2),
   Haswell Server (GT2+), Haswell SDV Desktop (GT1),
   Haswell SDV Desktop (GT2), Haswell SDV Desktop (GT2+),
   Haswell SDV Mobile (GT1), Haswell SDV Mobile (GT2),
   Haswell SDV Mobile (GT2+), Haswell SDV Server (GT1),
   Haswell SDV Server (GT2), Haswell SDV Server (GT2+),
   Haswell ULT Desktop (GT1), Haswell ULT Desktop (GT2),
   Haswell ULT Desktop (GT2+), Haswell ULT Mobile (GT1),
   Haswell ULT Mobile (GT2), Haswell ULT Mobile (GT2+),
   Haswell ULT Server (GT1), Haswell ULT Server (GT2),
   Haswell ULT Server (GT2+), Haswell CRW Desktop (GT1),
   Haswell CRW Desktop (GT2), Haswell CRW Desktop (GT2+),
   Haswell CRW Mobile (GT1), Haswell CRW Mobile (GT2),
   Haswell CRW Mobile (GT2+), Haswell CRW Server (GT1),
   Haswell CRW Server (GT2), Haswell CRW Server (GT2+)
[  1544.602] (--) using VT number 7

[  1544.672] (EE) No devices detected.
[  1544.672]
Fatal server error:
[  1544.672] no screens found
[  1544.672] (EE)
Please consult the The X.Org Foundation support
 for help.
[  1544.672] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  1544.672] (EE)

This is without anything within /etc/X11/xorg.conf. I can use that file to force X to load the nVidia driver instead but the results don't make much of a difference. For some reason it worked right after the install but never again afterwards, which I fail to explain. Maybe that was still the installation kernel working for me but I am not able to reproduce it and I don't know what information to provide here.

Any suggestions on getting X to work are appreciated. I don't care too much about which graphics card is used but compositing would be a desireable feature (didn't work when I had X running).

As promised, here is my emerge --info:


Portage (default/linux/amd64/10.0/desktop, gcc-4.6.3, glibc-2.15-r2, 3.5.3-gentoo x86_64)
System uname: Linux-3.5.3-gentoo-x86_64-Intel-R-_Core-TM-_i7-2670QM_CPU_@_2.20GHz-with-gentoo-2.2
Timestamp of tree: Sat, 15 Sep 2012 15:15:01 +0000
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r2, 3.2.3-r1
dev-util/cmake:           2.8.9
dev-util/pkgconfig:       0.27.1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.10.5
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.3
sys-devel/binutils:       2.22.90
sys-devel/gcc:            4.5.3-r2, 4.6.3
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r3
sys-kernel/linux-headers: 3.5 (virtual/os-headers)
sys-libs/glibc:           2.15-r2
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -pipe -g -march=native"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -g -march=native"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="de en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg kde lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds pppd qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="canon" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="jruby ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Last edited by herbert12345 on Tue Sep 18, 2012 8:13 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Tue Sep 18, 2012 7:38 pm    Post subject: Reply with quote

use the intel; disable the nvidia seems to be the working option
Defund the FCC.
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 29 Aug 2012
Posts: 89
Location: Chicago

PostPosted: Tue Sep 18, 2012 7:40 pm    Post subject: Reply with quote

Seems similar to this:

"a lot of people are reporting this problem. It seems that the gentoo handbook has no mention of adding udev to the proper runlevel.

# rc-update add udev sysinit"
Back to top
View user's profile Send private message

Joined: 04 Sep 2007
Posts: 58

PostPosted: Tue Sep 18, 2012 8:13 pm    Post subject: Reply with quote


thanks to both of you. The combination of both did the trick. Actually I should add that udev goes automatically to that runlevel but the kernel needs to be built with

Device-Drivers --->
         Generic Driver Options  --->
      [*] Maintain a devtmpfs filesystem to mount at /dev

in order to start correctly. Reading bootup error messages might have made this easier for me :oops:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum