Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
(Solved)Need help with Setting manual ip address.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Thu Sep 20, 2012 7:06 pm    Post subject: (Solved)Need help with Setting manual ip address. Reply with quote

I finally got my gentoo up and running apar tfrom the manual ip address only 2 things are bothering me right now let me start by mentioning those
as i boot i get 2 errors (and 1 warning that says falling back to default settings, which is probably what i wanted anyhow)

Code:
Warning: rc_sys not defined in rc.conf. Falling back to automatic detection
hwclock: Cannot access the Hardware Clock via any known method.
hwlcock: Use the --debug option to see the details of our search for an access method.
Failed to set the system clock
mount: mount point /mnt/windows does not exist
Some local filesystem failed to mount


Code:
(logged in as root)
/etc/conf.d/hwclock --debug
-bash: /etc/conf.d/hwclock: Permission denied


comparatively to my last attempts i think i did fairly well to only get 2 errors. the former one is the one that scares me the most. May be because i did not edit the "/etc/conf.d/hwclock" with any options, i didn't see the point why (Edit: since i was mentioning it i decided to take another look at it, and saw it said if i dualboot i should set it to local instead of UTC, so i tried that, this did not fix this however) the clock if i use the "date" command is correct however, so i'm not sure if this even matters.
i don't know what bad things this might do, but i just thought i'd mention them here, if i could possibly do something about them. i would

i'm guessing the latter error has something to do with fstab, heres my windows setting
Code:
/dev/sda2       /mnt/windows    ntfs-3g         defaults,noatime                0 2

also tried
Code:
/dev/sda2       /mnt/Windows    ntfs-3g      quiet,defaults,locale=en_US.utf8,umask=0,noexec     0 0
(from wikipedia)

My real issue here however, is that i absolutely must have a manual ip configuration.

heres what it'd look like on windows:
Code:
IP Address: 192.168.1.39
Subnet mask: 255.255.255.0
Default Gateway: 192.168.1.254

Preferred DNS Server: 192.168.1.254
Alternate DNS Server: (unimportant)


I already confirmed my net works with dhcp

Heres how i tried set up my /etc/conf.d/net
Code:
config_eth0="192.168.1.39 netmask 255.255.255.0 brd 192.168.1.254"
routes_eth0="default via 192.168.1.254"


and i also tried
Code:
config_eth0="192.168.1.39 netmask 255.255.255.0 brd 192.168.1.254"
routes_eth0="192.168.1.254"


Last edited by rabcor on Thu Sep 20, 2012 8:57 pm; edited 4 times in total
Back to top
View user's profile Send private message
Ant P.
Watchman
Watchman


Joined: 18 Apr 2009
Posts: 5761

PostPosted: Thu Sep 20, 2012 7:25 pm    Post subject: Re: Need help with Setting manual ip address. (and 2 errors) Reply with quote

rabcor wrote:
Code:
(logged in as root)
/etc/conf.d/hwclock --debug
-bash: /etc/conf.d/hwclock: Permission denied

/etc/conf.d/hwclock is, as the directory name implies, a configuration file. Try running the actual hwclock binary.

Quote:
Heres how i tried set up my /etc/conf.d/net
Code:
config_eth0="192.168.1.39 netmask 255.255.255.0 brd 192.168.1.254"
routes_eth0="default via 192.168.1.254"

That looks correct. After you run /etc/init.d/net.eth0 start, what does "ifconfig -a" show?
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Thu Sep 20, 2012 7:45 pm    Post subject: Re: Need help with Setting manual ip address. (and 2 errors) Reply with quote

Ant P. wrote:
rabcor wrote:
Code:
(logged in as root)
/etc/conf.d/hwclock --debug
-bash: /etc/conf.d/hwclock: Permission denied

/etc/conf.d/hwclock is, as the directory name implies, a configuration file. Try running the actual hwclock binary.

Quote:
Heres how i tried set up my /etc/conf.d/net
Code:
config_eth0="192.168.1.39 netmask 255.255.255.0 brd 192.168.1.254"
routes_eth0="default via 192.168.1.254"

That looks correct. After you run /etc/init.d/net.eth0 start, what does "ifconfig -a" show?



hwclock binary? sorry, i'm an absolute, fresh noob you could say. i just spent near 40 hours installing this thing through trial and error, over and over again till i came just this close to success.
Guess:
Code:
hwclock --debug
hwclock from util-linux 2.20.1
hwclock: Open of /dev/rtc failed: No such file or directory
No useable clock interface found.
hwclock: Cannot access the Hardware clock via any known method.


net.eth0 has already been started (i set it to run at boot)

Code:
eth0
Link encap: Ethernet   HWaddr...
inet addr:192.168.1.39 Bcast:192.168.1.254 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:13 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:780 (780.0 B)   TX bytes:0 (0.0 B)


on dhcp:
Code:
eth0
Link encap: Ethernet   HWaddr...
inet addr:192.168.1.39 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:23 errors:0 dropped:0 overruns:0 frame:0
TX packets:21 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2018 (1.9 KiB)   TX bytes:1957 (1.9 KiB)


I tried changing the bcast to 192.168.1.255 but it didn't seem to make it connect in fact makes it worse (0 RX packets)


Last edited by rabcor on Thu Sep 20, 2012 8:12 pm; edited 2 times in total
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Thu Sep 20, 2012 8:01 pm    Post subject: Reply with quote

rabcor,

If you can't connect try:
Code:
echo "8.8.8.8" > /etc/resolv.conf

And you can add google's dns to your /etc/conf.d/net until you figure out your provider's:
Code:
config_eth0="192.168.1.39 netmask 255.255.255.0 brd 192.168.1.254"
routes_eth0="default via 192.168.1.254"
dns_servers_eth0="8.8.8.8 8.8.4.4"

About the clock, I have no clue at the moment :roll:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
rabcor
Apprentice
Apprentice


Joined: 05 Apr 2012
Posts: 200

PostPosted: Thu Sep 20, 2012 8:21 pm    Post subject: Reply with quote

This is what my router says...

Primary DNS: 212.30.200.200

Secondary DNS: 194.105.224.1

and that 8.8.8.8 thing didn't seem to help me

thanks a lot guys, this seemed to work

Code:
config_eth0="192.168.1.39 netmask 255.255.255.0 brd 192.168.1.255"
routes_eth0="default via 192.168.1.254"
dns_servers_eth0="212.30.200.200"


now, i'm really at the moment only worried about the clock, i don't wanna risk something going wrong.

should i just run genkernel again and enable realtimeclock in the menuconfig before i compile it? i'm pretty sure that might fix this error message, but i don't know how this whole thing works, or if it'd overwrite something i'd already made, etc, etc.

but if its safe to keep going and just installing my x windows system, (and other programs) i'll probably just ignore the error message, i don't really care if it doesn't do any harm.
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Thu Sep 20, 2012 8:31 pm    Post subject: Reply with quote

rabcor,

From the error message mount point /mnt/windows does not exist I would guess you don't have a /mnt/windows directory

And your net configuration of:
Code:
config_eth0="192.168.1.39 netmask 255.255.255.0 brd 192.168.1.254"
routes_eth0="default via 192.168.1.254"

isn't quite kosher. You're using the broadcast address for the gateway :(
Code:
routes_eth0="default via 192.168.1.1"

would be a lot better :D
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7089
Location: Saint Amant, Acadiana

PostPosted: Thu Sep 20, 2012 8:52 pm    Post subject: Reply with quote

192.168.1.254 is a valid gateway address, broadcast is 192.168.1.255.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
BillWho
Veteran
Veteran


Joined: 03 Mar 2012
Posts: 1600
Location: US

PostPosted: Thu Sep 20, 2012 8:59 pm    Post subject: Reply with quote

Jaglover wrote:
192.168.1.254 is a valid gateway address, broadcast is 192.168.1.255.
You're correct - 192.168.1.255 is broadcast - my bad :oops:
_________________
Good luck :wink:

Since installing gentoo, my life has become one long emerge :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum