Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
C2hs and language-c
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
blietaer
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2006
Posts: 103

PostPosted: Thu Dec 27, 2012 2:33 pm    Post subject: C2hs and language-c Reply with quote

Yihaaa!
Today I got an emerge world of about 185 new ebuilds, mainly Gnome upgrade !

...but it all fails down when trying to compile the c2hs

Quote:
>>> Emerging (34 of 184) dev-haskell/c2hs-0.16.4

Linking setup ...
./setup configure --ghc --prefix=/usr --with-compiler=/usr/bin/ghc --with-hc-pkg=/usr/bin/ghc-pkg --prefix=/usr --libdir=/usr/lib64 --libsubdir=c2hs-0.16.4/ghc-7.4.2 --datadir=/usr/share/ --datasubdir=c2hs-0.16.4/ghc-7.4.2 --ghc-option=-optl-Wl,-O1 --ghc-option=-optl-Wl,--as-needed --disable-executable-stripping --docdir=/usr/share/doc/c2hs-0.16.4 --verbose
Configuring c2hs-0.16.4...
setup: At least the following dependencies are missing:
language-c >=0.3.1.1 && <0.5




It complains it should find a language-c between l >=0.3.1.1 && <0.5

do I have to mention that it _is_ the case ?
:roll:

--> 0.4.2

Code:
eix language                                                                                                                                          ──(jeu,déc27)─┘

[I] dev-haskell/language-c
     Available versions:  0.3.2.1 (~)0.3.2.1-r1 (~)0.4.2 {doc hscolour profile}
     Installed versions:  0.4.2(23:23:34 13/04/12)(-doc -hscolour -profile)
     Homepage:            http://www.sivity.net/projects/language.c/
     Description:         Analysis and generation of C code



Where/why does the configure test fails then ?
Back to top
View user's profile Send private message
lxg
Veteran
Veteran


Joined: 12 Nov 2005
Posts: 1019
Location: Aachen, Germany

PostPosted: Thu Dec 27, 2012 9:37 pm    Post subject: Reply with quote

It could be that the language-c package is broken or outdated. Please emerge it again (use the -1 flag) and then run revdep-rebuild.
_________________
lxg.de – codebits and tech talk
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum