Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
tried to emerge gentoo-sources, and odd errors..help?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
loyalbluefox28
n00b
n00b


Joined: 29 Dec 2012
Posts: 1

PostPosted: Sat Dec 29, 2012 6:23 am    Post subject: tried to emerge gentoo-sources, and odd errors..help? Reply with quote

Well, this is my first time attempting to install Gentoo, and I've hit quite the snag and while I'm here I'm going to ask about USEflags because maybe I am thinking this error is stemming from typing in USEflags. So my question about USEflags is how are you supposed to type them in? I have all the ones written down that I want and the way that I entered them was:

nano -w etc/portage/make.conf

and then under where it said:

USE="bindist"

I typed all the other ones I wanted following the same form such as:

USE="java"

My question is: Is there a different way to enter USEflags that I am missing, or is the form that I used okay?

My second issue is when it came to:

emerge gentoo-sources

it gave me these lines of error:

/etc/portage/make.conf", line 133: [Errno 2] No such file or directory: '/etc/portage/USE'
Traceback (most recent call last):
File "/usr/bin/emerge", line 48, in <module>
retval = emerge_main()
File "/usr/lib/portage/pym/_emerge/main.py", line 1009, in emerge_main
settings, trees, mtimedb = load_emerge_config()
File "/usr/lib/portage/pym/portage/proxy/objectproxy.py", line 31, in __call__
return result(*args, **kwargs)
File "/usr/lib/portage/pym/_emerge/actions.py", line 3061, in load_emerge_config
trees = portage.create_trees(trees=trees, **kwargs)
File "/usr/lib/portage/pym/portage/__init__.py", line 522, in create_trees
env=env, eprefix=eprefix)
File "/usr/lib/portage/pym/portage/package/ebuild/config.py", line 334, in __init__
expand=make_conf) or {})
File "/usr/lib/portage/pym/portage/util/__init__.py", line 638, in getconfig
val=lex.get_token()
File "/usr/lib/python3.2/shlex.py", line 96, in get_token
spec = self.sourcehook(self.read_token())
File "/usr/lib/python3.2/shlex.py", line 251, in sourcehook
return (newfile, open(newfile, "r"))
IOError: [Errno 2] No such file or directory: '/etc/portage/USE'

Can anyone help? Thanks in advance!
Back to top
View user's profile Send private message
gabrielg
Tux's lil' helper
Tux's lil' helper


Joined: 16 Nov 2012
Posts: 93

PostPosted: Sat Dec 29, 2012 11:37 am    Post subject: Reply with quote

You are probably managing the USE variable wrongly in your /etc/portage/make.conf - assuming you will use flag1, flag2, flag 3 but _not_ flag4, you would type:
Code:
USE="flag1 flag2 flag3 -flag4"


Post your make.conf if things still don't work.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum