Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
USB devices ignored by new installation. [WORKAROUND]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
52midnight
Apprentice
Apprentice


Joined: 20 Mar 2012
Posts: 176
Location: Brisbane AU

PostPosted: Wed Mar 20, 2013 1:30 am    Post subject: USB devices ignored by new installation. [WORKAROUND] Reply with quote

I'm now starting to use the latest of my Gentoo installations. The first major problem is that peripheral USB devices aren't recognized. A USB memory stick present during the boot process is recognized by 'lsusb' along with the motherboard USB hubs, but the external powered hub permanently attached to the machine is ignored:
Code:
Bus 006 Device 002: ID 1307:0165 Transcend Information, Inc. 2GB/4GB Flash Drive
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

If the USB stick is removed and plugged back in it generates error messages:
Code:
[ 7109.841749] sd 5:0:0:0: [sdc] Attached SCSI removable disk
[ 7123.790057] usb 2-6: device descriptor read/64, error -110
[ 7139.050413] usb 2-6: device descriptor read/64, error -110
[ 7139.220374] hub 2-0:1.0: unable to enumerate USB device on port 6
[ 7139.540081] usb 2-6: new high-speed USB device number 87 using ehci_hcd
[ 7154.690618] usb 2-6: device descriptor read/64, error -110
[ 7169.950059] usb 2-6: device descriptor read/64, error -110
[ 7170.120386] hub 2-0:1.0: unable to enumerate USB device on port 6
[ 7170.440081] usb 2-6: new high-speed USB device number 89 using ehci_hcd
[ 7185.590055] usb 2-6: device descriptor read/64, error -110
[ 7200.850068] usb 2-6: device descriptor read/64, error -110
[ 7201.020351] hub 2-0:1.0: unable to enumerate USB device on port 6
[ 7201.340080] usb 2-6: new high-speed USB device number 91 using ehci_hcd
[ 7216.490124] usb 2-6: device descriptor read/64, error -110

Anything else is ignored when plugged-in. I turned to the official Gentoo documentation to discover:
Quote:
udev is meant to be used in combination with a 2.6 kernel

I'm using a 3.7.9 kernel. The USB page is equally uninformative.

This problem makes my new installation quite unusable. Could someone please asvise where to start debugging it?


Last edited by 52midnight on Wed Mar 20, 2013 4:22 am; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Mar 20, 2013 2:37 am    Post subject: Reply with quote

https://bugs.archlinux.org/task/33887 apparently some people are having this problem with kernels 3.7.6 to 3.7.9
_________________
Defund the FCC.
Back to top
View user's profile Send private message
52midnight
Apprentice
Apprentice


Joined: 20 Mar 2012
Posts: 176
Location: Brisbane AU

PostPosted: Wed Mar 20, 2013 2:43 am    Post subject: Reply with quote

Thanks for your advice. This is a major bug for anyone stuck with it, and to be present for several revisions seems perplexing.

Is there any way of hurrying up a fix?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7552
Location: Goose Creek SC

PostPosted: Wed Mar 20, 2013 2:52 am    Post subject: Reply with quote

put
Quote:
sys-kernel/gentoo-sources ~amd64
in /etc/portage/package.keywords
Code:
emerge gentoo-sources
eselect kernel set linux-3.8.3-gentoo-r1
and build a 3.8.3--r1 kernel
_________________
Defund the FCC.


Last edited by DONAHUE on Wed Mar 20, 2013 4:26 am; edited 1 time in total
Back to top
View user's profile Send private message
52midnight
Apprentice
Apprentice


Joined: 20 Mar 2012
Posts: 176
Location: Brisbane AU

PostPosted: Wed Mar 20, 2013 4:21 am    Post subject: Reply with quote

> and build a 3.8.3--r1 kernel

I'll thank you sincerely for your advice and hope that others can profit by it; but I'll have to confess to being one of those cowards who last compiled a kernel more than five years ago.

For those privately content with the coward's way out, I've swapped back to a 3.5.7 kernel from an installation CD (install-x86-minimal-20121213.iso) and everything works as advertised.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum