Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X Crash when using MasterPDFEditor[SOLVED]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message

Joined: 30 Jan 2004
Posts: 958

PostPosted: Wed Mar 20, 2013 11:33 am    Post subject: X Crash when using MasterPDFEditor[SOLVED] Reply with quote

Hi All:

When using masterpdfeditor build 1.8.23 (, X crashes with this:
[ 8631.261] (EE)
[ 8631.261] (EE) Backtrace:
[ 8631.261] (EE) 0: /usr/bin/X (xorg_backtrace+0x34) [0x596974]
[ 8631.261] (EE) 1: /usr/bin/X (0x400000+0x19a7a9) [0x59a7a9]
[ 8631.262] (EE) 2: /lib64/ (0x7fb64defb000+0x10460) [0x7fb64df0b460]
[ 8631.262] (EE) 3: /lib64/ (0x7fb64cb81000+0x13e16b) [0x7fb64ccbf16b]
[ 8631.262] (EE) 4: /usr/lib64/xorg/modules/ (0x7fb647933000+0x92888) [0x7fb6479c5888]
[ 8631.262] (EE) 5: /usr/lib64/xorg/modules/ (0x7fb647933000+0x8eadd) [0x7fb6479c1add]
[ 8631.262] (EE) 6: /usr/bin/X (0x400000+0x11d914) [0x51d914]
[ 8631.262] (EE) 7: /usr/bin/X (0x400000+0x117815) [0x517815]
[ 8631.262] (EE) 8: /usr/bin/X (0x400000+0x3b091) [0x43b091]
[ 8631.262] (EE) 9: /usr/bin/X (0x400000+0x29b5a) [0x429b5a]
[ 8631.262] (EE) 10: /lib64/ (__libc_start_main+0xfd) [0x7fb64cba34bd]
[ 8631.262] (EE) 11: /usr/bin/X (0x400000+0x29eb1) [0x429eb1]
[ 8631.262] (EE)
[ 8631.262] (EE) Segmentation fault at address 0x7fb63f77bcb0
[ 8631.262]
Fatal server error:
[ 8631.262] Caught signal 11 (Segmentation fault). Server aborting

This is my system:
jserinki7 jserink # emerge --info
Portage (default/linux/amd64/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.7.10-gentoo x86_64)
System uname: Linux-3.7.10-gentoo-x86_64-Intel-R-_Core-TM-_i7-2720QM_CPU_@_2.20GHz-with-gentoo-2.1
KiB Mem: 16394244 total, 14511904 free
KiB Swap: 19531248 total, 19531248 free
Timestamp of tree: Wed, 20 Mar 2013 08:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash: 4.2_p37
dev-java/java-config: 2.1.12-r1
dev-lang/python: 2.7.3-r3, 3.2.3-r2
dev-util/cmake: 2.8.9
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.1-r1
sys-apps/openrc: 0.11.8::pentoo
sys-apps/sandbox: 2.5
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.9.6-r3, 1.10.3, 1.11.6, 1.12.6
sys-devel/binutils: 2.22-r1
sys-devel/gcc: 4.4.5, 4.5.4, 4.6.3
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.6 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo zugaina science graaff games rebutia perl-experimental kde-sunset sabayon dottout pentoo DuPol dauleet my_overlay
CFLAGS="-march=corei7 -mtune=corei7 -O2 -pipe"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-march=corei7 -mtune=corei7 -O2 -pipe"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/var/lib/layman/zugaina /var/lib/layman/science /var/lib/layman/graaff /var/lib/layman/games /var/lib/layman/rebutia /var/lib/layman/perl-experimental /var/lib/layman/kde-sunset /var/lib/layman/sabayon /var/lib/layman/dottout /var/lib/layman/pentoo /var/lib/layman/DuPol /var/lib/layman/dauleet /usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bluetooth branding bzip2 cairo cdda cdr cleartype cli consolekit corefonts cracklib crypt cups curl cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fontforge foomaticdb fortran fortran2003 gdbm geoip gif gimp gnuplot gpm gstreamer gtk gzip hddtemp iconv ieee1394 ipv6 java java6 jpeg jpeg2k lcms libnotify lm_sensors lock lzma lzo mad matroska mmx mng modules motif mozilla mp3 mp4 mpeg mplayer msn mssql mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pango pcmcia pcre pdf perl png policykit posix ppds pulseaudio python qt3support qt4 quicktime rdesktop readline samba sdl seamonkey session smp sockets sound spell sse sse2 ssl startup-notification svg szip tcl tcpd theora threads thunar tiff tk truetype type1 udev udisks unicode upower usb v4l2 videos vim-syntax vorbis wavpack wifi wmf wxwidgets x264 xcb xcomposite xft xine xinerama xinetd xml xmp xpm xscreensaver xulrunner xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="nlpsolver pdfimport" LINGUAS="en en_GB" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 i386" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

Am using this:
* Searching for ati-drivers ...
[IP-] [ ] x11-drivers/ati-drivers-13.1:1

This is the only application this happens with this app, X is stable otherwise.
How to trouble shoot this?

Back to top
View user's profile Send private message

Joined: 30 Jan 2004
Posts: 958

PostPosted: Sun May 05, 2013 10:52 am    Post subject: Reply with quote

Updated MasterPDFeditor and the problem disappeared.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum