Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] emerge gcc-4.5.4 Fails on PowerBook G4
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Gentoo on PPC
View previous topic :: View next topic  
Author Message

Joined: 26 Jan 2010
Posts: 9

PostPosted: Tue Apr 02, 2013 11:08 pm    Post subject: [SOLVED] emerge gcc-4.5.4 Fails on PowerBook G4 Reply with quote

I'm having trouble emerging sys-devel/gcc-4.5.4 on a PowerBook G4 (PowerBook6,1). My Gentoo install is fresh; I've added no packages beyond what the Handbook suggests for bare bones. My profile is default/linux/powerpc/ppc64/13.0/32bit-userland

(I had the same problem with sysdevel/gcc-4.6.3, which is why I downgraded to this version.)

The current working version of gcc is also 4.5.4, as installed by the stage tarball. This re-emerge is a result of some new libraries emerged after my first emerge --sync and emerge -avuND. revdep-rebuild wanted to recompile gcc against the new in order to remove old dependencies.

Does anyone have any idea how I can get gcc to compile on my machine? I've been looking for days in the forums and on Google.

Here's the last 50 lines of the build.log:


HEADERS="auto-host.h ansidecl.h" DEFINES="USED_FOR_TARGET " \
/bin/sh /var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/ tconfig.h
echo '#endif' >> truncdfsf2.c
cp /var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/config/rs6000/sfp-machine.h sfp-machine.h
if [ xinfo = xinfo ]; then \
   makeinfo --split-size=5000000 --split-size=5000000 --split-size=5000000 --no-split -I . -I /var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc \
      -I /var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc/include -o doc/ /var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc/cpp.texi; \
/var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc/include/gcc-common.texi:12: @include `gcc-vers.texi': No such file or directory.
if [ xinfo = xinfo ]; then \
   makeinfo --split-size=5000000 --split-size=5000000 --split-size=5000000 --no-split -I . -I /var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc \
      -I /var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc/include -o doc/ /var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc/gcc.texi; \
/var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc/include/gcc-common.texi:12: @include `gcc-vers.texi': No such file or directory.
/var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc/gcc.texi:125: warning: undefined flag: version-GCC.
/var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc//invoke.texi:1376: warning: undefined flag: srcdir.
/var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc//invoke.texi:1375: @include `{No value for `srcdir'}/../libiberty/at-file.texi': No such file or directory.
makeinfo: Removing output file `doc/' due to errors; use --force to preserve.
make[3]: *** [doc/] Error 1
make[3]: *** Waiting for unfinished jobs....
/var/tmp/portage/sys-devel/gcc-4.5.4/work/gcc-4.5.4/gcc/doc//bugreport.texi:91: warning: undefined flag: BUGURL.
makeinfo: Removing output file `doc/' due to errors; use --force to preserve.
make[3]: *** [doc/] Error 1
make[3]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.5.4/work/build/gcc'
make[2]: *** [all-stage1-gcc] Error 2
make[2]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.5.4/work/build'
make[1]: *** [stage1-bubble] Error 2
make[1]: Leaving directory `/var/tmp/portage/sys-devel/gcc-4.5.4/work/build'
make: *** [bootstrap-lean] Error 2
emake failed
 * ERROR: sys-devel/gcc-4.5.4 failed (compile phase):
 *   emake failed with bootstrap-lean
 * Call stack:
 *, line   93:  Called src_compile
 *   environment, line 4095:  Called toolchain_src_compile
 *   environment, line 4751:  Called gcc_do_make
 *   environment, line 2392:  Called die
 * The specific snippet of code:
 * If you need support, post the output of `emerge --info '=sys-devel/gcc-4.5.4'`,
 * the complete build log and the output of `emerge -pqv '=sys-devel/gcc-4.5.4'`.
 * Please include /var/tmp/portage/sys-devel/gcc-4.5.4/work/build/gcc-build-logs.tar.bz2 in your bug report
 * The complete build log is located at '/var/tmp/portage/sys-devel/gcc-4.5.4/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-devel/gcc-4.5.4/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-devel/gcc-4.5.4/work/build'
 * S: '/var/tmp/portage/sys-devel/gcc-4.5.4/work/build'

emerge --info


PB12 sys-devel # emerge --info                       
Portage (default/linux/powerpc/ppc64/13.0/32bit-userland, gcc-4.5.4, glibc-2.15-r3, 3.7.10-gentoo ppc)
System uname: Linux-3.7.10-gentoo-ppc-7455,_altivec_supported-with-gentoo-2.1
KiB Mem:     1159160 total,     53532 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Mon, 01 Apr 2013 20:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.3-r3, 3.2.3-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.11.8
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.69
sys-devel/automake:       1.10.3, 1.11.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.5.4
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo
CFLAGS="-O2 -pipe -mcpu=G4 -maltivec -mabi=altivec -fno-strict-aliasing"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -pipe -mcpu=G4 -maltivec -mabi=altivec -fno-strict-aliasing"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="acl alsa berkdb bindist bzip2 cdr cli cracklib crypt cxx dri dvd fortran gcc64 gdbm gnome gpm gtk iconv ipv6 modules mudflap ncurses nls nptl openmp pam pcre ppc readline session ssl tcpd unicode zlib" ALSA_CARDS="aoa aoa-fabric-layout aoa-onyx aoa-soundbus aoa-soundbus-i2s aoa-tas aoa-toonie powermac usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nouveau fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"

emerge -pqv '=sys-devel/gcc-4.5.4'


[ebuild   R   ] sys-devel/gcc-4.5.4  USE="cxx fortran gtk* mudflap nls nptl openmp -altivec -doc (-fixed-point) -gcj -graphite (-hardened) (-libssp) -lto (-multilib) -multislot -nopie -nossp -objc -objc++ -objc-gc {-test} -vanilla (-bootstrap%) (-build%)"

cat /proc/cpuinfo


processor   : 0
cpu      : 7455, altivec supported
clock      : 867.000000MHz
revision   : 3.3 (pvr 8001 0303)
bogomips   : 108.20
timebase   : 33280357
platform   : PowerMac
model      : PowerBook6,1
machine      : PowerBook6,1
motherboard   : PowerBook6,1 MacRISC3 Power Macintosh
detected as   : 287 (PowerBook G4 12")
pmac flags   : 0000001a
L2 cache   : 256K unified
pmac-generation   : NewWorld
Memory      : 1152 MB

Thank You,

-=GT=- :)

Last edited by GrowlTiger on Wed Apr 03, 2013 7:02 pm; edited 1 time in total
Back to top
View user's profile Send private message

Joined: 02 May 2003
Posts: 7412

PostPosted: Tue Apr 02, 2013 11:30 pm    Post subject: Reply with quote
Back to top
View user's profile Send private message

Joined: 26 Jan 2010
Posts: 9

PostPosted: Wed Apr 03, 2013 7:01 pm    Post subject: Reply with quote

Much thanks for responding so quickly to my request, krinn! Your suggestion fixed my issue!

Apparently it was a bug having to do with the interaction between the gcc and texinfo packages.

Also thanks to DirtyHarry over in the Portage & Programming forum, and the guys at Bugzilla (Ryan Hill and Xarthisius) for squashing the bug.

Since they quickly added the fix to the Portage tree, all I had to do was:


# emerge --sync

# emerge --oneshot gcc

Now I've got a freshly compiled and updated gcc.

Thanks again. The Gentoo community is amazing!


Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on PPC All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum