Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
skype crash with my bluetooth headset
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
sangeshitou
n00b
n00b


Joined: 30 Aug 2013
Posts: 21

PostPosted: Sat Jan 11, 2014 1:19 pm    Post subject: skype crash with my bluetooth headset Reply with quote

Skype randomly crashes when i pick a call or during a call. But arecord never crash.

Updated:
It is definitely the bluetooth headset do not work. I pick up a call without bluetooth headset, the skype do not crash.


Quote:

os version: x86_64
bluetooth headset: jabra BT4010(pretty old product)


I check the dmesg log
Quote:
[ 151.211358] ehci-pci 0000:00:1a.0: shutdown urb ffff880110634000 ep3out-iso
[ 151.211362] ehci-pci 0000:00:1a.0: shutdown urb ffff880110634800 ep3out-iso
[ 151.211368] ehci-pci 0000:00:1a.0: shutdown urb ffff880110634600 ep3out-iso
[ 151.211372] ehci-pci 0000:00:1a.0: shutdown urb ffff880110853000 ep3out-iso
[ 151.211376] ehci-pci 0000:00:1a.0: shutdown urb ffff880110853800 ep3out-iso
[ 151.211380] ehci-pci 0000:00:1a.0: shutdown urb ffff880110853400 ep3out-iso
[ 178.252731] Bluetooth: hci0 SCO packet for unknown connection handle 65529
[ 178.252738] Bluetooth: hci0 SCO packet for unknown connection handle 0
[ 178.252741] Bluetooth: hci0 SCO packet for unknown connection handle 0
[ 178.252743] Bluetooth: hci0 SCO packet for unknown connection handle 0
[ 178.252745] Bluetooth: hci0 SCO packet for unknown connection handle 0
[ 178.252747] Bluetooth: hci0 SCO packet for unknown connection handle 0


google for a while, i find a post at https://forums.gentoo.org/viewtopic-t-615965-view-next.html?sid=1305a1df243a891c234c29d11bc13fc5 long ago, but it do not work for me.

Below is my kernel config related to bluetooth
Quote:

CONFIG_BT=m
CONFIG_BT_RFCOMM=m
CONFIG_BT_RFCOMM_TTY=y
CONFIG_BT_BNEP=m
# CONFIG_BT_BNEP_MC_FILTER is not set
# CONFIG_BT_BNEP_PROTO_FILTER is not set
CONFIG_BT_HIDP=m
CONFIG_BT_HCIBTUSB=m
CONFIG_BT_HCIUART=m
CONFIG_BT_HCIUART_H4=y
CONFIG_BT_HCIUART_BCSP=y
CONFIG_BT_HCIUART_ATH3K=y
CONFIG_BT_HCIUART_LL=y
CONFIG_BT_HCIUART_3WIRE=y
CONFIG_BT_HCIBCM203X=m
CONFIG_BT_HCIBPA10X=m
CONFIG_BT_HCIBFUSB=m
CONFIG_BT_HCIDTL1=m
CONFIG_BT_HCIBT3C=m
CONFIG_BT_HCIBLUECARD=m
CONFIG_BT_HCIBTUART=m
CONFIG_BT_HCIVHCI=m
CONFIG_BT_MRVL=m
CONFIG_BT_ATH3K=m
# CONFIG_TABLET_USB_KBTAB is not set
# CONFIG_INPUT_ATLAS_BTNS is not set
# CONFIG_SND_BT87X is not set
# CONFIG_TOSHIBA_BT_RFKILL is not set
# CONFIG_BTRFS_FS is not set
# CONFIG_RBTREE_TEST is not set



Below is my config related to alsa
Quote:
@hooks [
{
func load
files [
"/usr/share/alsa/bluetooth.conf"
]
errors false
}
]

pcm.board {
type plug;
slave {
pcm "hw:1,0"
}
}


pcm.!default board


Below is my config related to bluetooth audio
Quote:
# Configuration file for the audio service

# This section contains options which are not specific to any
# particular interface
[General]

# Allow PulseAudio to connect by default
# https://bugzilla.redhat.com/show_bug.cgi?id=964031
#Disable=Socket
Enable=Source,Sink,Media,Socket

# Switch to master role for incoming connections (defaults to true)
#Master=true

# If we want to disable support for specific services
# Defaults to supporting all implemented services
#Disable=Gateway,Source,Socket

# SCO routing. Either PCM or HCI (in which case audio is routed to/from ALSA)
# Defaults to HCI
#SCORouting=PCM

# Automatically connect both A2DP and HFP/HSP profiles for incoming
# connections. Some headsets that support both profiles will only connect the
# other one automatically so the default setting of true is usually a good
# idea.
#AutoConnect=true
#

# Headset interface specific options (i.e. options which affect how the audio
# service interacts with remote headset devices)
[Headset]

# Set to true to support HFP, false means only HSP is supported
# Defaults to true
HFP=true

# Maximum number of connected HSP/HFP devices per adapter. Defaults to 1
MaxConnected=1

# Set to true to enable use of fast connectable mode (faster page scanning)
# for HFP when incoming call starts. Default settings are restored after
# call is answered or rejected. Page scan interval is much shorter and page
# scan type changed to interlaced. Such allows faster connection initiated
# by a headset.
FastConnectable=True

# Just an example of potential config options for the other interfaces
#[A2DP]
#SBCSources=1
#MPEG12Sources=0


It is important to me, any help will be appereciated.


Last edited by sangeshitou on Sun Jan 12, 2014 3:39 am; edited 1 time in total
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Sun Jan 12, 2014 12:36 am    Post subject: Reply with quote

Maybe have an /etc/asound.conf with an entry that declare the Bluetooth MAC address of your headset and make this entry the default can be more effective.
Code:
pcm.headset {
        type plug
        slave {
                pcm {
                type bluetooth
                device XX:XX:XX:XX:XX:XX
                profile "auto"
                }
        }
        hint {
                show on
                description "What you want."
    }
}

ctl.headset {
        type plug
}

pcm.!default {
        type plug
       slave.pcm "headset"
        hint {
                show on
                description "What you want."
        }
}

ctl.!default {
        type plug
}

_________________
Paul
Back to top
View user's profile Send private message
sangeshitou
n00b
n00b


Joined: 30 Aug 2013
Posts: 21

PostPosted: Sun Jan 12, 2014 3:10 am    Post subject: Reply with quote

Logicien wrote:
Maybe have an /etc/asound.conf with an entry that declare the Bluetooth MAC address of your headset and make this entry the default can be more effective.
Code:
pcm.headset {
        type plug
        slave {
                pcm {
                type bluetooth
                device XX:XX:XX:XX:XX:XX
                profile "auto"
                }
        }
        hint {
                show on
                description "What you want."
    }
}

ctl.headset {
        type plug
}

pcm.!default {
        type plug
       slave.pcm "headset"
        hint {
                show on
                description "What you want."
        }
}

ctl.!default {
        type plug
}


Thanks for your reply, but it still crash with the configuration above
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1369
Location: Montréal

PostPosted: Sun Jan 12, 2014 3:44 am    Post subject: Reply with quote

Maybe use your headset through Pulseaudio. With the previous /etc/asound.conf, just modify the line /etc/pulse/default.pa to have
Code:
load-module module-alsa-sink device=headset

and reload Pulseaudio. You should have an entry in the menu of Pavucontrol to use it. It can be a white line but it's there. Make Pulseaudio the default audio server in $HOME/.asoundrc
Code:
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

pcm.!default {
    type pulse
}

ctl.!default {
    type pulse
}


That's the way I use my own Bluetooth headset.
_________________
Paul
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum