Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Headless (VirtualBox, Fusion, and Parallels) Failed
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message

Joined: 21 Nov 2004
Posts: 62
Location: Vancouver, Canada

PostPosted: Thu Dec 11, 2014 5:38 pm    Post subject: Headless (VirtualBox, Fusion, and Parallels) Failed Reply with quote

It seems I have struck out on 3 different virtualization systems with Gentoo, and I believe now (not confirmed) it may be because I did not install X-Windows. My host system is OS X 10.10 and I was installing Gentoo 32bit 20141118.

My goal was simply to connect to a shared folder and access USB connected drives as if they were connected to a normal Linux installation... they show up in lsblk and can be mounted.

VMware Fusion

  • Native tool installer always failed looking for things that did not exist
  • Open source tools required ~x86 to get some parts built but in the end the parts that mattered had compiler errors. Patches exist from a few weeks ago, but I do not know how to use patches in the portage.
  • Default keyboard mappings caused the left command button to switch TTY which wigged me out for the first while till I moved it to the right command button


  • Able to see shared folders
  • Never once able to see USB devices. The USB controller never loaded for USB1.1 or USB2, and the extensions had compiler issues.


  • No idea where to even get guest support

In all cases my USE statement included -X because I did not need it and wanted to keep things small. That was likely many of my problems right there.

Not looking for support any longer on this folks, just stating what my findings have been. Sorry if the bullet points are a bit vague, I have been trying so many different angles for a couple weeks now and have started to forget all that I have tried. I am also not claiming to be super proficient at gentoo or linux. People have tried to offer help along the way, but I'm not sure I have the will to try much else at this point.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum