Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
grep: error while loading shared libraries: libpcre.so.0:
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Sun Jun 03, 2012 4:51 pm    Post subject: grep: error while loading shared libraries: libpcre.so.0: Reply with quote

Hi,

I got the following error when trying to do
Code:

 emerge --update --newuse --deep  world


Code:

 * Failed Running aclocal !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/net-libs/liblockfile-1.09/temp/aclocal.out

 * ERROR: net-libs/liblockfile-1.09 failed (prepare phase):
 *   Failed Running aclocal !
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_prepare
 *   environment, line 2527:  Called eautoreconf
 *   environment, line  691:  Called eaclocal
 *   environment, line  603:  Called autotools_run_tool '--at-m4flags' 'aclocal'
 *   environment, line  454:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of 'emerge --info =net-libs/liblockfile-1.09',
 * the complete build log and the output of 'emerge -pqv =net-libs/liblockfile-1.09'.
 * The complete build log is located at '/var/tmp/portage/net-libs/liblockfile-1.09/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/liblockfile-1.09/temp/environment'.
 * S: '/var/tmp/portage/net-libs/liblockfile-1.09/work/liblockfile-1.09'

>>> Failed to emerge net-libs/liblockfile-1.09, Log file:

>>>  '/var/tmp/portage/net-libs/liblockfile-1.09/temp/build.log'

 * Messages for package net-libs/liblockfile-1.09:

 * Failed Running aclocal !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/net-libs/liblockfile-1.09/temp/aclocal.out
 * ERROR: net-libs/liblockfile-1.09 failed (prepare phase):
 *   Failed Running aclocal !
 *
 * Call stack:
 *     ebuild.sh, line   85:  Called src_prepare
 *   environment, line 2527:  Called eautoreconf
 *   environment, line  691:  Called eaclocal
 *   environment, line  603:  Called autotools_run_tool '--at-m4flags' 'aclocal'
 *   environment, line  454:  Called die
 * The specific snippet of code:
 *           die "Failed Running $1 !";
 *
 * If you need support, post the output of 'emerge --info =net-libs/liblockfile-1.09',
 * the complete build log and the output of 'emerge -pqv =net-libs/liblockfile-1.09'.
 * The complete build log is located at '/var/tmp/portage/net-libs/liblockfile-1.09/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/net-libs/liblockfile-1.09/temp/environment'.
 * S: '/var/tmp/portage/net-libs/liblockfile-1.09/work/liblockfile-1.09'



It seems that somehow libpcre is missing for some reason?
less /var/tmp/portage/net-libs/liblockfile-1.09/temp/aclocal.out

Code:

***** aclocal *****
***** PWD: /var/tmp/portage/net-libs/liblockfile-1.09/work/liblockfile-1.09
***** aclocal

grep: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory
autom4te-2.68: need GNU m4 1.4 or later: /usr/bin/m4
aclocal-1.11: autom4te failed with exit status: 1



I'm pretty lost in terms of trying to figure out what happened. Any pointers?

Thanks in advance!

Here is the emerge info:

Code:

 # emerge --info =net-libs/liblockfile-1.09
Portage 2.1.10.49 (default/linux/amd64/10.0, gcc-4.5.3, glibc-2.14.1-r3, 3.2.1-gentoo-r2 x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.2.1-gentoo-r2-x86_64-Intel-R-_Core-TM-_i5-2405S_CPU_@_2.50GHz-with-gentoo-2.1
Timestamp of tree: Sun, 03 Jun 2012 09:35:01 +0000
app-shells/bash:          4.2_p20
dev-java/java-config:     2.1.11-r3
dev-lang/python:          2.7.3-r1, 3.2.3
dev-util/cmake:           2.8.7-r5
dev-util/pkgconfig:       0.26
sys-apps/baselayout:      2.1-r1
sys-apps/openrc:          0.9.8.4
sys-apps/sandbox:         2.5
sys-devel/autoconf:       2.13, 2.68
sys-devel/automake:       1.11.1
sys-devel/binutils:       2.21.1-r1
sys-devel/gcc:            4.5.3-r2
sys-devel/gcc-config:     1.5-r2
sys-devel/libtool:        2.4-r1
sys-devel/make:           3.82-r1
sys-kernel/linux-headers: 3.1 (virtual/os-headers)
sys-libs/glibc:           2.14.1-r3
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -pipe -march=native"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c"
CXXFLAGS="-O2 -pipe -march=native"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs distlocks ebuild-locks fixlafiles news parallel-fetch protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://gentoo.osuosl.org/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acl alsa amd64 apm bash-completion berkdb bzip2 cli consolekit cracklib crypt cups cxx dbus dri dvd emacs firefox fortran gdbm gnutls gpm iconv ipv6 javascript kde latex lm_sensors mmx modules mudflap multilib ncurses nls nptl nsplugin opengl openmp pam pcre policykit pppd qt3 qt3support qt4 readline session sse sse2 ssl tcpd udev unicode usb xinerama xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" PHP_TARGETS="php5-3" PYTHON_TARGETS="python3_2 python2_7" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Sun Jun 03, 2012 6:19 pm    Post subject: Re: grep: error while loading shared libraries: libpcre.so.0 Reply with quote

nw_biohazard wrote:
grep: error while loading shared libraries: libpcre.so.0: cannot open shared object file: No such file or directory

IIRC, for the purpose of recompiling grep, I got away with this hack:
Code:
ln -s libpcre.so.1.0.0 libpcre.so.0
Back to top
View user's profile Send private message
dmpogo
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2785
Location: Canada

PostPosted: Sun Jun 03, 2012 6:30 pm    Post subject: Reply with quote

libpcre was recently updated, did you run revdep-rebuild after that ?
Back to top
View user's profile Send private message
nw_biohazard
Tux's lil' helper
Tux's lil' helper


Joined: 05 Aug 2008
Posts: 122

PostPosted: Mon Jun 04, 2012 1:42 am    Post subject: Reply with quote

Adding
Code:

ln -s /lib64/libpcre.so.1.0.0 /lib64/libpcre.so.0


Allowed the revdep-rebuild to complete. Is it safe to remove the link now?

I do seem to now have an unrelated issue which is that revdep-rebuild wants to rebuild this over and over:

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] app-emulation/emul-linux-x86-gstplugins-20120127
 * Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild


I let it rebuild it, then run revdep-rebuild again, and get the same message.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Mon Jun 04, 2012 1:47 am    Post subject: Reply with quote

nw_biohazard wrote:
Is it safe to remove the link now?

Yes, removing that hacky link is the correct thing to do, after it's served its purpose of recompiling grep.
Back to top
View user's profile Send private message
Duncan Mac Leod
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 260
Location: Germany

PostPosted: Sun Jul 07, 2013 2:43 pm    Post subject: Reply with quote

Thank you :) ! You saved my workstation!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum