Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I failed to upgrade fcitx [Solved]
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
Tux's lil' helper
Tux's lil' helper

Joined: 01 Nov 2008
Posts: 94

PostPosted: Sun Aug 18, 2013 3:24 pm    Post subject: I failed to upgrade fcitx [Solved] Reply with quote

These days, I used a command (emerge -e world) to upgrade my system.

It stopped at emerging fcitx-sunpinyin.

>>> Failed to emerge app-i18n/fcitx-sunpinyin-0.4.1, Log file:

>>> '/var/tmp/portage/app-i18n/fcitx-sunpinyin-0.4.1/temp/build.log'

* Messages for package app-i18n/fcitx-sunpinyin-0.4.1:

* ERROR: app-i18n/fcitx-sunpinyin-0.4.1 failed (configure phase):
* cmake failed
* Call stack:
*, line 93: Called src_configure
* environment, line 3033: Called cmake-utils_src_configure
* environment, line 605: Called _execute_optionaly 'src_configure'
* environment, line 207: Called enable_cmake-utils_src_configure
* environment, line 928: Called die
* The specific snippet of code:
* "${CMAKE_BINARY}" "${cmakeargs[@]}" "${CMAKE_USE_DIR}" || die "cmake failed";
* If you need support, post the output of `emerge --info '=app-i18n/fcitx-sunpinyin-0.4.1'`,
* the complete build log and the output of `emerge -pqv '=app-i18n/fcitx-sunpinyin-0.4.1'`.
* The complete build log is located at '/var/tmp/portage/app-i18n/fcitx-sunpinyin-0.4.1/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/app-i18n/fcitx-sunpinyin-0.4.1/temp/environment'.
* Working directory: '/var/tmp/portage/app-i18n/fcitx-sunpinyin-0.4.1/work/fcitx-sunpinyin-0.4.1_build'
* S: '/var/tmp/portage/app-i18n/fcitx-sunpinyin-0.4.1/work/fcitx-sunpinyin-0.4.1'

I have already add this in the portage.keyword file:
=app-i18n/fcitx-sunpinyin-0.4.1 ~x86

So I don't know what is the problem.

Thanks for your support!

Last edited by bluephoenix on Wed Aug 21, 2013 5:14 pm; edited 1 time in total
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 01 Nov 2008
Posts: 94

PostPosted: Wed Aug 21, 2013 4:43 pm    Post subject: emerge --info '=app-i18n/fcitx-sunpinyin-0.4.1' Reply with quote

emerge --info '=app-i18n/fcitx-sunpinyin-0.4.1'
Portage (default/linux/x86/13.0/desktop, gcc-4.6.3, glibc-2.15-r3, 3.8.13-gentoo i686)
System Settings
System uname: Linux-3.8.13-gentoo-i686-Intel-R-_Pentium-R-_M_processor_1.60GHz-with-gentoo-2.2
KiB Mem: 509588 total, 51168 free
KiB Swap: 1048572 total, 1045724 free
Timestamp of tree: Thu, 15 Aug 2013 19:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
ccache version 3.1.9 [enabled]
app-shells/bash: 4.2_p45
dev-java/java-config: 2.1.12-r1
dev-lang/python: 2.7.5, 3.2.5-r1
dev-util/ccache: 3.1.9
dev-util/pkgconfig: 0.28
sys-apps/baselayout: 2.2
sys-apps/openrc: 0.11.8
sys-apps/sandbox: 2.6-r1
sys-devel/autoconf: 2.13, 2.69
sys-devel/automake: 1.11.6, 1.12.6
sys-devel/binutils: 2.23.1
sys-devel/gcc: 4.6.3
sys-devel/gcc-config: 1.7.3
sys-devel/libtool: 2.4-r1
sys-devel/make: 3.82-r4
sys-kernel/linux-headers: 3.7 (virtual/os-headers)
sys-libs/glibc: 2.15-r3
Repositories: gentoo
CFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.3/ext-active/ /etc/php/apache2-php5.4/ext-active/ /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.3/ext-active/ /etc/php/cgi-php5.4/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.3/ext-active/ /etc/php/cli-php5.4/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=pentium-m -O2 -pipe -fomit-frame-pointer"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS="-O2 -march=i686 -pipe"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X a52 aac acl acpi alsa berkdb bindist bluetooth branding bzip2 cairo cdda cdr cgi cli consolekit cracklib crypt ctype cups curl cxx dbus dri dts dvd dvdr emboss encode exif extras fam fastcgi firefox flac fortran ftp gd gdbm gif gpm gtk hash iconv jpeg lcms ldap libnotify lock mad ming mmx mng modules mp3 mp4 mpeg mudflap mysql ncurses network nginx nls nptl ogg opengl openmp pam pango pcre pdf pdo png policykit ppds python qt3support readline sasl sdl session spell sqlite sse sse2 ssl startup-notification svg symlink tcpd thunar tiff truetype udev udisks unicode upower usb v4l2 vorbis wxwidgets x264 x86 xcb xml xv xvid zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="zh_CN zh" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-4" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 01 Nov 2008
Posts: 94

PostPosted: Wed Aug 21, 2013 5:13 pm    Post subject: Reply with quote

i unmerged the fcitx and emerge again and everything is OK now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum