Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Configure wireless card/network
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
310354
n00b
n00b


Joined: 01 Aug 2013
Posts: 59

PostPosted: Wed Sep 11, 2013 12:27 am    Post subject: [SOLVED] Configure wireless card/network Reply with quote

Hi,
I have to get Internet working on my Gentoo installation, but I don't know where to start. I included the necessary modules/drivers for the wireless card (Atheros AR9485) when compiling the kernel (http://wireless.kernel.org/en/users/Drivers/ath9k#Enabling_ath9k). I can only use the Internet by chrooting. I think I will need 'ppp' (I have an ADSL and the provider uses the 'PPPoE' protocol) and 'dhcpd' (?). How can I 'activate' the wireless card at each boot with its drivers? How can I connect to my router? Thank you :)


Last edited by 310354 on Wed Oct 02, 2013 4:01 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Wed Sep 11, 2013 12:37 am    Post subject: Reply with quote

I don't know but don't think it's possible to pass pppoe over wifi, anyone know for sure?

I would think most people would have their router deal with pppoe and then have your computer just have a regular wifi link.

If you're starting out, and you want to use Gnome or are using a laptop, I'd highly suggest use NetworkManager and nm-applet. If you have your drivers built properly and have the correct USE flags (default gnome profile is fine) it will set up your wifi pretty much automatically.

Once you've gotten a feel how Linux networking works, and have a desktop that you want a hardcoded connection to your router, then you could use the usual tools directly through openrc to setup the connection. You'll need to use wpa-supplicant to deal with WPA on your router.

Even I'm too lazy to setup a hardcoded wifi connection, I just use networkmanager on most of my machines :o
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
310354
n00b
n00b


Joined: 01 Aug 2013
Posts: 59

PostPosted: Wed Sep 11, 2013 1:08 am    Post subject: Reply with quote

eccerr0r wrote:
I don't know but don't think it's possible to pass pppoe over wifi, anyone know for sure?

I would think most people would have their router deal with pppoe and then have your computer just have a regular wifi link.

If you're starting out, and you want to use Gnome or are using a laptop, I'd highly suggest use NetworkManager and nm-applet. If you have your drivers built properly and have the correct USE flags (default gnome profile is fine) it will set up your wifi pretty much automatically.

Once you've gotten a feel how Linux networking works, and have a desktop that you want a hardcoded connection to your router, then you could use the usual tools directly through openrc to setup the connection. You'll need to use wpa-supplicant to deal with WPA on your router.

Even I'm too lazy to setup a hardcoded wifi connection, I just use networkmanager on most of my machines :o

Thank you for the reply. I think there's still work to do before dealing with a network manager like wpa_supplicant.. With ifconfig the wireless card doesn't appear, even with 'modprobe ath9k'.. Maybe I forgot something in the kernel... But it would be strange since I carefully followed the linked guide.. The problem now is getting wifi card working
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7094
Location: Saint Amant, Acadiana

PostPosted: Wed Sep 11, 2013 1:25 am    Post subject: Reply with quote

See your dmesg for errors. You may need to load firmware for instance.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Wed Sep 11, 2013 2:54 am    Post subject: Reply with quote

^ ++

Definitely check dmesg, also are you using the udev persistent device names? If so, your wireless will not show up as wlan0.

The other bonus of NetworkManager is that it will configure the devices for you even if you have strange names from persistent device names and don't need to do the funny links from net.enp4s0 or whatever your network interface might show up as...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
310354
n00b
n00b


Joined: 01 Aug 2013
Posts: 59

PostPosted: Wed Sep 11, 2013 12:31 pm    Post subject: Reply with quote

Here is the dmesg output immediatly after the boot/login:

Code:
[    1.083462] Dquot-cache hash table entries: 512 (order 0, 4096 bytes)
[    1.083863] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    1.083956] SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
[    1.084356] OCFS2 1.5.0
[    1.084486] ocfs2: Registered cluster interface o2cb
[    1.084524] OCFS2 DLMFS 1.5.0
[    1.084614] OCFS2 User DLM kernel interface loaded
[    1.084654] OCFS2 Node Manager 1.5.0
[    1.084841] OCFS2 DLM 1.5.0
[    1.085254] GFS2 installed
[    1.085294] msgmni has been set to 14762
[    1.085721] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 253)
[    1.085761] io scheduler noop registered
[    1.085798] io scheduler deadline registered
[    1.085859] io scheduler cfq registered (default)
[    1.086057] pcieport 0000:00:02.0: irq 40 for MSI/MSI-X
[    1.086247] pcieport 0000:00:15.0: irq 41 for MSI/MSI-X
[    1.086361] pcieport 0000:00:15.1: irq 42 for MSI/MSI-X
[    1.086475] pcieport 0000:00:15.2: irq 43 for MSI/MSI-X
[    1.086690] pcieport 0000:00:02.0: Signaling PME through PCIe PME interrupt
[    1.086730] pci 0000:01:00.0: Signaling PME through PCIe PME interrupt
[    1.086771] pcie_pme 0000:00:02.0:pcie01: service driver pcie_pme loaded
[    1.086790] pcieport 0000:00:15.0: Signaling PME through PCIe PME interrupt
[    1.086832] pcie_pme 0000:00:15.0:pcie01: service driver pcie_pme loaded
[    1.086849] pcieport 0000:00:15.1: Signaling PME through PCIe PME interrupt
[    1.086889] pci 0000:04:00.0: Signaling PME through PCIe PME interrupt
[    1.086930] pcie_pme 0000:00:15.1:pcie01: service driver pcie_pme loaded
[    1.086948] pcieport 0000:00:15.2: Signaling PME through PCIe PME interrupt
[    1.086989] pci 0000:05:00.0: Signaling PME through PCIe PME interrupt
[    1.087033] pcie_pme 0000:00:15.2:pcie01: service driver pcie_pme loaded
[    1.087349] Serial: 8250/16550 driver, 4 ports, IRQ sharing enabled
[    1.088237] Linux agpgart interface v0.103
[    1.091565] brd: module loaded
[    1.093263] loop: module loaded
[    1.093624] i8042: PNP: PS/2 Controller [PNP0303:PS2K,PNP0f13:PS2M] at 0x60,0x64 irq 1,12
[    1.098488] serio: i8042 KBD port at 0x60,0x64 irq 1
[    1.098530] serio: i8042 AUX port at 0x60,0x64 irq 12
[    1.098804] mousedev: PS/2 mouse device common for all mice
[    1.098999] cpuidle: using governor ladder
[    1.099037] cpuidle: using governor menu
[    1.099178] hidraw: raw HID events driver (C) Jiri Kosina
[    1.099924] TCP: cubic registered
[    1.099988] NET: Registered protocol family 17
[    1.100823] registered taskstats version 1
[    1.101363] drivers/rtc/hctosys.c: unable to open rtc device (rtc0)
[    1.101583] Freeing unused kernel memory: 800k freed
[    1.103435] input: AT Translated Set 2 keyboard as /devices/platform/i8042/serio0/input/input0
[    1.203965] ACPI: bus type ATA registered
[    1.204390] libata version 3.00 loaded.
[    1.497786] psmouse serio1: alps: Unknown ALPS touchpad: E7=10 00 64, EC=10 00 64
[    2.228681] input: PS/2 Generic Mouse as /devices/platform/i8042/serio1/input/input1
[    2.457251] ahci 0000:00:11.0: version 3.0
[    2.457475] ahci 0000:00:11.0: irq 44 for MSI/MSI-X
[    2.457550] ahci 0000:00:11.0: AHCI 0001.0300 32 slots 3 ports 6 Gbps 0xb impl SATA mode
[    2.457554] ahci 0000:00:11.0: flags: 64bit ncq sntf ilck pm led clo pmp pio slum part sxs
[    2.459200] scsi0 : ahci
[    2.459512] scsi1 : ahci
[    2.459797] scsi2 : ahci
[    2.460056] scsi3 : ahci
[    2.460366] ata1: SATA max UDMA/133 abar m2048@0xffb4f000 port 0xffb4f100 irq 44
[    2.460370] ata2: SATA max UDMA/133 abar m2048@0xffb4f000 port 0xffb4f180 irq 44
[    2.460371] ata3: DUMMY
[    2.460373] ata4: SATA max UDMA/133 abar m2048@0xffb4f000 port 0xffb4f280 irq 44
[    2.810189] ata4: SATA link down (SStatus 0 SControl 300)
[    3.000195] ata2: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
[    3.000229] ata1: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    3.001556] ata1.00: ATA-8: Hitachi HTS547575A9E384, JE4OA60A, max UDMA/133
[    3.001560] ata1.00: 1465149168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    3.003045] ata1.00: configured for UDMA/133
[    3.003277] scsi 0:0:0:0: Direct-Access     ATA      Hitachi HTS54757 JE4O PQ: 0 ANSI: 5
[    3.003583] ata2.00: ATAPI: HL-DT-ST DVDRAM GT51N, AS01, max UDMA/133
[    3.003905] sd 0:0:0:0: [sda] 1465149168 512-byte logical blocks: (750 GB/698 GiB)
[    3.003909] sd 0:0:0:0: [sda] 4096-byte physical blocks
[    3.003985] sd 0:0:0:0: [sda] Write Protect is off
[    3.003991] sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    3.004044] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    3.006610] ata2.00: configured for UDMA/133
[    3.012408] scsi 1:0:0:0: CD-ROM            HL-DT-ST DVDRAM GT51N     AS01 PQ: 0 ANSI: 5
[    3.019216] sr0: scsi3-mmc drive: 24x/24x writer dvd-ram cd/rw xa/form2 cdda tray
[    3.019219] cdrom: Uniform CD-ROM driver Revision: 3.20
[    3.019702] sr 1:0:0:0: Attached scsi CD-ROM sr0
[    3.103376]  sda: sda1 sda2 sda4 < sda5 sda6 sda7 sda8 >
[    3.104765] sd 0:0:0:0: [sda] Attached SCSI disk
[    3.322040] sd 0:0:0:0: Attached scsi generic sg0 type 0
[    3.322149] sr 1:0:0:0: Attached scsi generic sg1 type 5
[    3.614405] scsi: <fdomain> Detection failed (no card)
[    3.728928] GDT-HA: Storage RAID Controller Driver. Version: 3.05
[    3.891672] imm: Version 2.05 (for Linux 2.4.0)
[    4.204115] 3ware Storage Controller device driver for Linux v1.26.02.003.
[    4.247942] 3ware 9000 Storage Controller device driver for Linux v2.26.02.014.
[    4.291281] Compaq SMART2 Driver (v 2.6.0)
[    4.393921] HP CISS Driver (v 3.6.26)
[    4.530903] Adaptec aacraid driver 1.2-0[30200]-ms
[    4.627728] megaraid cmm: 2.20.2.7 (Release Date: Sun Jul 16 00:01:03 EST 2006)
[    4.629771] megaraid: 2.20.5.1 (Release Date: Thu Nov 16 15:32:35 EST 2006)
[    4.721409] megasas: 06.506.00.00-rc1 Sat. Feb. 9 17:00:00 PDT 2013
[    4.790382] qla2xxx [0000:00:00.0]-0005: : QLogic Fibre Channel HBA Driver: 8.05.00.03-k.
[    4.851873] Emulex LightPulse Fibre Channel SCSI driver 8.3.39
[    4.851876] Copyright(c) 2004-2009 Emulex.  All rights reserved.
[    4.976963] aic94xx: Adaptec aic94xx SAS/SATA driver version 1.0.3 loaded
[    5.059239] ACPI: bus type USB registered
[    5.059448] usbcore: registered new interface driver usbfs
[    5.059537] usbcore: registered new interface driver hub
[    5.059663] usbcore: registered new device driver usb
[    5.062961] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    5.066047] ehci-pci: EHCI PCI platform driver
[    5.066289] ehci-pci 0000:00:12.2: EHCI Host Controller
[    5.066297] ehci-pci 0000:00:12.2: new USB bus registered, assigned bus number 1
[    5.066313] QUIRK: Enable AMD PLL fix
[    5.066315] ehci-pci 0000:00:12.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
[    5.066326] ehci-pci 0000:00:12.2: debug port 1
[    5.066368] ehci-pci 0000:00:12.2: irq 17, io mem 0xffb4d000
[    5.080209] ehci-pci 0000:00:12.2: USB 2.0 started, EHCI 1.00
[    5.080243] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    5.080246] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.080248] usb usb1: Product: EHCI Host Controller
[    5.080250] usb usb1: Manufacturer: Linux 3.10.7-gentoo ehci_hcd
[    5.080252] usb usb1: SerialNumber: 0000:00:12.2
[    5.080610] hub 1-0:1.0: USB hub found
[    5.080618] hub 1-0:1.0: 5 ports detected
[    5.081002] ehci-pci 0000:00:13.2: EHCI Host Controller
[    5.081009] ehci-pci 0000:00:13.2: new USB bus registered, assigned bus number 2
[    5.081015] ehci-pci 0000:00:13.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
[    5.081026] ehci-pci 0000:00:13.2: debug port 1
[    5.081062] ehci-pci 0000:00:13.2: irq 17, io mem 0xffb4b000
[    5.100181] ehci-pci 0000:00:13.2: USB 2.0 started, EHCI 1.00
[    5.100223] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[    5.100226] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.100228] usb usb2: Product: EHCI Host Controller
[    5.100230] usb usb2: Manufacturer: Linux 3.10.7-gentoo ehci_hcd
[    5.100232] usb usb2: SerialNumber: 0000:00:13.2
[    5.100677] hub 2-0:1.0: USB hub found
[    5.100684] hub 2-0:1.0: 5 ports detected
[    5.219089] usbcore: registered new interface driver usb-storage
[    5.275366] uhci_hcd: USB Universal Host Controller Interface driver
[    5.331659] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    5.331987] ohci_hcd 0000:00:12.0: OHCI Host Controller
[    5.331995] ohci_hcd 0000:00:12.0: new USB bus registered, assigned bus number 3
[    5.332026] ohci_hcd 0000:00:12.0: irq 18, io mem 0xffb4e000
[    5.394153] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
[    5.394165] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.394167] usb usb3: Product: OHCI Host Controller
[    5.394169] usb usb3: Manufacturer: Linux 3.10.7-gentoo ohci_hcd
[    5.394170] usb usb3: SerialNumber: 0000:00:12.0
[    5.394678] hub 3-0:1.0: USB hub found
[    5.394687] hub 3-0:1.0: 5 ports detected
[    5.395060] ohci_hcd 0000:00:13.0: OHCI Host Controller
[    5.395067] ohci_hcd 0000:00:13.0: new USB bus registered, assigned bus number 4
[    5.395086] ohci_hcd 0000:00:13.0: irq 18, io mem 0xffb4c000
[    5.454195] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
[    5.454199] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.454201] usb usb4: Product: OHCI Host Controller
[    5.454203] usb usb4: Manufacturer: Linux 3.10.7-gentoo ohci_hcd
[    5.454205] usb usb4: SerialNumber: 0000:00:13.0
[    5.454623] hub 4-0:1.0: USB hub found
[    5.454630] hub 4-0:1.0: 5 ports detected
[    5.511948] xhci_hcd 0000:00:10.0: xHCI Host Controller
[    5.511957] xhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 5
[    5.512170] xhci_hcd 0000:00:10.0: irq 45 for MSI/MSI-X
[    5.512177] xhci_hcd 0000:00:10.0: irq 46 for MSI/MSI-X
[    5.512186] xhci_hcd 0000:00:10.0: irq 47 for MSI/MSI-X
[    5.512192] xhci_hcd 0000:00:10.0: irq 48 for MSI/MSI-X
[    5.512198] xhci_hcd 0000:00:10.0: irq 49 for MSI/MSI-X
[    5.512301] usb usb5: New USB device found, idVendor=1d6b, idProduct=0002
[    5.512303] usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.512305] usb usb5: Product: xHCI Host Controller
[    5.512306] usb usb5: Manufacturer: Linux 3.10.7-gentoo xhci_hcd
[    5.512308] usb usb5: SerialNumber: 0000:00:10.0
[    5.512661] xHCI xhci_add_endpoint called for root hub
[    5.512662] xHCI xhci_check_bandwidth called for root hub
[    5.512768] hub 5-0:1.0: USB hub found
[    5.512776] hub 5-0:1.0: 2 ports detected
[    5.512931] xhci_hcd 0000:00:10.0: xHCI Host Controller
[    5.512936] xhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 6
[    5.515567] usb usb6: New USB device found, idVendor=1d6b, idProduct=0003
[    5.515569] usb usb6: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    5.515571] usb usb6: Product: xHCI Host Controller
[    5.515573] usb usb6: Manufacturer: Linux 3.10.7-gentoo xhci_hcd
[    5.515575] usb usb6: SerialNumber: 0000:00:10.0
[    5.515870] xHCI xhci_add_endpoint called for root hub
[    5.515871] xHCI xhci_check_bandwidth called for root hub
[    5.515971] hub 6-0:1.0: USB hub found
[    5.515979] hub 6-0:1.0: 2 ports detected
[    5.620040] usb 2-4: new high-speed USB device number 2 using ehci-pci
[    5.628652] usbcore: registered new interface driver usbhid
[    5.628655] usbhid: USB HID core driver
[    5.877104] usb 2-4: New USB device found, idVendor=1bcf, idProduct=2883
[    5.877109] usb 2-4: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    5.877111] usb 2-4: Product: ASUS USB2.0 Webcam
[    5.877113] usb 2-4: Manufacturer: 04G626000611BQ342000NN6
[    6.059337] device-mapper: uevent: version 1.0.3
[    6.059499] device-mapper: ioctl: 4.24.0-ioctl (2013-01-15) initialised: dm-devel@redhat.com
[    6.501965] md: raid0 personality registered for level 0
[    6.560422] md: raid1 personality registered for level 1
[    6.638781] async_tx: api initialized (async)
[    6.640073] usb 4-5: new full-speed USB device number 2 using ohci_hcd
[    6.810027] raid6: sse2x1    4153 MB/s
[    6.883267] usb 4-5: New USB device found, idVendor=13d3, idProduct=3362
[    6.883271] usb 4-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[    6.883273] usb 4-5: Product: Bluetooth USB Host Controller
[    6.883275] usb 4-5: Manufacturer: Atheros Communications
[    6.883277] usb 4-5: SerialNumber: Alaska Day 2006
[    6.980101] raid6: sse2x2    6785 MB/s
[    7.030136] usb 3-1: new low-speed USB device number 2 using ohci_hcd
[    7.150082] raid6: sse2x4    7686 MB/s
[    7.150085] raid6: using algorithm sse2x4 (7686 MB/s)
[    7.150086] raid6: using ssse3x2 recovery algorithm
[    7.186940] xor: automatically using best checksumming function:
[    7.273145] usb 3-1: New USB device found, idVendor=046d, idProduct=c05f
[    7.273149] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[    7.273152] usb 3-1: Product: USB Optical Mouse
[    7.273154] usb 3-1: Manufacturer: Logitech
[    7.280017]    avx       :  3193.200 MB/sec
[    7.281744] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1:1.0/input/input2
[    7.282094] hid-generic 0003:046D:C05F.0001: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:12.0-1/input0
[    7.292636] md: raid6 personality registered for level 6
[    7.292639] md: raid5 personality registered for level 5
[    7.292640] md: raid4 personality registered for level 4
[    7.359567] md: raid10 personality registered for level 10
[    7.422349] md: linear personality registered for level -1
[    7.485317] md: multipath personality registered for level -4
[    7.561967] JFS: nTxBlock = 8192, nTxLock = 65536
[    7.647011] RPC: Registered named UNIX socket transport module.
[    7.647013] RPC: Registered udp transport module.
[    7.647014] RPC: Registered tcp transport module.
[    7.647015] RPC: Registered tcp NFSv4.1 backchannel transport module.
[    7.725237] fuse init (API version 7.22)
[    7.790930] e1000: Intel(R) PRO/1000 Network Driver - version 7.3.21-k8-NAPI
[    7.790932] e1000: Copyright (c) 1999-2006 Intel Corporation.
[    7.872879] pps_core: LinuxPPS API ver. 1 registered
[    7.872883] pps_core: Software ver. 5.3.6 - Copyright 2005-2007 Rodolfo Giometti <giometti@linux.it>
[    7.874901] PTP clock support registered
[    7.957075] Loading iSCSI transport class v2.0-870.
[    8.434556] EXT3-fs (sda6): error: couldn't mount because of unsupported optional features (240)
[    8.434872] EXT2-fs (sda6): error: couldn't mount because of unsupported optional features (244)
[    8.438736] EXT4-fs (sda6): INFO: recovery required on readonly filesystem
[    8.438739] EXT4-fs (sda6): write access will be enabled during recovery
[   12.219081] EXT4-fs (sda6): recovery complete
[   12.225304] EXT4-fs (sda6): mounted filesystem with ordered data mode. Opts: (null)
[   13.736975] systemd-udevd[14608]: starting version 204
[   13.909579] input: Lid Switch as /devices/LNXSYSTM:00/device:00/PNP0C0D:00/input/input3
[   13.920206] ACPI: Lid Switch [LID]
[   13.920295] input: Power Button as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input4
[   13.920373] ACPI: Power Button [PWRB]
[   13.920428] input: Sleep Button as /devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input5
[   13.920500] ACPI: Sleep Button [SLPB]
[   13.920563] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input6
[   13.920629] ACPI: Power Button [PWRF]
[   13.970655] hda-intel 0000:00:01.1: Force to non-snoop mode
[   13.970694] snd_hda_intel 0000:00:01.1: irq 50 for MSI/MSI-X
[   13.975267] ACPI: Deprecated procfs I/F for AC is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
[   13.975329] ACPI: AC Adapter [AC0] (on-line)
[   14.051006] ACPI: Deprecated procfs I/F for battery is loaded, please retry with CONFIG_ACPI_PROCFS_POWER cleared
[   14.051014] ACPI: Battery Slot [BAT0] (battery present)
[   14.062253] thermal LNXTHERM:00: registered as thermal_zone0
[   14.062257] ACPI: Thermal Zone [THRM] (56 C)
[   14.063076] ACPI: acpi_idle registered with cpuidle
[   14.066091] rtc_cmos 00:04: RTC can wake from S4
[   14.066222] rtc_cmos 00:04: rtc core: registered rtc_cmos as rtc0
[   14.066275] rtc_cmos 00:04: alarms up to one month, y3k, 114 bytes nvram, hpet irqs
[   14.068087] acpi device:0d: registered as cooling_device3
[   14.068178] ACPI: Video Device [VGA] (multi-head: yes  rom: no  post: no)
[   14.068233] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/device:0c/LNXVIDEO:00/input/input7
[   14.073381] acpi device:35: registered as cooling_device5
[   14.073876] ACPI: Video Device [VGA1] (multi-head: yes  rom: no  post: no)
[   14.073943] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A03:00/LNXVIDEO:01/input/input8
[   14.172550] input: PC Speaker as /devices/platform/pcspkr/input/input9
[   14.224519] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   14.250489] r8169 0000:05:00.0: irq 51 for MSI/MSI-X
[   14.250706] r8169 0000:05:00.0 eth0: RTL8168evl/8111evl at 0xffffc900102ba000, 74:d0:2b:1a:fb:e0, XID 0c900800 IRQ 51
[   14.250710] r8169 0000:05:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   14.430285] systemd-udevd[14627]: renamed network interface eth0 to enp5s0
[   14.470339] kvm: Nested Virtualization enabled
[   14.470343] kvm: Nested Paging enabled
[   14.494955] [drm] Initialized drm 1.1.0 20060810
[   14.506779] cfg80211: Calling CRDA to update world regulatory domain
[   14.530734] acpi-cpufreq: overriding BIOS provided _PSD data
[   14.538518] ACPI Warning: 0x0000000000000b00-0x0000000000000b07 SystemIO conflicts with Region \SMBX 1 (20130328/utaddress-251)
[   14.538527] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[   14.722523] ath: EEPROM regdomain: 0x60
[   14.722525] ath: EEPROM indicates we should expect a direct regpair map
[   14.722527] ath: Country alpha2 being used: 00
[   14.722528] ath: Regpair used: 0x60
[   14.758397] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   14.758614] ieee80211 phy0: Atheros AR9485 Rev:1 mem=0xffffc90010780000, irq=17
[   14.840258] systemd-udevd[14625]: renamed network interface wlan0 to wlp4s0
[   15.447444] [drm] radeon kernel modesetting enabled.
[   15.447860] [drm] initializing kernel modesetting (ARUBA 0x1002:0x9903 0x1043:0x106B).
[   15.447904] [drm] register mmio base: 0xFFB00000
[   15.447905] [drm] register mmio size: 262144
[   15.448055] ATOM BIOS: 113
[   15.448117] radeon 0000:00:01.0: VRAM: 512M 0x0000000000000000 - 0x000000001FFFFFFF (512M used)
[   15.448120] radeon 0000:00:01.0: GTT: 512M 0x0000000020000000 - 0x000000003FFFFFFF
[   15.448744] [drm] Detected VRAM RAM=512M, BAR=256M
[   15.448747] [drm] RAM width 64bits DDR
[   15.448840] [TTM] Zone  kernel: Available graphics memory: 3779510 kiB
[   15.448841] [TTM] Zone   dma32: Available graphics memory: 2097152 kiB
[   15.448842] [TTM] Initializing pool allocator
[   15.448849] [TTM] Initializing DMA pool allocator
[   15.448874] [drm] radeon: 512M of VRAM memory ready
[   15.448876] [drm] radeon: 512M of GTT memory ready.
[   15.519200] radeon 0000:00:01.0: radeon_uvd: Can't load firmware "radeon/TAHITI_uvd.bin"
[   15.519236] [drm] GART: num cpu pages 131072, num gpu pages 131072
[   15.525635] [drm] Loading ARUBA Microcode
[   15.526218] ni_cp: Failed to load firmware "radeon/ARUBA_pfp.bin"
[   15.526221] [drm:cayman_startup] *ERROR* Failed to load firmware!
[   15.526224] radeon 0000:00:01.0: disabling GPU acceleration
[   15.527248] radeon 0000:00:01.0: ffff8802421b7800 unpin not necessary
[   15.527250] radeon 0000:00:01.0: ffff8802421b7800 unpin not necessary
[   15.528842] [drm] radeon atom DIG backlight initialized
[   15.528844] [drm] Radeon Display Connectors
[   15.528845] [drm] Connector 0:
[   15.528846] [drm]   LVDS-1
[   15.528847] [drm]   HPD1
[   15.528849] [drm]   DDC: 0x6530 0x6530 0x6534 0x6534 0x6538 0x6538 0x653c 0x653c
[   15.528850] [drm]   Encoders:
[   15.528851] [drm]     LCD1: INTERNAL_UNIPHY2
[   15.528852] [drm]     LCD1: TRAVIS
[   15.528853] [drm] Connector 1:
[   15.528854] [drm]   VGA-1
[   15.528855] [drm]   HPD2
[   15.528857] [drm]   DDC: 0x6540 0x6540 0x6544 0x6544 0x6548 0x6548 0x654c 0x654c
[   15.528858] [drm]   Encoders:
[   15.528859] [drm]     CRT1: INTERNAL_UNIPHY2
[   15.528859] [drm]     CRT1: NUTMEG
[   15.528860] [drm] Connector 2:
[   15.528861] [drm]   HDMI-A-1
[   15.528862] [drm]   HPD3
[   15.528864] [drm]   DDC: 0x6550 0x6550 0x6554 0x6554 0x6558 0x6558 0x655c 0x655c
[   15.528864] [drm]   Encoders:
[   15.528865] [drm]     DFP1: INTERNAL_UNIPHY
[   15.641158] [drm] Internal thermal controller without fan control
[   15.641171] [drm] radeon: power management initialized
[   15.915982] [drm] fb mappable at 0xB0040000
[   15.915984] [drm] vram apper at 0xB0000000
[   15.915985] [drm] size 4325376
[   15.915986] [drm] fb depth is 24
[   15.915986] [drm]    pitch is 5632
[   15.916191] fbcon: radeondrmfb (fb0) is primary device
[   16.036840] Console: switching to colour frame buffer device 170x48
[   16.040709] radeon 0000:00:01.0: fb0: radeondrmfb frame buffer device
[   16.040712] radeon 0000:00:01.0: registered panic notifier
[   16.041070] [drm] Initialized radeon 2.33.0 20080528 for 0000:00:01.0 on minor 0
[   16.041143] radeon 0000:01:00.0: enabling device (0000 -> 0003)
[   16.041373] [drm] initializing kernel modesetting (CAICOS 0x1002:0x6760 0x1043:0x106B).
[   16.041394] [drm] register mmio base: 0xFFA20000
[   16.041395] [drm] register mmio size: 131072
[   28.600222] ATOM BIOS: Asus
[   28.600686] radeon 0000:01:00.0: VRAM: 1024M 0x0000000000000000 - 0x000000003FFFFFFF (1024M used)
[   28.600689] radeon 0000:01:00.0: GTT: 512M 0x0000000040000000 - 0x000000005FFFFFFF
[   28.601226] [drm] Detected VRAM RAM=1024M, BAR=256M
[   28.601229] [drm] RAM width 64bits DDR
[   28.601252] [drm] radeon: 1024M of VRAM memory ready
[   28.601253] [drm] radeon: 512M of GTT memory ready.
[   28.601809] radeon 0000:01:00.0: radeon_uvd: Can't load firmware "radeon/SUMO_uvd.bin"
[   28.601841] [drm] GART: num cpu pages 131072, num gpu pages 131072
[   28.603906] [drm] Loading CAICOS Microcode
[   28.604499] ni_cp: Failed to load firmware "radeon/CAICOS_pfp.bin"
[   28.604502] [drm:evergreen_startup] *ERROR* Failed to load firmware!
[   28.604504] radeon 0000:01:00.0: disabling GPU acceleration
[   28.605556] radeon 0000:01:00.0: ffff880242072000 unpin not necessary
[   28.605558] radeon 0000:01:00.0: ffff880242072000 unpin not necessary
[   28.605637] [drm:evergreen_init] *ERROR* radeon: MC ucode required for NI+.
[   28.605640] radeon 0000:01:00.0: Fatal error during GPU init
[   28.605642] [drm] radeon: finishing device.
[   28.612702] [drm] radeon: ttm finalized
[   28.613031] radeon: probe of 0000:01:00.0 failed with error -22
[   30.029734] EXT4-fs (sda6): re-mounted. Opts: (null)
[   30.140217] Adding 9017340k swap on /dev/sda8.  Priority:-1 extents:1 across:9017340k
[   36.047247] usb 3-1: USB disconnect, device number 2
[   38.620168] usb 3-1: new low-speed USB device number 3 using ohci_hcd
[   38.815292] usb 3-1: New USB device found, idVendor=046d, idProduct=c05f
[   38.815296] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   38.815298] usb 3-1: Product: USB Optical Mouse
[   38.815299] usb 3-1: Manufacturer: Logitech
[   38.823507] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1:1.0/input/input10
[   38.823686] hid-generic 0003:046D:C05F.0002: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:12.0-1/input0
[   67.589280] usb 3-1: USB disconnect, device number 3
[   70.160175] usb 3-1: new low-speed USB device number 4 using ohci_hcd
[   70.355294] usb 3-1: New USB device found, idVendor=046d, idProduct=c05f
[   70.355299] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[   70.355301] usb 3-1: Product: USB Optical Mouse
[   70.355303] usb 3-1: Manufacturer: Logitech
[   70.363537] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1:1.0/input/input11
[   70.363725] hid-generic 0003:046D:C05F.0003: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:12.0-1/input0
[   99.129056] usb 3-1: USB disconnect, device number 4
[  101.700177] usb 3-1: new low-speed USB device number 5 using ohci_hcd
[  101.894309] usb 3-1: New USB device found, idVendor=046d, idProduct=c05f
[  101.894313] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  101.894315] usb 3-1: Product: USB Optical Mouse
[  101.894316] usb 3-1: Manufacturer: Logitech
[  101.903525] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1:1.0/input/input12
[  101.903721] hid-generic 0003:046D:C05F.0004: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:12.0-1/input0
[  114.803595] EXT4-fs (sda5): recovery complete
[  114.831916] EXT4-fs (sda5): mounted filesystem with ordered data mode. Opts: (null)
[  130.668912] usb 3-1: USB disconnect, device number 5
[  133.240181] usb 3-1: new low-speed USB device number 6 using ohci_hcd
[  133.434327] usb 3-1: New USB device found, idVendor=046d, idProduct=c05f
[  133.434331] usb 3-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[  133.434333] usb 3-1: Product: USB Optical Mouse
[  133.434334] usb 3-1: Manufacturer: Logitech
[  133.442552] input: Logitech USB Optical Mouse as /devices/pci0000:00/0000:00:12.0/usb3/3-1/3-1:1.0/input/input13
[  133.442740] hid-generic 0003:046D:C05F.0005: input,hidraw0: USB HID v1.11 Mouse [Logitech USB Optical Mouse] on usb-0000:00:12.0-1/input0


ifconfig -a:

Code:
enp5s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 74:d0:2b:1a:fb:e0  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        loop  txqueuelen 0  (Local Loopback)
        RX packets 28  bytes 1932 (1.8 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 28  bytes 1932 (1.8 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp4s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 6c:71:d9:92:87:a5  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Thank you
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7134
Location: almost Mile High in the USA

PostPosted: Wed Sep 11, 2013 2:13 pm    Post subject: Reply with quote

tant0c1b0 wrote:
Here is the dmesg output immediatly after the boot/login:

Code:

[   14.722523] ath: EEPROM regdomain: 0x60
[   14.722525] ath: EEPROM indicates we should expect a direct regpair map
[   14.722527] ath: Country alpha2 being used: 00
[   14.722528] ath: Regpair used: 0x60
[   14.758397] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   14.758614] ieee80211 phy0: Atheros AR9485 Rev:1 mem=0xffffc90010780000, irq=17


ifconfig -a:

Code:

wlp4s0: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 6c:71:d9:92:87:a5  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Thank you


This appears to be your wireless, as far as I can tell it detected the wireless device...

Supposedly all you need to do now is to configure it for your access point.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
310354
n00b
n00b


Joined: 01 Aug 2013
Posts: 59

PostPosted: Wed Oct 02, 2013 4:01 pm    Post subject: Reply with quote

I forgot to say: thanks! I managed to get wireless working. NetworkManager also did the trick (autoconfiguration).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum