Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Broken system: no root account, read only user account
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 26, 27, 28  Next  
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sat Sep 14, 2013 11:41 pm    Post subject: Reply with quote

Code:
emerge gpm

_________________
Defund the FCC.
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sat Sep 14, 2013 11:42 pm    Post subject: Reply with quote

DONAHUE wrote:
Code:
emerge gpm
Done.. gcc is newer

gcc-config -l
[1] x86_64-pc-linux-gnu-4.6.3 *


Last edited by auddoula on Sat Sep 14, 2013 11:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sat Sep 14, 2013 11:51 pm    Post subject: Reply with quote

hard stuff
Code:
emerge  -avuND world
how huge is it?
_________________
Defund the FCC.
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sat Sep 14, 2013 11:53 pm    Post subject: Reply with quote

well..


!! Problems have been detected with your world file
!!! Please run emaint --check world


!!! Ebuilds for the following packages are either all
!!! masked or don't exist:
sys-apps/hotplug dev-util/lafilefixer sys-apps/slocate app-portage/autounmask dev-lang/ifc

emerge: there are no ebuilds built with USE flags to satisfy "x11-base/xorg-server[kdrive]".
!!! One of the following packages is required to complete your request:
- x11-base/xorg-server-1.13.4::gentoo (Change USE: +kdrive)
(dependency required by "app-admin/sabayon-2.30.1" [ebuild])
(dependency required by "gnome-base/gnome-2.32.1-r2[ldap]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 12:01 am    Post subject: Reply with quote

Code:
emaint --check world
??
Code:
emerge --unmerge sys-apps/hotplug dev-util/lafilefixer sys-apps/slocate app-portage/autounmask dev-lang/ifc

Code:
echo  "x11-base/xorg-server:gentoo kdrive" >> /etc/portagepackage.use

_________________
Defund the FCC.
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 12:05 am    Post subject: Reply with quote

emaint --check world
Emaint: check world 100% [============================================>]

'media-libs/libmpeg3' is not installed
'media-libs/libmpeg2' is not installed
'x11-apps/xclock' is not installed
'app-portage/eix' is not installed
'app-editors/emacs' is not installed
'app-text/acroread' is not installed
'app-vim/vim-latex' is not installed
'sys-fs/ntfs3g' is not installed
'media-video/mpeg-tools' is not installed
'media-libs/libpng' is not installed
'app-shells/sash' is not installed
'app-admin/metalog' is not installed
'app-vim/info' is not installed
'sci-libs/hdf' is not installed
'x11-wm/twm' is not installed
'x11-drivers/xf86-input-evdev' is not installed
'app-text/wgetpaste' is not installed
'net-misc/rdate' is not installed
'sci-visualization/gnuplot' is not installed
'app-editors/vim' is not installed
'app-misc/strigi' is not installed
'sys-process/vixie-cron' is not installed
'media-libs/sge' is not installed
'dev-lang/ifc' is not installed
'media-sound/alsa-utils' is not installed
'virtual/opengl' is not installed
'x11-base/xorg-server' is not installed
'sys-apps/slocate' is not installed
'sci-libs/netcdf' is not installed
'sys-kernel/genkernel' is not installed
'app-portage/autounmask' is not installed
'x11-base/xorg-x11' is not installed
'dev-util/lafilefixer' is not installed
'www-client/firefox' is not installed
'net-ftp/ftp' is not installed
'gnome-base/gnome' is not installed
'sci-libs/hdf5' is not installed
'net-libs/libsoup-gnome:2.4' is not installed
'media-video/gxine' is not installed
'www-plugins/nspluginwrapper' is not installed
'sys-cluster/openmpi' is not installed
'x11-misc/x11vnc' is not installed
'sys-kernel/gentoo-sources' is not installed
'x11-libs/libdrm' is not installed
'gnome-base/gdm' is not installed
'x11-terms/xterm' is not installed
'media-video/mpeg2vidcodec' is not installed
'x11-wm/fluxbox' is not installed
'net-libs/libsoup:2.4' is not installed
'app-shells/tcsh' is not installed
'app-portage/gentoolkit' is not installed
'x11-drivers/nvidia-drivers' is not installed
'media-plugins/gst-plugins-mpeg2dec' is not installed
'dev-haskell/x11' is not installed
'app-admin/gkrellm' is not installed
'sys-boot/grub-static' is not installed
'kde-base/kde-meta' is not installed
'media-gfx/xv' is not installed
'sys-apps/hotplug' is not installed
'media-video/mplayer' is not installed
'app-misc/screen' is not installed
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 12:06 am    Post subject: Reply with quote

emerge --unmerge sys-apps/hotplug dev-util/lafilefixer sys-apps/slocate app-portage/autounmask dev-lang/ifc
* This action can remove important packages! In order to be safer, use
* `emerge -pv --depclean <atom>` to check for reverse dependencies before
* removing packages.

--- Couldn't find 'sys-apps/hotplug' to unmerge.

--- Couldn't find 'dev-util/lafilefixer' to unmerge.

--- Couldn't find 'sys-apps/slocate' to unmerge.

--- Couldn't find 'app-portage/autounmask' to unmerge.

--- Couldn't find 'dev-lang/ifc' to unmerge.

>>> No packages selected for removal by unmerge
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 12:11 am    Post subject: Reply with quote

edit /var/lib/portage/world to remove them if present -- --- Couldn't find 'sys-apps/hotplug' to unmerge.
_________________
Defund the FCC.
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 12:19 am    Post subject: Reply with quote

i edited the file, and removed all those items, but

emerge --unmerge sys-apps/hotplug dev-util/lafilefixer sys-apps/slocate app-portage/autounmask dev-lang/ifc
* This action can remove important packages! In order to be safer, use
* `emerge -pv --depclean <atom>` to check for reverse dependencies before
* removing packages.

--- Couldn't find 'sys-apps/hotplug' to unmerge.

--- Couldn't find 'dev-util/lafilefixer' to unmerge.

--- Couldn't find 'sys-apps/slocate' to unmerge.

--- Couldn't find 'app-portage/autounmask' to unmerge.

--- Couldn't find 'dev-lang/ifc' to unmerge.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 12:28 am    Post subject: Reply with quote

Code:
emerge -1avuND world

_________________
Defund the FCC.
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 12:29 am    Post subject: Reply with quote

DONAHUE wrote:
Code:
emerge -1avuND world


emerge: there are no ebuilds built with USE flags to satisfy "x11-base/xorg-server[kdrive]".
!!! One of the following packages is required to complete your request:
- x11-base/xorg-server-1.13.4::gentoo (Change USE: +kdrive)
(dependency required by "app-admin/sabayon-2.30.1" [ebuild])
(dependency required by "gnome-base/gnome-2.32.1-r2[ldap]" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 12:32 am    Post subject: Reply with quote

Code:
echo  "x11-base/xorg-server:gentoo kdrive" >> /etc/portage/package.use
sorry typo
_________________
Defund the FCC.
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 12:34 am    Post subject: Reply with quote

hmmm
emerge -1avuND world
has the same error
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 12:41 am    Post subject: Reply with quote

Code:
nano /etc/portage/package.use
did it take the kdrive flag?
if so delete :gentoo save and try again
_________________
Defund the FCC.
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 12:44 am    Post subject: Reply with quote

some improvement...

emerge: there are no ebuilds built with USE flags to satisfy ">=gnome-base/gnome-menus-2.27.92:0[python]".
!!! One of the following packages is required to complete your request:
- gnome-base/gnome-menus-2.30.5-r1::gentoo (Change USE: +python)
(dependency required by "x11-misc/alacarte-0.13.2" [ebuild])
(dependency required by "gnome-base/gnome-2.32.1-r2" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 12:48 am    Post subject: Reply with quote

Code:
echo "gnome-base/gnome-menus python"  >> /etc/portage/package.use

_________________
Defund the FCC.
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 12:50 am    Post subject: Reply with quote

hmm... this almost funny... let's see how far gentoo can move the post!!


emerge: there are no ebuilds built with USE flags to satisfy "dev-lang/python:2.7[threads,sqlite]".
!!! One of the following packages is required to complete your request:
- dev-lang/python-2.7.5-r2::gentoo (Change USE: +sqlite)
(dependency required by "www-client/firefox-17.0.8" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 12:53 am    Post subject: Reply with quote

echo " dev-lang/python sqlite" >> /etc/portage/package.use
_________________
Defund the FCC.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 12:54 am    Post subject: Reply with quote

if it will stop harassing us and run we will be able to run emerge --quickpackage world to have a complete set of binary packages
_________________
Defund the FCC.


Last edited by DONAHUE on Sun Sep 15, 2013 12:57 am; edited 1 time in total
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 12:56 am    Post subject: Reply with quote

good news..

Total: 1108 packages (11 upgrades, 1078 new, 4 in new slots, 15 reinstalls), Size of downloads: 2,792,339 kB

Shall I start it? Is there anything else we need to do prior that?
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 1:00 am    Post subject: Reply with quote

OK, I started it.. it will probably take a while.
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 1:00 am    Post subject: Reply with quote

add a keep-going
Code:
emerge --keep-going -1avuND world

see you domani

I was slow, if it does puke during a compile emerge --keep-going --resume will restart where it left off.
_________________
Defund the FCC.


Last edited by DONAHUE on Sun Sep 15, 2013 1:04 am; edited 1 time in total
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 1:01 am    Post subject: Reply with quote

DONAHUE wrote:
add a keep-going
Code:
emerge --keep-going -1avuND world

see you domani

Shoot... Should I stop it, and reissue the modified command?
Back to top
View user's profile Send private message
DONAHUE
Watchman
Watchman


Joined: 09 Dec 2006
Posts: 7553
Location: Goose Creek SC

PostPosted: Sun Sep 15, 2013 1:05 am    Post subject: Reply with quote

if it looks good no
see above if crashes
_________________
Defund the FCC.
Back to top
View user's profile Send private message
auddoula
Guru
Guru


Joined: 30 Apr 2008
Posts: 387

PostPosted: Sun Sep 15, 2013 1:05 am    Post subject: Reply with quote

Have a good night.. Thank you for your help and patience.. this was definitely hard stuff. let's see what domani brings us..
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Goto page Previous  1, 2, 3 ... 6, 7, 8 ... 26, 27, 28  Next
Page 7 of 28

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum