Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[S]media-video/mplayer2-2.0_p20131009 fails install phase o0
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Thu May 15, 2014 8:30 am    Post subject: [S]media-video/mplayer2-2.0_p20131009 fails install phase o0 Reply with quote

FEATURES="-fail-clean" MAKEOPTS='-j1' emerge -1 --quiet-build=n media-video/mplayer2 ends with this:

Code:
>>> Source compiled.
>>> Test phase [not enabled]: media-video/mplayer2-2.0_p20131009

>>> Install mplayer2-2.0_p20131009 into /var/tmp/portage/media-video/mplayer2-2.0_p20131009/image/ category media-video
make -j1 V=1 DESTDIR=/var/tmp/portage/media-video/mplayer2-2.0_p20131009/image/ install
./version.sh
if test ! -d /var/tmp/portage/media-video/mplayer2-2.0_p20131009/image//usr/bin ; then install -d /var/tmp/portage/media-video/mplayer2-2.0_p20131009/image//usr/bin ; fi
if test ! -d /var/tmp/portage/media-video/mplayer2-2.0_p20131009/image//etc/mplayer2 ; then install -d /var/tmp/portage/media-video/mplayer2-2.0_p20131009/image//etc/mplayer2 ; fi
install -m 755 mplayer2 /var/tmp/portage/media-video/mplayer2-2.0_p20131009/image//usr/bin
rst2man.py DOCS/man/en/mplayer.rst DOCS/man/en/mplayer.1
Traceback (most recent call last):
  File "/usr/lib/python-exec/python3.2/rst2man.py", line 26, in <module>
    publish_cmdline(writer=manpage.Writer(), description=description)
  File "/usr/lib64/python3.2/site-packages/docutils/core.py", line 349, in publish_cmdline
    pub.set_components(reader_name, parser_name, writer_name)
  File "/usr/lib64/python3.2/site-packages/docutils/core.py", line 93, in set_components
    self.set_reader(reader_name, self.parser, parser_name)
  File "/usr/lib64/python3.2/site-packages/docutils/core.py", line 83, in set_reader
    self.reader = reader_class(parser, parser_name)
  File "/usr/lib64/python3.2/site-packages/docutils/readers/__init__.py", line 52, in __init__
    self.set_parser(parser_name)
  File "/usr/lib64/python3.2/site-packages/docutils/readers/__init__.py", line 63, in set_parser
    parser_class = parsers.get_parser_class(parser_name)
  File "/usr/lib64/python3.2/site-packages/docutils/parsers/__init__.py", line 50, in get_parser_class
    module = __import__(parser_name, globals(), locals(), level=1)
  File "/usr/lib64/python3.2/site-packages/docutils/parsers/rst/__init__.py", line 75, in <module>
    from docutils.parsers.rst import states
  File "/usr/lib64/python3.2/site-packages/docutils/parsers/rst/states.py", line 116, in <module>
    from docutils.parsers.rst import directives, languages, tableparser, roles
  File "/usr/lib64/python3.2/site-packages/docutils/parsers/rst/roles.py", line 78, in <module>
    from docutils.utils.code_analyzer import Lexer, LexerError
  File "/usr/lib64/python3.2/site-packages/docutils/utils/code_analyzer.py", line 12, in <module>
    import pygments
  File "/usr/lib64/python3.2/site-packages/pygments/__init__.py", line 37, in <module>
    from pygments.util import StringIO, BytesIO
  File "/usr/lib64/python3.2/site-packages/pygments/util.py", line 224
    return u'[%s-%s]' % (unichr(a), unichr(b))
                    ^
SyntaxError: invalid syntax
Makefile:530: recipe for target 'DOCS/man/en/mplayer.1' failed
make: *** [DOCS/man/en/mplayer.1] Error 1
8O

Any ideas how to fix this?
Thank you!
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."


Last edited by Kollin on Thu May 15, 2014 11:07 am; edited 1 time in total
Back to top
View user's profile Send private message
fturco
Veteran
Veteran


Joined: 08 Dec 2010
Posts: 1105
Location: Italy

PostPosted: Thu May 15, 2014 10:33 am    Post subject: Reply with quote

It seems similar to bug 509422. Please try re-emerging the "pygments" package.
Back to top
View user's profile Send private message
Kollin
Veteran
Veteran


Joined: 25 Feb 2006
Posts: 1137
Location: Sofia/Bulgaria

PostPosted: Thu May 15, 2014 11:06 am    Post subject: Reply with quote

fturco wrote:
It seems similar to bug 509422. Please try re-emerging the "pygments" package.


It worked!
Thank you!!! :D
_________________
"Dear Enemy: may the Lord hate you and all your kind, may you be turned orange in hue, and may your head fall off at an awkward moment."
"Linux is like a wigwam - no windows, no gates, apache inside..."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum