Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ALC892 ALSA kein 5.1 Sound / segfault
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
andi_s
Apprentice
Apprentice


Joined: 10 Feb 2005
Posts: 226
Location: Germany

PostPosted: Sun Nov 24, 2013 1:00 pm    Post subject: ALC892 ALSA kein 5.1 Sound / segfault Reply with quote

Hallo,

mir gelingt es nicht 5.1 Sound unter Linux auszugeben (Stereo funktioniert)

Code:

#emerge --info
Portage 2.2.7 (default/linux/amd64/13.0, gcc-4.7.3, glibc-2.15-r3, 3.12.1-gentoo x86_64)

#lsmod
snd_hda_codec_realtek    38493  1
snd_hda_codec_hdmi     29242  1
snd_hda_intel          27802  9
snd_hda_codec         132961  3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
snd_hwdep               5932  1 snd_hda_codec

#aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: MID [HDA Intel MID], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: MID [HDA Intel MID], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 0: ALC892 Analog [ALC892 Analog]
  Subdevices: 0/1
  Subdevice #0: subdevice #0
card 1: PCH [HDA Intel PCH], device 3: ALC892 Digital [ALC892 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

# zcat /proc/config.gz | grep SND | grep "=y"
CONFIG_SND=y
CONFIG_SND_TIMER=y
CONFIG_SND_PCM=y
CONFIG_SND_JACK=y
CONFIG_SND_SEQUENCER=y
CONFIG_SND_OSSEMUL=y
CONFIG_SND_MIXER_OSS=y
CONFIG_SND_PCM_OSS=y
CONFIG_SND_PCM_OSS_PLUGINS=y
CONFIG_SND_SEQUENCER_OSS=y
CONFIG_SND_HRTIMER=y
CONFIG_SND_SEQ_HRTIMER_DEFAULT=y
CONFIG_SND_DYNAMIC_MINORS=y
CONFIG_SND_SUPPORT_OLD_API=y
CONFIG_SND_VERBOSE_PROCFS=y
CONFIG_SND_VMASTER=y
CONFIG_SND_KCTL_JACK=y
CONFIG_SND_DMA_SGBUF=y
CONFIG_SND_PCI=y
CONFIG_SND_HDA_HWDEP=y
CONFIG_SND_HDA_RECONFIG=y
CONFIG_SND_HDA_INPUT_BEEP=y
CONFIG_SND_HDA_INPUT_JACK=y
CONFIG_SND_HDA_CODEC_REALTEK=y
CONFIG_SND_HDA_CODEC_ANALOG=y
CONFIG_SND_HDA_CODEC_HDMI=y
CONFIG_SND_HDA_I915=y
CONFIG_SND_HDA_CODEC_CA0132=y
CONFIG_SND_HDA_GENERIC=y

#cat /proc/asound/card1/codec#* | grep Codec
Codec: Realtek ALC892

#cat /proc/asound/card0/codec#* | grep Codec
Codec: Intel Haswell HDMI

# cat .asoundrc
defaults.pcm.!card 1
defaults.pcm.!device 0



Der XFCE-4-Mixer zeigt mir auch alle Devices an und die Einstellung der Lautstärke und Anschlüsse (analoges 5.1 System) habe ich überprüft.

Unter VLC sehe ich auch eine analoges 5.1 PCH Intel 892 Device, allerdings bleiben die Lautsprecher stumm und es funktioniert ebenfalls nur die Stereo-Ausgabe

Code:

# speaker-test -c 2 -t wav

funktioniert

Code:

#speaker-test -c 6 -D surround51 -t wav

speaker-test 1.0.27.1

Playback device is surround51
Stream parameters are 48000Hz, S16_LE, 6 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 22 to 5461
Period size range from 11 to 2730
Using max buffer size 5460
Periods = 4
was set period_size = 1365
was set buffer_size = 5460
Segmentation fault


funktioniert nicht (Segmentation fault)
Code:

#dmesg
speaker-test[12471]: segfault at fffffff90217175a ip 00007f112ae2687b sp 00007fffc4806320 error 5 in libc-2.15.so[7f112adab000+19b000]


Ich hatte vorher noch oss in den globalen Useflags und hatte gehofft, dass 5.1 funktioniert, wenn ich es rausnehme. Ausserdem habe ich im Kernel noch HDA_CODEC_ANALOG hinzugefügt (und noch irgendeine andere Option).
Davor lief der 5.1 speaker-test (allerdings kam da auch nur Audio aus L+R) und nun erhalte ich den Segfault.

Glibc habe ich schon neu gebaut und auch mal revdep-rebuild durchlaufen lassen...

Nun bin ich ratlos und hoffe es gibt eine Lösung.

Hardware-Probleme schliesse ich aus da ich das Problem nur unter Linux habe!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum