Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
@preserved-rebuild problem [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Wed Dec 04, 2013 5:36 pm    Post subject: @preserved-rebuild problem [solved] Reply with quote

I've a very strange problem with the emerge @preserved-rebuild command.

When I launch, an error message block
Code:
emerge: there are no ebuilds to satisfy "media-gfx/gnome-scan:0".
(dependency required by "@preserved-rebuild" [argument])


I don't use gnome-scan, i don't need it...


Last edited by mrl4n on Wed Dec 04, 2013 8:47 pm; edited 1 time in total
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1656
Location: United Kingdom

PostPosted: Wed Dec 04, 2013 6:00 pm    Post subject: Reply with quote

I don't know about gnome-scan in particular, but sometimes this kind of thing happens to me with obsolete packages that are lying around and don't show up when I use eix (even after doing and eix-update) but do show up if I search with emerge -s. Have you tried emerge --depclean --ask gnome-scan followed by revdep-rebuild -i?
_________________
Clevo W230SS: amd64 OpenRC elogind nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 OpenRC elogind xf86-video-ati. Dual boot Win 7 Pro 64-bit.
KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
mrl4n
l33t
l33t


Joined: 08 Apr 2009
Posts: 674

PostPosted: Wed Dec 04, 2013 8:48 pm    Post subject: Reply with quote

Great...works fine!

Thanks
Back to top
View user's profile Send private message
dataking
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 251

PostPosted: Thu Dec 05, 2013 8:40 am    Post subject: Reply with quote

I have a similar issue. emerge complains that there are unresolved preserved libs, yet when I run the command suggested, it rebuilds java-jre. I tried emerge --deep -- newuse --update --with-bdeps=y @world and it doesn't do anything. If I do emerge @preserved-rebuild it emerges nothing and then complains that certain libs need to be rebuilt for ffmpeg, including jre.
_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum