Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Boot hangs on "switching to clock source tsc"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
m1cmac
n00b
n00b


Joined: 10 Dec 2013
Posts: 10

PostPosted: Tue Dec 10, 2013 10:35 pm    Post subject: [solved] Boot hangs on "switching to clock source tsc&q Reply with quote

Hello, everyone.

The Gentoo installation process has been very educational for me, so far, and I'm loving it, however, I am at the point where I reboot the system for the first time, and try logging in using my GRUB setup.

First off, I had a few issues with the GRUB setup: it throws error 15, file not found if I leave the initramfs line in, which is bizarre, considering I'm pretty sure it's there... Do I need the initramfs if I only have /boot and /root on different partitions?

If I remove the initramfs line, I can get the system to boot up until it hangs at "switching to clock source tsc," then, after about two minutes or so, the computer shuts down.

Any help would be appreciated! :)


Last edited by m1cmac on Fri Dec 13, 2013 1:52 am; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13831

PostPosted: Wed Dec 11, 2013 12:51 am    Post subject: Reply with quote

Please post the output of emerge --info and the contents of a kernel log after this happens.
Back to top
View user's profile Send private message
m1cmac
n00b
n00b


Joined: 10 Dec 2013
Posts: 10

PostPosted: Wed Dec 11, 2013 2:00 am    Post subject: Reply with quote

Hu wrote:
Please post the output of emerge --info

Code:
Portage 2.2.7 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.16.0, 3.4.66-std381-amd64 x86_64)
=================================================================
System uname: Linux-3.4.66-std381-amd64-x86_64-Intel-R-_Core-TM-_i5-2500K_CPU_@_3.30GHz-with-gentoo-2.2
KiB Mem:     8158056 total,   7525884 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Tue, 10 Dec 2013 00:45:01 +0000
ld GNU ld (GNU Binutils) 2.23.1
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.5-r3, 3.3.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.23.1
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.9 (virtual/os-headers)
sys-libs/glibc:           2.16.0
Repositories: gentoo
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.csclub.uwaterloo.ca/gentoo-distfiles/"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync4.ca.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="fbdev glint intel mach64 mga nouveau nv r128 radeon savage sis tdfx trident vesa via vmware dummy v4l" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON


Quote:
and the contents of a kernel log after this happens.
Unfortunately, I am not sure how to do this! If I use a live-cd and chroot into my gentoo install and use dmesg, I get the live cd's dmesg, and syslog-ng doesn't seem to start until after the error occurs, leading to no useful output in /var/log/messages. How would you recommend I get thisinformation?
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13831

PostPosted: Wed Dec 11, 2013 2:56 am    Post subject: Reply with quote

A serial console would allow another machine to record the output.

You appear to have a great many video cards configured. I suggest that you disable the irrelevant ones.
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Wed Dec 11, 2013 3:51 am    Post subject: Re: System boot hangs on "switching to clock source tsc Reply with quote

m1cmac wrote:
it hangs at "switching to clock source tsc,"

Try the notsc bootup kernel commandline option.
Back to top
View user's profile Send private message
m1cmac
n00b
n00b


Joined: 10 Dec 2013
Posts: 10

PostPosted: Wed Dec 11, 2013 1:08 pm    Post subject: Reply with quote

Hu wrote:
A serial console would allow another machine to record the output.
I will see if I can look into this after work today. For now, all I can give you guys are cruddy pictures from my phone: http://imgur.com/a/g1IQM I have uploaded images with and without the notsc boot flag.

Hu wrote:
You appear to have a great many video cards configured. I suggest that you disable the irrelevant ones.
I have updated my make.conf to only use my video card. Thanks for the tip!

PaulBredbury wrote:
Try the notsc bootup kernel commandline option.
if you take a look at this: http://imgur.com/a/g1IQM (the same link as above) the first image is with the notsc flag. I seem to get a very similar issue, but hanging a few lines earlier.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Wed Dec 11, 2013 5:23 pm    Post subject: Reply with quote

try boot with clocksource=hpet
Back to top
View user's profile Send private message
m1cmac
n00b
n00b


Joined: 10 Dec 2013
Posts: 10

PostPosted: Wed Dec 11, 2013 5:44 pm    Post subject: Reply with quote

krinn wrote:
try boot with clocksource=hpet


Trying this results in the same problem, but hanging one line later than when I try with the notsc flag, but one line earlier than when I try without either flag.

the line it hangs on is:
Code:
tsc: Refined TSC clocksource calibration: 3399.621 MHz
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13831

PostPosted: Wed Dec 11, 2013 10:11 pm    Post subject: Reply with quote

Users often report a "hang at clocksource tsc" when the real problem is a hang or long stall initializing the first module after the tsc. Aside from the report that the computer turns off afterward, this has all the symptoms of missing graphics firmware.
Back to top
View user's profile Send private message
m1cmac
n00b
n00b


Joined: 10 Dec 2013
Posts: 10

PostPosted: Wed Dec 11, 2013 10:33 pm    Post subject: Reply with quote

Hu wrote:
Users often report a "hang at clocksource tsc" when the real problem is a hang or long stall initializing the first module after the tsc. Aside from the report that the computer turns off afterward, this has all the symptoms of missing graphics firmware.

This could very well be the problem. I have gone through and added more radeon video drivers(I'm using a Radeon HD 6850), and after looking at a working bootup's dmesg, found that
Code:
[    3.495538] firewire_core 0000:08:03.0: created device fw0: GUID 001e8c000039bdac, S400
was the next line output to the console, so I added a bunch of firewire kernel options, but I'm still getting the same issue. If it's a video driver problem, would removing video from the boot flags solve this temporarily, and let me know for sure that it's gpu-related?

edit: I hope not, because I just tried removing video, and I got the same result!
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 7071

PostPosted: Wed Dec 11, 2013 10:56 pm    Post subject: Reply with quote

m1cmac wrote:
If it's a video driver problem, would removing video from the boot flags solve this temporarily, and let me know for sure that it's gpu-related?

I think reading that might help you more : https://wiki.gentoo.org/wiki/Radeon#Installation

And your firewire message looks more related to loading firewire:the IEEE 1394 interface than related to radon firewire commercial names.
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1368
Location: Montréal

PostPosted: Wed Dec 11, 2013 11:39 pm    Post subject: Reply with quote

As I know, you do not need an initramfs if everything Linux need to boot without it is compiled in the kernel itself and not as modules, with the needed firmware files not in the initramfs, but in the kernel image itself, unless you have a usr partition. usr partition need an initramfs. I do not use a boot or a usr partition.

The Grub error 15, file not found can come from a grub.conf file wrong partition number and/or syntax where Grub must search the initramfs file. It can come from too the fact that the initramfs file is written in the boot directory of the root partition instead of the root directory of the boot partition.

If the boot partition was not mounted when the initramfs was copied in the boot directory than, Grub must search the initramfs in the boot directory of the root partition. If the boot partition was mounted, Grub must search it in the root directory of the boot partition. In the later case as example, the path must be write /initramfs and not /boot/initramfs like for the first case.

The fact that the initramfs is not found, possibly make some needed firmware files and/or mandatory support not available at boot time, that are not in the kernel image too, resulting in the stall.

First try to make Grub find the initramfs.
_________________
Paul
Back to top
View user's profile Send private message
m1cmac
n00b
n00b


Joined: 10 Dec 2013
Posts: 10

PostPosted: Thu Dec 12, 2013 3:47 am    Post subject: Reply with quote

thanks for all the helpful comments, guys!

I yet to get it up and booting, but I haven't spent much time with it since being linked to the Radeon installation guide. I followed it loosely (it's outdated, and some of the kernel options it recommends say "depreciated" beside them, or I can't find them with search), and recompiled my kernel, but I still get the same error. At least now I have more direction in terms of what to look for.

I also fixed my initramfs line, so that works now, and I understand that FireWire wouldn't have much impact on radeon GPU stuff, but I figured I'd check it because it came up after the hang in a working Linux boot on my machine.

I will try more stuff after work tomorrow, and get back to you all if I make any progress (or get stumped, again)
Back to top
View user's profile Send private message
m1cmac
n00b
n00b


Joined: 10 Dec 2013
Posts: 10

PostPosted: Fri Dec 13, 2013 1:51 am    Post subject: Reply with quote

Thabks a ton, everybody! I just successfully booted into my Gentoo installation! Hu was right, I needed to add the radeon firmware packages to my kernel.

After following the instructions linked to by krinn, I got everything working fine!

Thanks again for all of your help!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum