Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Inconsistent reporting from mdadm, no mount for /boot
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mbrenn
n00b
n00b


Joined: 15 Dec 2013
Posts: 4

PostPosted: Tue Dec 17, 2013 9:09 pm    Post subject: Inconsistent reporting from mdadm, no mount for /boot Reply with quote

Hello,

trying to build up a desktop for testing raid on a server but do not really understand the behavior of mdadm.

When I enter some commands for mdadm, I get inconsistent results.

I created two raid-assemblies during set-up:
1) /dev/sda1 + /dev/sdb1 => /dev/md0 (formatted as ext2, 500 MB)
2) /dev/sda2 + /dev/sdb2 => /dev/md1 (formatted as ext4, ~2000 GB)

The installation of gentoo, including kernel and grub went fine.
But after reboot, I cannot mount /boot anymore. In Live-CD mode, I can.

Quote:
hessen ~ # cat /proc/mdstat
Personalities : [raid1]
md126 : active raid1 sda2[0] sdb2[1]
1953001472 blocks [2/2] [UU]

md127 : active raid1 sda1[0] sdb1[1]
511936 blocks [2/2] [UU]

hessen ~ # mdadm --detail --scan --test
mdadm: cannot open /dev/md/0_0: No such file or directory
ARRAY /dev/md126 metadata=0.90 UUID=5d3d83c3:43b62ba4:776c2c25:004bd7b2

hessen ~ # mdadm --examine --scan
ARRAY /dev/md0 UUID=87b3da0c:951868ac:776c2c25:004bd7b2
ARRAY /dev/md126 UUID=5d3d83c3:43b62ba4:776c2c25:004bd7b2

hessen ~ # mdadm --examine /dev/sda1
/dev/sda1:
Magic : a92b4efc
Version : 0.90.00
UUID : 87b3da0c:951868ac:776c2c25:004bd7b2
Creation Time : Mon Dec 16 20:55:20 2013
Raid Level : raid1
Used Dev Size : 511936 (500.02 MiB 524.22 MB)
Array Size : 511936 (500.02 MiB 524.22 MB)
Raid Devices : 2
Total Devices : 2
Preferred Minor : 0

Update Time : Tue Dec 17 21:13:12 2013
State : clean
Active Devices : 2
Working Devices : 2
Failed Devices : 0
Spare Devices : 0
Checksum : e3177114 - correct
Events : 18


Number Major Minor RaidDevice State
this 0 8 1 0 active sync /dev/sda1

0 0 8 1 0 active sync /dev/sda1
1 1 8 17 1 active sync /dev/sdb1

hessen ~ # mount | grep md[0,1]
/dev/md126 on / type ext4 (rw,noatime,data=ordered)

hessen ~ # mount /boot
mount: special device /dev/md0 does not exist

hessen ~ # find /dev/ | grep md
/dev/.tmp.md127
/dev/disk/by-id/md-uuid-5d3d83c3:43b62ba4:776c2c25:004bd7b2
/dev/md126
/dev/md
/dev/md/126_0
/dev/.mdadm
/dev/.mdadm/map
/dev/mdev.seq

hessen ~ # mdadm --assemble /dev/md0 /dev/sda1 /dev/sdb1
mdadm: /dev/sda1 is busy - skipping
mdadm: /dev/sdb1 is busy - skipping

hessen ~ # cat /etc/fstab | grep /
# /etc/fstab: static file system information.
# switch between notail / tail freely.
# <fs> <mountpoint> <type> <opts> <dump/pass>
/dev/md126 / ext4 noatime 0 1
/dev/md0 /boot ext2 auto,noatime 1 2
#/dev/SWAP none swap sw 0 0
#/dev/cdrom /mnt/cdrom auto noauto,ro 0 0
#/dev/fd0 /mnt/floppy auto noauto 0 0

hessen ~ # fdisk -l

Disk /dev/sdb: 2000.4 GB, 2000398934016 bytes, 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000b0558

Device Boot Start End Blocks Id System
/dev/sdb1 2048 1026047 512000 83 Linux
/dev/sdb2 1026048 3907029167 1953001560 83 Linux

Disk /dev/sda: 2000.4 GB, 2000398934016 bytes, 3907029168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0000cbf1

Device Boot Start End Blocks Id System
/dev/sda1 2048 1026047 512000 83 Linux
/dev/sda2 1026048 3907029167 1953001560 83 Linux

Disk /dev/md126: 1999.9 GB, 1999873507328 bytes, 3906002944 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

hessen ~ # cat /etc/default/grub | grep CMD
GRUB_CMDLINE_LINUX="domdadm rootfstype=ext4 dolvm init=/usr/lib/systemd/systemd"
#GRUB_CMDLINE_LINUX_DEFAULT=""

hessen ~ # cat /usr/src/linux/.config | grep CONFIG_MD
CONFIG_MD=y
CONFIG_MD_AUTODETECT=y
# CONFIG_MD_LINEAR is not set
# CONFIG_MD_RAID0 is not set
CONFIG_MD_RAID1=y
# CONFIG_MD_RAID10 is not set
# CONFIG_MD_RAID456 is not set
# CONFIG_MD_MULTIPATH is not set
# CONFIG_MD_FAULTY is not set
# CONFIG_MDIO_BITBANG is not set




I do not understand why I cannot mount my boot partition on /dev/sda1.
Any suggestions?
Back to top
View user's profile Send private message
mbrenn
n00b
n00b


Joined: 15 Dec 2013
Posts: 4

PostPosted: Wed Dec 18, 2013 11:05 pm    Post subject: Reply with quote

Can be closed...
I recreated the server with --metadata=1.2 and no automatic mount by kernel and everything worked fine.
Back to top
View user's profile Send private message
xp-vit
n00b
n00b


Joined: 22 Sep 2012
Posts: 37

PostPosted: Thu Dec 19, 2013 9:55 am    Post subject: Reply with quote

if problem is actually solved, can you please add [SOLVED] to the topic name. If can be achived by editing first post. Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum