Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fglrx load fail, symbol problem or else
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
FKK
n00b
n00b


Joined: 11 Jan 2014
Posts: 14
Location: Middle Land

PostPosted: Thu Jan 16, 2014 5:33 am    Post subject: fglrx load fail, symbol problem or else Reply with quote

ati-drivers install success, but fglrx not loaded for symbol problems
Code:

# modprobe fglrx
modprobe: ERROR: could not insert 'fglrx': Invalid argument

# dmesg:
[   25.191370] fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[   25.191376] Disabling lock debugging due to kernel taint
[   25.205161] fglrx: no symbol version for acpi_lid_open
[   25.205169] fglrx: Unknown symbol acpi_lid_open (err -22)
[   25.205647] fglrx: no symbol version for acpi_lid_notifier_register
[   25.205650] fglrx: Unknown symbol acpi_lid_notifier_register (err -22)
[   25.206013] fglrx: no symbol version for acpi_lid_notifier_unregister
[   25.206016] fglrx: Unknown symbol acpi_lid_notifier_unregister (err -22)

# nm -g fglrx.ko  | grep acpi
                 U acpi_bus_get_device
                 U acpi_disabled
                 U acpi_evaluate_object
                 U acpi_get_devices
                 U acpi_get_handle
                 U acpi_get_next_object
                 U acpi_get_table_with_size
                 U acpi_lid_notifier_register
                 U acpi_lid_notifier_unregister
                 U acpi_lid_open
0000000000041550 T firegl_acpi_atif_select_active_displays
0000000000041bf0 T firegl_acpi_eval_ATPX
0000000000040b10 T firegl_acpi_eval_method
0000000000040940 T firegl_acpi_eval_method_helper
0000000000041fa0 T firegl_acpi_get_ac_state
00000000000416a0 T firegl_acpi_init
0000000000041d40 T firegl_acpi_read_vbios
0000000000042050 T firegl_acpi_resume
0000000000041ac0 T firegl_acpi_shutdown
0000000000042100 T firegl_acpi_update_ac_state
0000000000041020 T firegl_acpi_video_query_state
0000000000041260 T firegl_acpi_video_set_state
                 U register_acpi_notifier
                 U unregister_acpi_notifier

# nm -g button.ko  | grep lid
00000000544b0c11 A __crc_acpi_lid_notifier_register
00000000cbae6c7a A __crc_acpi_lid_notifier_unregister
0000000048193639 A __crc_acpi_lid_open
000000000000027d T acpi_lid_notifier_register
0000000000000268 T acpi_lid_notifier_unregister
0000000000000000 T acpi_lid_open

# cat /proc/kallsyms | grep acpi_lid
ffffffffa002a049 t acpi_lid_send_state  [button]
ffffffffa002a27d T acpi_lid_notifier_register   [button]
ffffffffa002a268 T acpi_lid_notifier_unregister [button]
ffffffffa002a000 T acpi_lid_open        [button]

# lsmod | grep button   
button                  4485  0


if interested, here is what i have tried: https://forums.gentoo.org/viewtopic-p-7481630.htm
_________________
config config config
build build build
boot boot boot
crash crash crash
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7132
Location: Saint Amant, Acadiana

PostPosted: Fri Jan 17, 2014 4:34 am    Post subject: Reply with quote

You get unknown symbol errors when you try insert a module into a kernel it wasn't built against.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
FKK
n00b
n00b


Joined: 11 Jan 2014
Posts: 14
Location: Middle Land

PostPosted: Fri Jan 17, 2014 5:14 am    Post subject: Reply with quote

Jaglover wrote:
You get unknown symbol errors when you try insert a module into a kernel it wasn't built against.

ty for reply.

by /proc/kallsyms, it's already built inside kernel, i think.
how to make sure these symbols built or not?

I know these symbols should be offered by acpi/button.ko, and nm tells it offered.
_________________
config config config
build build build
boot boot boot
crash crash crash
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum