Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
failed to update the system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
chenylex
n00b
n00b


Joined: 19 Dec 2013
Posts: 14

PostPosted: Thu Dec 19, 2013 1:31 pm    Post subject: failed to update the system Reply with quote

when i haved installed the gentoo linux system ,i want to update my system.but it is failed!
i want to know why!
i use gentoo first time!
Gentoo-20121221 gentoo # emerge --update --deep --with-bdeps=y @world

* IMPORTANT: 10 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies or

!!! Problem resolving dependencies for net-analyzer/wireshark from @selected
... done!

!!! The ebuild selected to satisfy "net-analyzer/wireshark" has unmet requirements.
- net-analyzer/wireshark-1.10.4::gentoo USE="caps crypt filecaps gtk2 gtk3 ipv6 netlink pcap portaudio qt4 ssl zlib -adns -doc -doc-pdf -geoip -kerberos -libadns -lua (-selinux) -smi"

The following REQUIRED_USE flag constraints are unsatisfied:
at-most-one-of ( gtk2 gtk3 qt4 )

The above constraints are a subset of the following complete expression:
at-most-one-of ( gtk2 gtk3 qt4 ) ssl? ( crypt )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Gentoo-20121221 gentoo #
Back to top
View user's profile Send private message
lexflex
Guru
Guru


Joined: 05 Mar 2006
Posts: 354
Location: the Netherlands

PostPosted: Thu Dec 19, 2013 1:47 pm    Post subject: Re: failed to update the system Reply with quote

chenylex wrote:

!!! The ebuild selected to satisfy "net-analyzer/wireshark" has unmet requirements.
- net-analyzer/wireshark-1.10.4::gentoo USE="caps crypt filecaps gtk2 gtk3 ipv6 netlink pcap portaudio qt4 ssl zlib -adns -doc -doc-pdf -geoip -kerberos -libadns -lua (-selinux) -smi"

The following REQUIRED_USE flag constraints are unsatisfied:
at-most-one-of ( gtk2 gtk3 qt4 )

The above constraints are a subset of the following complete expression:
at-most-one-of ( gtk2 gtk3 qt4 ) ssl? ( crypt )
gentoo #


It appears Wireshark requires you to define "at-most-one" of gtk2 gtk3 or qt4, while in your useflags it it set to install with both gtk2 and gtk3.
So, try to remove one of those from your useflags ( probably in /etc/portage/package.use)

Alex.
Back to top
View user's profile Send private message
chenylex
n00b
n00b


Joined: 19 Dec 2013
Posts: 14

PostPosted: Thu Dec 19, 2013 3:01 pm    Post subject: failed to update the system Reply with quote

Gentoo-20121221 gentoo # emerge --update --deep --with-bdeps=y --newuse @world


!!! /etc/portage/make.profile is not a symlink and will probably prevent most merges.
!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


!!! Your current profile is invalid. If you have just changed your profile
!!! configuration, you should revert back to the previous configuration.
!!! Allowed actions are limited to --help, --info, --search, --sync, and
!!! --version.
Gentoo-20121221 gentoo #
that is wht something about!
i do not know how to do!
Back to top
View user's profile Send private message
szatox
Veteran
Veteran


Joined: 27 Aug 2013
Posts: 1746

PostPosted: Thu Dec 19, 2013 3:35 pm    Post subject: Reply with quote

happens even to me. Usually then I forgot to mount /usr/portage.
just run `emerge --sync` before you update system. And make friends with gentoo handbook, following it prevents you from getting into pitfalls like this
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Thu Dec 19, 2013 3:48 pm    Post subject: Reply with quote

The Installation handbook and other resources in many languages can be found here:
http://www.gentoo.org/doc/en/index.xml
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
chenylex
n00b
n00b


Joined: 19 Dec 2013
Posts: 14

PostPosted: Fri Dec 20, 2013 12:11 am    Post subject: Reply with quote

Gentoo-20121221 gentoo # emerge --update --deep --with-bdeps=y --newuse @world

* IMPORTANT: 10 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies oo

!!! Problem resolving dependencies for media-gfx/blender from @selected
... done!

!!! The ebuild selected to satisfy "media-gfx/blender" has unmet requirements.
- media-gfx/blender-2.69::gentoo USE="boost bullet dds elbeem game-engine nls openexr openmp sdl sse sse2 tiff -collada -colorio -cycles -debug -doc -ffmpeg -fftw -jack -jpeg2k -ndof -openal -player -redcode -sndfile" PYTHON_SINGLE_TARGET="-python3_3" PYTHON_TARGETS="python3_3"

The following REQUIRED_USE flag constraints are unsatisfied:
python_single_target_python3_3

The above constraints are a subset of the following complete expression:
python_single_target_python3_3? ( python_targets_python3_3 ) exactly-one-of ( python_single_target_python3_3 ) player? ( game-engine ) redcode? ( jpeg2k ) cycles? ( boost openexr tiff ) nls? ( boost ) game-engine? ( boost )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Gentoo-20121221 gentoo #
i am sorry i do not know what something it want to tell me!
Back to top
View user's profile Send private message
chenylex
n00b
n00b


Joined: 19 Dec 2013
Posts: 14

PostPosted: Fri Dec 20, 2013 12:14 am    Post subject: failed to update the system Reply with quote

Gentoo-20121221 gentoo # emerge --update --deep --with-bdeps=y --newuse @world

* IMPORTANT: 10 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.

Calculating dependencies oo

!!! Problem resolving dependencies for media-gfx/blender from @selected
... done!

!!! The ebuild selected to satisfy "media-gfx/blender" has unmet requirements.
- media-gfx/blender-2.69::gentoo USE="boost bullet dds elbeem game-engine nls openexr openmp sdl sse sse2 tiff -collada -colorio -cycles -debug -doc -ffmpeg -fftw -jack -jpeg2k -ndof -openal -player -redcode -sndfile" PYTHON_SINGLE_TARGET="-python3_3" PYTHON_TARGETS="python3_3"

The following REQUIRED_USE flag constraints are unsatisfied:
python_single_target_python3_3

The above constraints are a subset of the following complete expression:
python_single_target_python3_3? ( python_targets_python3_3 ) exactly-one-of ( python_single_target_python3_3 ) player? ( game-engine ) redcode? ( jpeg2k ) cycles? ( boost openexr tiff ) nls? ( boost ) game-engine? ( boost )

(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Gentoo-20121221 gentoo #
that is what ! i am so confuse!
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Fri Dec 20, 2013 8:39 am    Post subject: Reply with quote

Blender is somewhat special in its current version, and there already are some threads about that here.

In short: While Python-3.3 is not a default target, blender must be built for it. To do so add the following line to /etc/portage/package.use :
Code:
media-gfx/blender python_single_target_python3_3 python_targets_python3_3


Further: Please, please, please use code-tags if you are posting output from a console!

However, let's dissect your output:
Code:
!!! Problem resolving dependencies for media-gfx/blender from @selected
... done!
Portage can not find out how to emerge blender, because there is a problem with its dependencies.
"from @selected" means, that you have directly chosen to install blender, it is not a dependency to something else.

Code:
!!! The ebuild selected to satisfy "media-gfx/blender" has unmet requirements.
- media-gfx/blender-2.69::gentoo USE="boost bullet dds elbeem game-engine nls openexr openmp sdl sse sse2 tiff -collada -colorio -cycles -debug -doc -ffmpeg -fftw -jack -jpeg2k -ndof -openal -player -redcode -sndfile" PYTHON_SINGLE_TARGET="-python3_3" PYTHON_TARGETS="python3_3"
At least one requirement is not fulfilled. The bottom line shows how you wanted it to be emerged, which is not possible.

Code:
The following REQUIRED_USE flag constraints are unsatisfied:
python_single_target_python3_3
The USE flag python_single_target_python3_3 must be set, but you haven't.

Note: This is a so called "expandable". This means, that the value:

PYTHON_SINGLE_TARGET="-python3_3" (*)
expands to
USE="-python_single_target_python3_3".

And the value
PYTHON_TARGETS="python3_3" (*)
expands to
USE="python_targets_python3_3"

(*) This is not entirely true. The expandable values are either set, or not. So actually
PYTHON_TARGETS="python3_3" expands to
USE="-python_targets_python2_6 -python_targets_python2_7 -python_targets_python3_2 python_targets_python3_3"
Code:
The above constraints are a subset of the following complete expression:
python_single_target_python3_3? ( python_targets_python3_3 ) exactly-one-of ( python_single_target_python3_3 ) player? ( game-engine ) redcode? ( jpeg2k ) cycles? ( boost openexr tiff ) nls? ( boost ) game-engine? ( boost )
This is the full expression in the ebuild that leads to the requirement.

In short (All of them are USE flags!) :
  • python_single_target_python3_3? ( python_targets_python3_3 ) means:
    If python_single_target_python3_3 is set, python_targets_python3_3 must be set, too.
  • exactly-one-of ( python_single_target_python3_3 ) means:
    python_single_target_python3_3 must be set, no alternatives available.
  • player? ( game-engine ) means:
    If player is set, game-engine must be set, too.
  • redcode? ( jpeg2k ) means:
    If redcode is set, jpeg2k must be set, too.
and so on.

Code:
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
These are the reverse dependency.
@world requires @selected (What you chose to emerge), and @selected is where blender comes from.
_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
chenylex
n00b
n00b


Joined: 19 Dec 2013
Posts: 14

PostPosted: Sat Dec 21, 2013 3:02 am    Post subject: how to use the gentoo unstable Reply with quote

now,my gentoo linux can update,but it is not update to the unstable!
i want to use the unstable ,because i like the newest version of software,i know it is not good for my system.
but I really want to do that!
And now how can i do!
Back to top
View user's profile Send private message
Yamakuzure
Advocate
Advocate


Joined: 21 Jun 2006
Posts: 2273
Location: Bardowick, Germany

PostPosted: Sat Dec 21, 2013 10:02 am    Post subject: Reply with quote

"Keyworded" (~x86) does not mean "unstable" automatically. It just means that stability is not confirmed for the respective keyword (x86). Another reason for an otherwise perfectly stable package to remain keyworded is uncertainty in the stability of at least one of its dependencies.

Packages can only be unkeyworded, if all of their dependencies are, too. Otherwise a stabilization of a package with keyworded dependencies would force users to mix software branches. A perfectly fine technique if you really know what you are doing and are apt and ready to keep the pieces.

You can find further information in the documentation about mixing software branches.

But first, to make your life easier with searching and finding packages that might or might not be keyworded, you should try out eix, it is really great:
Code:
 ~ $ eix eix
[I] app-portage/eix
     Available versions:  0.25.5 0.29.3 (~)0.29.6 ~0.30.0 **99999999*l[1] {clang debug +dep doc nls optimization security sqlite strong-optimization strong-security swap-remote tools zsh-completion LINGUAS="de ru"}
     Installed versions:  0.29.6(08:30:51 13.10.2013)(clang dep doc nls optimization sqlite tools -debug -security -strong-optimization -strong-security -swap-remote LINGUAS="de -ru")
     Homepage:            http://eix.berlios.de
     Description:         Search and query ebuilds, portage incl. local settings, ext. overlays, version changes, and more


[1] "mv" /var/lib/layman/mv
But now to the newest blender-2.69: (I need to update myself)
  1. Add the new blender version to package.accept_keywords
    Code:
     ~ # echo "=media-gfx/blender-2.69" >> /etc/portage/package.accept_keywords
  2. Then update blender
    Code:
     ~ # emerge -au blender

    These are the packages that would be merged, in order:

    Calculating dependencies  ....... ...... .... done!
    [ebuild     U ~] media-gfx/blender-2.69 [2.68a] USE="boost bullet collada -colorio cycles dds -debug doc elbeem ffmpeg fftw game-engine -jack jpeg2k -ndof nls openal openexr openmp player -redcode sdl sndfile sse sse2 tiff" PYTHON_SINGLE_TARGET="python3_3" PYTHON_TARGETS="python3_3" 40,308 kB

    Total: 1 package (1 upgrade), Size of downloads: 40,308 kB

    Would you like to merge these packages? [Yes/No]

_________________
Important German:
  1. "Aha" - German reaction to pretend that you are really interested while giving no f*ck.
  2. "Tja" - German reaction to the apocalypse, nuclear war, an alien invasion or no bread in the house.
Back to top
View user's profile Send private message
njcwotx
Guru
Guru


Joined: 25 Feb 2005
Posts: 564
Location: Texas

PostPosted: Fri Jan 17, 2014 6:23 am    Post subject: Reply with quote

the use requirement is only for wireshark. I had same issue, the gtk2 and qt4 were pulled in by my profile. Other packages might use one or both or the other, so instead of removing from profile or make.conf....


Code:

USE="-gtk2" emerge wireshark


putting the USE="-gtk2" in front of emerge only sets (or in this case removes) the flag for that package emerge. NOTE: you might have an issue if you come back later and update world, but I think you can play with package.use and set flags for that package by itself. I rarely have to set package specific use flags, but I think in package.use you can also just set the -gtk2 flag and the rest will be used. Someone might overturn my judgment on this one.


-----
chenylex wrote:
i want to know why!
i use gentoo first time!

For a long time I used Red Hat when I first started to use Linux and I wasn't really learning it fast enough. A uber-nerd summer intern turned me on to Gentoo and said that it was a really good distro to learn hard core Linux. He was right, I learned so much more faster and in about 4 months and several installations I finally started to 'get Linux'. Keep at it. Gentoo is not intended to be an easy install, easy configure, until you have installed it about 4 times, then you start to get the hang of it. Took me a few years to understand some parts of Gentoo, but I love it because it stretches my skillset. Whenever I need a Linux tool in the datacenter that isn't for 'customer' production I use a Gentoo build. For production environments we still use Red Hat for the mainstream support and customer acceptance aspects, but when I need a Linux hammer, I go for the Gentoo box.
_________________
Drinking from the fountain of knowldege.
Sometimes sipping.
Sometimes gulping.
Always thirsting.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum