Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
faied to mount the usb disk!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
chenylex
n00b
n00b


Joined: 19 Dec 2013
Posts: 14

PostPosted: Sun Dec 22, 2013 1:37 pm    Post subject: faied to mount the usb disk! Reply with quote

I found my system cannot automatically identify and mount the USB disk! When I add a hard disk from the USB interface,i must input the command
"mount /dev/sdb1 /mnt" in tne terminal!I feel very cumbersome and helpless!And I also found my system had no voice control , no network settings, no shutdown button or sleep button,All of these functions I must to be completed in the terminal!This system installated by myself, and also i installated first time, there are many something I don't know how to do!Now, I feel a little tired to this system, he is too hard to use!
But I still hope to solve there problem!
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 629
Location: Italy

PostPosted: Sun Dec 22, 2013 5:12 pm    Post subject: Reply with quote

Which desktop environment did you install?
Back to top
View user's profile Send private message
chenylex
n00b
n00b


Joined: 19 Dec 2013
Posts: 14

PostPosted: Mon Dec 23, 2013 12:34 am    Post subject: Reply with quote

the kde desktop which i install !
Back to top
View user's profile Send private message
chenylex
n00b
n00b


Joined: 19 Dec 2013
Posts: 14

PostPosted: Mon Dec 23, 2013 12:35 am    Post subject: Reply with quote

the kde desktop which i install !
Back to top
View user's profile Send private message
fturco
l33t
l33t


Joined: 08 Dec 2010
Posts: 629
Location: Italy

PostPosted: Mon Dec 23, 2013 10:36 am    Post subject: Reply with quote

Did you read the KDE wiki guide?
Back to top
View user's profile Send private message
njcwotx
Guru
Guru


Joined: 25 Feb 2005
Posts: 564
Location: Texas

PostPosted: Fri Jan 17, 2014 7:03 am    Post subject: Reply with quote

Quote:
https://forums.gentoo.org/viewtopic-t-951064-highlight-usb.html
look at this post.

I had a kernel config option to enable SCSI disk support. Since most disks are SATA now and SCSI isn't always enabled you might want to try to enable it and recompile. Also, look at some of the other stuff there. It might also be of help.
_________________
Drinking from the fountain of knowldege.
Sometimes sipping.
Sometimes gulping.
Always thirsting.
Back to top
View user's profile Send private message
ch64
Guru
Guru


Joined: 09 Jun 2010
Posts: 319

PostPosted: Fri Jan 17, 2014 9:42 am    Post subject: Reply with quote

The keyword here is automount
Here are two good guides:

http://wiki.gentoo.org/wiki/AutoFS
https://wiki.gentoo.org/wiki/USB/HOWTO

The first guide is for automount options.
The second guide is to be sure that you understand the usb part and you have well done your configurations.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Jan 17, 2014 4:34 pm    Post subject: Reply with quote

ch64 wrote:
The keyword here is automount
Here are two good guides:

http://wiki.gentoo.org/wiki/AutoFS
https://wiki.gentoo.org/wiki/USB/HOWTO

The first guide is for automount options.
The second guide is to be sure that you understand the usb part and you have well done your configurations.

The first guide is (almost) ridiculously out of date (and quite a bit off-topic), the second says little besides the obvious.
Back to top
View user's profile Send private message
shazeal
Apprentice
Apprentice


Joined: 03 May 2006
Posts: 197
Location: New Zealand

PostPosted: Fri Jan 17, 2014 7:44 pm    Post subject: Re: faied to mount the usb disk! Reply with quote

chenylex wrote:
I found my system cannot automatically identify and mount the USB disk! When I add a hard disk from the USB interface,i must input the command
"mount /dev/sdb1 /mnt" in tne terminal!I feel very cumbersome and helpless!And I also found my system had no voice control , no network settings, no shutdown button or sleep button,All of these functions I must to be completed in the terminal!This system installated by myself, and also i installated first time, there are many something I don't know how to do!Now, I feel a little tired to this system, he is too hard to use!
But I still hope to solve there problem!


Did you select the right profile? As long as you have the USB stuff in the kernel it should "just work tm.". The only USE flags relevant to KDE I added were. "networkmanager semantic-desktop"

Do 'eselect profile list' and make sure "default/linux/amd64/13.0/desktop/kde" or "default/linux/amd64/13.0/desktop/kde/systemd" is selected.
_________________
CFLAGS="-OmgWTFR1CE --fun-lol-loops --march=asmx86go"
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6194

PostPosted: Fri Jan 17, 2014 8:30 pm    Post subject: Reply with quote

For KDE, the component responsible for automount is kde-base/solid.
Check your useflags on kde-base/kdelibs too.
Though, going by some posts, consolekit and systemd are in strong conflict in KDE.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum