Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
I can't boot any boot loader
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
mrfabiolo
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jan 2011
Posts: 88

PostPosted: Sat Dec 28, 2013 8:25 pm    Post subject: I can't boot any boot loader Reply with quote

I've installed several distribution on my laptop.
For example: I installed Slackware 14.1 in /dev/sdb (my SSD) with lilo (without errors) installed in /dev/sdb.
but when I boot my laptop i can't see lilo. My computer seem to do nothing to boot my partition.
I also tried with Gentoo and grub 2. I can't boot my Operative systems...
I tried to format everything in my hard disk (and in my SSD) and install only one Linux Distribution with Grub 2 in my first hard disk (/dev/sda) (without errors). But nothing . . . It seem that my pc can't boot the boot loader. (neither from hard disk nor from SSD).
I tried also with Windows 8.1 (in UEFI mode) and it runs correctly. I can boot only Windows.

I remember that last month I was able to choose the hard drive to start, in my BIOS. I was able to boot only the SSD with its boot loader or I was able to boot only my hard disk with its boot loader (without problems).
I had changed many things for understand how to install Linux in UEFI mode. I think that I changed something, maybe in the BIOS, and now I can't boot any boot loader (except for windows). I would like to reset everything as it was before, but I have also restore the settings in my BIOS, but it doesn't change.
Back to top
View user's profile Send private message
The Doctor
Moderator
Moderator


Joined: 27 Jul 2010
Posts: 2574

PostPosted: Sat Dec 28, 2013 9:35 pm    Post subject: Reply with quote

Secure boot is enabled. You must disable it in bios.
_________________
First things first, but not necessarily in that order.

Apologies if I take a while to respond. I'm currently working on the dematerialization circuit for my blue box.
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 13848

PostPosted: Sat Dec 28, 2013 9:39 pm    Post subject: Reply with quote

Since you have Windows 8 installed, blaming Microsoft's Secure Boot mess is a good place to start. If that is not the problem, then we need to know why you think the computer cannot boot any other operating system. You were quite clear that you cannot, but you said nothing about what happens instead of the expected boot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum