Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
new install, ethernet stopped working (sort of) [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Mon Dec 30, 2013 2:21 am    Post subject: new install, ethernet stopped working (sort of) [SOLVED] Reply with quote

new install on thinkpad t440s; a million little things not quite right
but this is new to me

the intel ethernet adapter worked perfectly from the start (e1000e module).

Now, it times out waiting for ip from dhcpc

If I rmmod / modprobe it then works

Also, if I boot into another linux on usb stick eth0 works perfectly first time
and THEN works ONCE when I start gentoo; restarting gentoo goes back
to the timeout problem

when in the problem situation, ethtool cannot find eth0 at all (after
rmmod / modprobe ethtool reports as normal)

what in the world could have happened to cause such a thing?
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)


Last edited by albright on Tue Dec 31, 2013 1:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Mon Dec 30, 2013 4:11 am    Post subject: Reply with quote

replying to myself :oops:

but it looks like re-emerging dhcpcd somehow fixed
this ... (hasn't done it for a while at least)
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7089
Location: Saint Amant, Acadiana

PostPosted: Mon Dec 30, 2013 4:27 am    Post subject: Reply with quote

Just to make sure ... you do know Gentoo is using predictable network interface names now (which are hard to predict and will change without warning if you move your hardware)?
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
albright
Advocate
Advocate


Joined: 16 Nov 2003
Posts: 2541
Location: Near Toronto

PostPosted: Tue Dec 31, 2013 1:22 pm    Post subject: Reply with quote

I have the use-old-interface-names magic file in udev rules

the computer has been restarted innumerable times since
I reported this and the problem has not occurred again after
I re-emerged dhcpc, so I'll call this solved
_________________
.... there is nothing - absolutely nothing - half so much worth
doing as simply messing about with Linux ...
(apologies to Kenneth Graeme)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum