Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
need help copying music to an ipod touch
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Fri Dec 06, 2013 8:19 am    Post subject: need help copying music to an ipod touch Reply with quote

I've tried this alot and never had any success, I'm using gnome 2.32, udev 200, and gentoo sources 3.10.17

My Primary objective is to copy music to the ipod, I'm using an ipod touch 4G. It would be great if this was done with as little adding the kernel as possible, also the less packages that need to be pulled in the better.

thanks
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6315
Location: /usr/lib64/lv2

PostPosted: Fri Dec 06, 2013 4:06 pm    Post subject: Reply with quote

How do you physically connect the iPod to your computer? USB?
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Fri Dec 06, 2013 5:41 pm    Post subject: Reply with quote

yup I use usb, forgot to mention that :D
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1377

PostPosted: Fri Dec 06, 2013 6:59 pm    Post subject: Reply with quote

media-libs/libmtp-1.1.6-r1
Someone should bug 1.1.6 to be purged away from portage tree.
_________________
fun2gen2
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sat Dec 07, 2013 6:17 pm    Post subject: Reply with quote

I've emerged libmtp and now my ipod mounts.
I've tried using banshee with the ipod but it isn't detected
here are my use flags:
[ebuild R ] media-libs/libgpod-0.8.2 USE="gtk ios mono udev -python -static-libs" 0 kB

[ebuild R ] media-sound/banshee-2.6.1 USE="ipod mtp udev -aac -bpm -cdda -daap -doc -encode -karma {-test} -web -youtube" 0 kB

I'm stuck at this point, don't know if I should try something other than banshee(cause I've tried gtkpod and it never worked) or If I should work on banshee

thanks
Back to top
View user's profile Send private message
audiodef
Watchman
Watchman


Joined: 06 Jul 2005
Posts: 6315
Location: /usr/lib64/lv2

PostPosted: Sun Dec 08, 2013 6:02 pm    Post subject: Reply with quote

Once you mount your iPod, try copying your MP3 files over to it using a terminal (cp command) or your favorite file manager to drag and drop.
_________________
Gentoo Studio: A Gentoo-based, professional digital audio workstation OS.
Back to top
View user's profile Send private message
WvR
Apprentice
Apprentice


Joined: 03 Mar 2011
Posts: 181
Location: Tsuruga, Japan

PostPosted: Sun Dec 08, 2013 11:15 pm    Post subject: Reply with quote

blakdeath: does the iPod show up in the file manager once it is mounted? If so, use
Code:
 user@computer > mount
to find out where the iPod is mounted and set banshee to use that mount point.

audiodef: I didn't know you could just drag & drop files to an iPod. I mean: yes, you can drag and drop, but will those files be "playable"? I thought everything has to go through iTunes (or libgpod on linux)
Back to top
View user's profile Send private message
WvR
Apprentice
Apprentice


Joined: 03 Mar 2011
Posts: 181
Location: Tsuruga, Japan

PostPosted: Sun Dec 08, 2013 11:24 pm    Post subject: Reply with quote

ulenrich wrote:
media-libs/libmtp-1.1.6-r1
Someone should bug 1.1.6 to be purged away from portage tree.

I have a similar problem: https://forums.gentoo.org/viewtopic-t-976790-highlight-ipod.html and I can tell you that libmtp is __NOT__ the problem. I do not have libmtp on my computer, I never had, and the iPod has always worked without it.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Fri Dec 13, 2013 6:15 pm    Post subject: Reply with quote

after updating to gnome 3.8 and systemd, my pc hangs when I ttry to mount the ipod
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Fri Dec 13, 2013 6:27 pm    Post subject: Reply with quote

http://wiki.gentoo.org/wiki/Apple_iPod,_iPad,_iPhone

my ipod is old enough to not require all this noise and ive never gotten ipod touch to work though i only did this right when the iphone libs came out and were ultra buggy.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Fri Dec 13, 2013 7:17 pm    Post subject: Reply with quote

I can mount the ipod again(ran usbmuxd first)
666 I've tried this guide before, and im stuck at pointing gtkpod to the ipod mount point

here's the mount point I got when I tried to play the music on vlc:
afc://6989a35840255b66f8e4aa91ea24c8635a66d44c/

here's mount:
dhcppc0 ~ # mount
/dev/sda1 on / type ext4 (rw,noatime,data=ordered)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
devtmpfs on /dev type devtmpfs (rw,nosuid,size=1976460k,nr_inodes=494115,mode=755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
mqueue on /dev/mqueue type mqueue (rw,relatime)
tmpfs on /tmp type tmpfs (rw)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
dhcppc0 ~ #
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Fri Dec 13, 2013 8:02 pm    Post subject: Reply with quote

rhythmbox can detect the ipod, then it starts scanning at which point 506 songs are detected( i only have 356 on my ipod) and the scanning ends in nothing, no songs are available for import
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Fri Dec 13, 2013 8:31 pm    Post subject: Reply with quote

you might need to enable "ios" use flag and rebuild deep world.
Back to top
View user's profile Send private message
WvR
Apprentice
Apprentice


Joined: 03 Mar 2011
Posts: 181
Location: Tsuruga, Japan

PostPosted: Sat Dec 14, 2013 12:43 am    Post subject: Reply with quote

blakdeath wrote:
here's mount:
dhcppc0 ~ # mount
/dev/sda1 on / type ext4 (rw,noatime,data=ordered)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
devtmpfs on /dev type devtmpfs (rw,nosuid,size=1976460k,nr_inodes=494115,mode=755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620)
tmpfs on /run type tmpfs (rw,nosuid,nodev,mode=755)
tmpfs on /sys/fs/cgroup type tmpfs (rw,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,release_agent=/usr/lib/systemd/systemd-cgroups-agent,name=systemd)
mqueue on /dev/mqueue type mqueue (rw,relatime)
tmpfs on /tmp type tmpfs (rw)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
dhcppc0 ~ #
blakdeth, this list does not seem to have the iPod, unless your iPod is mounted under /dev/sda1, which I doubt. So it seems that the iPod is not mounted.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sat Dec 14, 2013 3:14 pm    Post subject: Reply with quote

@wvr, it is mounted by gvfs under afc://6989a35840255b66f8e4aa91ea24c8635a66d44c/
@666 the only package that will be re emerged is the upower package
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sat Dec 14, 2013 5:11 pm    Post subject: Reply with quote

i was looking through my own system and seen an ios use flag for gvfs. gvfs + ios use flag is what i was suggesting but i guess thats not a problem if its already got it built in.
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Sun Dec 22, 2013 11:22 am    Post subject: Reply with quote

bump
Back to top
View user's profile Send private message
Adel Ahmed
Veteran
Veteran


Joined: 21 Sep 2012
Posts: 1158

PostPosted: Thu Jan 02, 2014 9:46 am    Post subject: Reply with quote

bump
Back to top
View user's profile Send private message
ulenrich
Veteran
Veteran


Joined: 10 Oct 2010
Posts: 1377

PostPosted: Thu Jan 02, 2014 2:17 pm    Post subject: Reply with quote

Hey,
blakdeath wrote:
bump
You want another guess from me: Try with
sys-kernel/linux-headers-3.10
Of course recompile all multimedia. If that fits your needs then:
File a bug sys-kernel/linux-headers-3.10 should be stabilized!
_________________
fun2gen2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum