Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
lm_sensors will not start with systemd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
treeman1111
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2013
Posts: 77

PostPosted: Sun Jan 05, 2014 2:56 am    Post subject: lm_sensors will not start with systemd Reply with quote

I cannot get lm_sensors.service to run with systemd. Here is the output of systemctl status lm_sensors.service -l:
Code:

lm_sensors.service - Initialize hardware monitoring sensors
   Loaded: loaded (/usr/lib64/systemd/system/lm_sensors.service; disabled)
   Active: failed (Result: exit-code) since Sat 2014-01-04 21:48:14 EST; 6min ago
  Process: 2895 ExecStart=/usr/bin/sensors -s (code=exited, status=1/FAILURE)
  Process: 2893 ExecStart=/sbin/modprobe -qab $BUS_MODULES $HWMON_MODULES (code=exited, status=1/FAILURE)
 Main PID: 2895 (code=exited, status=1/FAILURE)

Jan 04 21:48:14 andromeda sensors[2895]: No sensors found!
Jan 04 21:48:14 andromeda systemd[1]: lm_sensors.service: main process exited, code=exited, status=1/FAILURE
Jan 04 21:48:14 andromeda systemd[1]: Failed to start Initialize hardware monitoring sensors.
Jan 04 21:48:14 andromeda systemd[1]: Unit lm_sensors.service entered failed state.


Here is the contents of my /etc/conf.d/lm_sensors file:
Code:

# Generated by sensors-detect on Sat Jan  4 21:41:33 2014
# This file is sourced by /etc/init.d/lm_sensors and defines the modules to
# be loaded/unloaded.
#
# The format of this file is a shell script that simply defines variables:
# HWMON_MODULES for hardware monitoring driver modules, and optionally
# BUS_MODULES for any required bus driver module (for example for I2C or SPI).

# Load modules at startup
LOADMODULES=yes

# Initialize sensors at startup
INITSENSORS=yes

HWMON_MODULES="fam15h_power it87 k10temp"

# For compatibility reasons, modules are also listed individually as variables
#    MODULE_0, MODULE_1, MODULE_2, etc.
# Please note that the numbers in MODULE_X must start at 0 and increase in
# steps of 1. Any number that is missing will make the init script skip the
# rest of the modules. Use MODULE_X_ARGS for arguments.
#
# You should use BUS_MODULES and HWMON_MODULES instead if possible.

#MODULE_0=fam15h_power
#MODULE_1=it87
#MODULE_2=k10temp
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sun Jan 05, 2014 2:58 am    Post subject: Reply with quote

did you run systemctl enable lm_sensors before systemctl start lm_sensors?
Back to top
View user's profile Send private message
treeman1111
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2013
Posts: 77

PostPosted: Sun Jan 05, 2014 3:31 am    Post subject: Reply with quote

I think I have found the issue - one of the modules was not built into my kernel.
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1248
Location: 42.68n 85.41w

PostPosted: Sun Jan 05, 2014 3:56 am    Post subject: Reply with quote

indeed lm_sensors is not an easy package to deal with.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum