Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] How to stop all internal drives from automounting?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1598
Location: U.S.A.

PostPosted: Tue Jan 07, 2014 11:08 pm    Post subject: [SOLVED] How to stop all internal drives from automounting? Reply with quote

Fix in 2nd post.

I don't want all my internal drives mounted at boot. But can't seem to stop it. The problem is that I have 10 internal partitions that I don't want the system to automount at boot. Only when I click on the icon. Is there a way to stop this? It seems to be totally ignoring the 'noauto' in /etc/fstab.

Only found one thing that seemed to be help and that didn't work either. http://wiki.bluelightav.org/display/BLUE/How+to+prevent+udisks2+automatically+mounting+a+device
It said to do this in /etc/udev/rules.d/99-local-udisks.rules
Code:
SUBSYSTEM=="block", KERNEL=="sd*", ENV{ID_FS_UUID}=="02a736f1-e1cf-4bbc-8be9-250bbe9491fe", ENV{UDISKS_PRESENTATION_HIDE}:="1"


Here is my log entries:
Quote:
Jan 7 16:26:47 decibels udisksd[2590]: Mounted /dev/sdc1 (system) at /mnt/windows7 on behalf of uid 1000
Jan 7 16:26:47 decibels udisksd[2590]: Mounted /dev/sda1 (system) at /boot on behalf of uid 1000
.......


Also I have checked in KDE/System Settings/Removable Devices and none of the attached devices are checked to automount on login or when attached.

Almost everything I find is about usb disks or cdroms,... I just want it to either: stop ignoring my fstab noauto option or find a way to stop this behavior.

I saw something about udisks-glue, but haven't tried it yet. Hope don't need it cause it won't compile.
emerge:
Code:
main.c:171:5: error: ‘g_type_init’ is deprecated (declared at /usr/include/glib-2.0/gobject/gtype.h:669) [-Werror=deprecated-declarations]
cc1: all warnings being treated as errors
make[2]: *** [udisks_glue-main.o] Error 1


If anyone has a clue please post.
_________________
Support bacteria – they’re the only culture some people have.”

– Steven Wright


Last edited by Decibels on Thu Jan 09, 2014 2:02 am; edited 2 times in total
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1598
Location: U.S.A.

PostPosted: Wed Jan 08, 2014 2:28 am    Post subject: Reply with quote

The problem was with KDE settings. System Settings / Removable Devices / Mount all removable media at login

I had that checked.

1) While searching for a fix, I ran across a discussion that said sata drives either weren't or shouldn't be considered removable media. Can't remember.
2) I never considered sata drives removable media, even though I knew I could hot swap them.

Anywho, my noauto option in /etc/fstab is now being honored. Only the drives I want mounted at login are mounted.
_________________
Support bacteria – they’re the only culture some people have.”

– Steven Wright
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum