Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Strange issue with Gambas - privilege related?
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
Clad in Sky

Joined: 04 May 2007
Posts: 852
Location: Germany

PostPosted: Thu Jan 16, 2014 4:08 pm    Post subject: [solved]Strange issue with Gambas - privilege related? Reply with quote


I wanted to try out Gambas. Since ebuilds are long gone from portage, I installed it from source. Compilation went well, as with previous installs I have done.
But I've got a strange problem that is probably related to user privileges - but even then it is strange.

After compiling and make install I can start the IDE from terminal with "gambas3" and it starts up correctly. I can create new projects or open one of the example files. Here's the first strange thing: Whenever I do this, I get the message that the file already seems to be opened and that it'll therefore be read-only.
This has been the case with previous installs as well; however, another strange thing is that I can't run the code, which worked before. Or rather, the code seems to be running, but there's no visible result.
Now the strangeness continues. When I start gambas3 from a terminal after su-ing, it starts up just fine and code can be run and example files opened without the warning about read-only.
But wait, there is more strangeness to come: Since starting the programme after su-ing worked, I logged into XFCE as root, made a launcher, execute the launcher and lo and behold, the same issue. And even weirder, opening a terminal as root and running gambas does NOT work. I really don't understand this.

So, does anyone have any idea what might cause this?
I'm not sure what kind of info might be relevant, so please specify.

Architecture: AMD64

Also, since there is no ebuild for gambas, I'd like to try and write one. Any suggestions on how to get started?

Solved by compiling from SVN. I still don't know what the cause really was.
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum