Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
"drivers/video/console/fbcondecor.o' failed"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Tue Jan 21, 2014 4:34 pm    Post subject: "drivers/video/console/fbcondecor.o' failed" Reply with quote

Hi guys!
When trying to compile gentoo-sources-3.13.0, I get the following error.
I did an "make oldconfig" as always, so I wonder why exactly does it fail?
Code:

drivers/video/console/fbcon.c: In function 'fbcon_clear_margins':
drivers/video/console/fbcon.c:1319:20: warning: unused variable 'ops' [-Wunused-variable]
  struct fbcon_ops *ops = info->fbcon_par;
                    ^
  CC      drivers/video/console/softcursor.o
  CC      drivers/video/cfbfillrect.o
  LD      drivers/video/backlight/built-in.o
  CC      drivers/video/cfbcopyarea.o
  CC      drivers/video/cfbimgblt.o
  CC      drivers/video/vesafb.o
  CC      drivers/video/console/fbcondecor.o
  CC      drivers/video/output.o
  CC      drivers/video/console/cfbcondecor.o
  LD      drivers/video/fb.o
drivers/video/console/fbcondecor.c:511:6: error: function declaration isn't a prototype [-Werror=strict-prototypes]
 void fbcon_decor_reset()
      ^
cc1: some warnings being treated as errors
scripts/Makefile.build:308: recipe for target 'drivers/video/console/fbcondecor.o' failed
make[3]: *** [drivers/video/console/fbcondecor.o] Error 1
make[3]: *** Waiting for unfinished jobs....
scripts/Makefile.build:455: recipe for target 'drivers/video/console' failed
make[2]: *** [drivers/video/console] Error 2
scripts/Makefile.build:455: recipe for target 'drivers/video' failed
make[1]: *** [drivers/video] Error 2
Makefile:816: recipe for target 'drivers' failed
make: *** [drivers] Error 2

_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
neph
n00b
n00b


Joined: 31 Jul 2010
Posts: 19

PostPosted: Tue Jan 21, 2014 4:45 pm    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-982018.html
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Tue Jan 21, 2014 4:48 pm    Post subject: Reply with quote

Ahh, so it means waiting and resync?!
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
neph
n00b
n00b


Joined: 31 Jul 2010
Posts: 19

PostPosted: Tue Jan 21, 2014 4:55 pm    Post subject: Reply with quote

I am not quite sure...

Its strange a bit, cause its not extravagant to compile with [-Werror=strict-prototypes].. So whether the kernel-source was not strict enough at anytime before and this was fixed by the patch-set on gentoo-sources in generally, which may be missed in this release somehow, or i don't know at all... :-/

so... i guess – patch it at your own or wait..

The question which i might take is -> Should this be filed as a build-bug?
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Tue Jan 21, 2014 5:28 pm    Post subject: Reply with quote

For what I can see at Bugzilla, there hasn't been a report yet.
I think I will just wait for the .1 release probably.
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
neph
n00b
n00b


Joined: 31 Jul 2010
Posts: 19

PostPosted: Tue Jan 21, 2014 6:38 pm    Post subject: Reply with quote

http://www.mpagano.com/blog/?p=184
Back to top
View user's profile Send private message
Martux
Veteran
Veteran


Joined: 04 Feb 2005
Posts: 1917

PostPosted: Tue Jan 21, 2014 9:06 pm    Post subject: Reply with quote

Nice, thanks! It works now.
What's strange: even the nvidia-drivers compile well, I get "failed to load module nvidia" at boot time.
_________________
"Coincidence is God's way of remaining anonymous."
Albert Einstein
"The road to success is always under construction"
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum