Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No bluetooth w/ hcitool on Thinkpad but rfkill says it is on
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
thender
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 125

PostPosted: Thu Jan 23, 2014 8:13 am    Post subject: No bluetooth w/ hcitool on Thinkpad but rfkill says it is on Reply with quote

I've gotten everything else on my Lenovo Thinkpad T520 to work without a hitch. Bluetooth is the last frontier.

Is it on?

Seems to be.

Code:
# rfkill list
0: phy0: Wireless LAN
   Soft blocked: no
   Hard blocked: no
1: phy1: Wireless LAN
   Soft blocked: no
   Hard blocked: no
2: tpacpi_bluetooth_sw: Bluetooth
   Soft blocked: no
   Hard blocked: no
3: phy2: Wireless LAN
   Soft blocked: no
   Hard blocked: no


Code:
# cat /proc/acpi/ibm/bluetooth
status:      enabled
commands:   enable, disable


Is it compiled into the kernel?

It seems to be from my kernel .config http://bpaste.net/show/171204/

dmesg even seems to acknowledge it as existing & working without issue here http://bpaste.net/show/171224/

So what am I doing wrong?

Code:
localhost ~ # hcitool dev
Devices:
localhost ~ #


:(
Back to top
View user's profile Send private message
thender
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 125

PostPosted: Thu Jan 23, 2014 9:43 pm    Post subject: Reply with quote

If it's any hint, when I plug a USB flash drive in and go fdisk -l, I do not see it.
Back to top
View user's profile Send private message
thender
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 125

PostPosted: Fri Jan 24, 2014 6:06 am    Post subject: Reply with quote

Awesome, I fixed it.

In the spirit of helping someone else out who is losing their mind.

This is the kernel version.

Code:

# uname -a
Linux localhost 3.10.25-gentoo #2 SMP Fri Jan 24 00:54:53 EST 2014 x86_64 Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz GenuineIntel GNU/Linux



This is the .config file. After I got it to work, wifi wasn't working, so I went a little nuts in the networking & device drivers/networking section, so it's kinda bloated, but it does work perfectly for a T520.


http://bpaste.net/show/171547/
Back to top
View user's profile Send private message
thender
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 125

PostPosted: Fri Feb 07, 2014 3:57 am    Post subject: Reply with quote

so I emerge -e world and now I have no bluetooth again. Same kernel.. what else can I try? blueman hangs indefinitely, rfkill list shows nothing disabled. This is on the exact same kernel that worked before. I'm stumped.
Back to top
View user's profile Send private message
thender
Tux's lil' helper
Tux's lil' helper


Joined: 26 Aug 2013
Posts: 125

PostPosted: Wed Jun 18, 2014 4:12 am    Post subject: Reply with quote

The same thing happens on a t440p sporadically. rfkill shows nothing blocked, but hcitool dev shows no devices. This is interesting.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum