Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dracut-034 tries to decrypt 2nd HDD
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Thu Jan 23, 2014 7:11 pm    Post subject: Dracut-034 tries to decrypt 2nd HDD Reply with quote

Hello,
I've a system with two encrypted HDDs. The first contains the rootfs, the second contains my home directory and will be decrypted during boot process by systemd via key file. This configuration worked fine until I had to update to dracut-034-r4. Now dracut builds an image which want's *also* decrypt the 2nd HDD via pass phrase.

Does someone know how I can prevent dracut to try to decrypt the 2nd HDD?
Back to top
View user's profile Send private message
schorsch_76
Guru
Guru


Joined: 19 Jun 2012
Posts: 450

PostPosted: Fri Jan 24, 2014 7:46 am    Post subject: Reply with quote

Just give dracut the id of your needed luks device. You probably have rd.luks.auto=1.

See the dracut wiki page http://wiki.gentoo.org/wiki/Dracut and http://man7.org/linux/man-pages/man7/dracut.cmdline.7.html
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Fri Jan 24, 2014 5:20 pm    Post subject: Reply with quote

I'd never append 'rd.luks.auto=1' to my command line.
I've tried your suggestions. Nothing works, the initramfs script tries to open the 2nd HDD even with 'rd.luks.uuid' in command line.
Back to top
View user's profile Send private message
schorsch_76
Guru
Guru


Joined: 19 Jun 2012
Posts: 450

PostPosted: Fri Jan 24, 2014 7:53 pm    Post subject: Reply with quote

add the line with your luks uuid to the cmdline.

rd.luks.uuid=05f6359d-643e.....

blkid /dev/yourroot
Back to top
View user's profile Send private message
renegart
Tux's lil' helper
Tux's lil' helper


Joined: 30 Oct 2012
Posts: 122

PostPosted: Fri Jan 24, 2014 7:55 pm    Post subject: Reply with quote

schorsch_76 wrote:
add the line with your luks uuid to the cmdline.

rd.luks.uuid=05f6359d-643e.....

blkid /dev/yourroot


As I tried to in the last post. This parameter seems to be ignored.
Back to top
View user's profile Send private message
schorsch_76
Guru
Guru


Joined: 19 Jun 2012
Posts: 450

PostPosted: Fri Jan 24, 2014 8:00 pm    Post subject: Reply with quote

My kernel cmd line is

Code:
GRUB_CMDLINE_LINUX="vconsole.keymap=de-latin1-nodeadkeys vconsole.locale.LANG=de_DE.UTF-8 net.ifnames=0 rd.auto=1 rd.luks=1 rd.lvm=1 rd.luks.uuid=05f6359d-...."


I have a luks device on my internal hdd and one on a exteral hdd. Like your setup.

Edit: the blkid needs to be the device of your luks device.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum