Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] docbook-xml-dtd-4.5 fails to emerge
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Installing Gentoo
View previous topic :: View next topic  
Author Message
zhMFe3
n00b
n00b


Joined: 24 Jan 2014
Posts: 11
Location: Germany

PostPosted: Fri Jan 24, 2014 4:21 pm    Post subject: [Solved] docbook-xml-dtd-4.5 fails to emerge Reply with quote

Hi everyone,

Ok, so this -i-s- was bugging me:

Problem
cannot install
Code:
app-text/docbook-xml-dtd-4.5-r1
which is a dependency of
Code:
dracut-034-r4
(which is apparently needed for a btrfs boot).

Keywords
GPT btrfs multidevice-rootfs raid1 grub2 dracut

Background
I am doing a fresh gentoo install. But lots of things have changed since i did it last time and I decided to try btrfs with -d raid1 -m raid1 for all partitions (GPT partitions that is), i.e. /boot and /. I want to postpone another reinstall for as long as possible (since it takes so much time)

I do want btrfs with its raid1 feature, now that i know about it ;-)

Otherwise I did everything by the Handbook. I used grub2, installed genkernel for it's initramfs and of course activated btrfs support in the kernel (gentoo-sources-3.10.25) as well as installed btrfsprogs. However, my initial reboot failed withe the error message:
Code:

error: no such device: root.
Loading Linux 3.10.25-gentoo ...
Loading initial ramdisk ...

Press any key to continue ...

or similar; since this is all concerning the installation process, It is hard to copy-paste things, and this is during grub2 boot anyway, so even harder to copy; my apologies, if that is not verbatim.
(any key does not continue anything)

So i decided to install dracut with its btrfs module and see what happens (people reported, that it works for them).
However,
Code:
emerge app-text/docbook-xml-dtd-4.5-r1
hangs indefinitely without an error message.

related bugreport
https://bugzilla.redhat.com/show_bug.cgi?id=890955
this error does occur when i do
Code:
grub2-mkconfig -o /boot/grub/grub.cfg


motivation related forum posts
https://forums.gentoo.org/viewtopic-t-975858-highlight-btrfs+root+grub2.html
https://forums.gentoo.org/viewtopic-t-923554-highlight-btrfs+root+grub2.html
https://forums.gentoo.org/viewtopic-t-909416-highlight-btrfs+root+grub2.html
*this is all about btrfs not docbook.

Additional Information
I think, that my fstab is reasonable for an initial boot, although i do not use partition UUIDs. But i do use the
Code:
device=/dev/sdc2,device=/dev/sdd2
options.
I will extract my fstab and show you if anyone thinks that it is important. But this is all background information/motivation.

update: tried UUIDs for filesystems (1st column) in /etc/fstab and PARTUUIDs for devices in btrfs options for fstab option column; same result.

My problem is that the emerge of docbook-xml-dtd-4.5 hangs (4.4 emerges alright). This is weird, because no related error is reported anywhere, including

  • /var/log/emerge.log
  • /var/log/emerge-fetch.log
  • /var/log/portage/elog/summary.log


Any insight is appreciated. (into docbook-xml-dtd and btrfs/grub2)

Issue resolved itself
apparently the laptop needed some time off on the weekend.
When I did the emerge this morning (without changing anything, but booted minimal-livecd for the fourth time to do it), it worked.

I also installed the latest unstable grub-2.02 and the error during grub2-mkconf was gone. dracut did not help the boot procedure though. All i see now is
Code:

Loading Linux 3.10.25-gentoo ...
Loading initial ramdisk ...


But strangely: i am doing a fresh install on a different laptop, a Thinkpad T61 and there i did nothing, that deviates from the handbook. Again i chose GPT partitioning and grub2, but ext2 for /boot and ext4 for /
The above (not proceeding past «Loading initial ramdisk ...») happens there as well.

kind regards
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Installing Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum