Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201401-19 ] GMime: Arbitrary code execution
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Advocate
Advocate


Joined: 12 May 2004
Posts: 2226

PostPosted: Sat Jan 25, 2014 4:15 am    Post subject: [ GLSA 201401-19 ] GMime: Arbitrary code execution Reply with quote

Gentoo Linux Security Advisory

Title: GMime: Arbitrary code execution (GLSA 201401-19)
Severity: normal
Exploitable: local, remote
Date: January 21, 2014
Bug(s): #308051
ID: 201401-19

Synopsis

A buffer overflow error in GMime might allow remote attackers to
execute arbitrary code or cause a Denial of Service condition.


Background

GMime is a C/C++ library which may be used for the creation and parsing
of messages using the Multipurpose Internet Mail Extension (MIME).


Affected Packages

Package: dev-libs/gmime
Vulnerable: < 2.4.15
Unaffected: >= 2.4.15
Unaffected: >= 2.4.17 < 2.4.18
Unaffected: >= 2.2.26 < 2.2.27
Architectures: All supported architectures


Description

GMime contains a buffer overflow flaw in the GMIME_UUENCODE_LEN macro in
gmime/gmime-encodings.h.


Impact

A context-dependent attacker could possibly execute arbitrary code or
cause a Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

GMime 2.4.x users on the PPC64 architecture should upgrade to the latest
version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/gmime-2.4.17"
   
GMime 2.4.x users on other architectures should upgrade to the latest
version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/gmime-2.4.15"
   
GMime 2.2.x users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/gmime-2.2.26"
   
Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying some of these packages.


References


CVE-2010-0409
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum